Bug 106556 - Add functionality that highlights all directly formatted text
Summary: Add functionality that highlights all directly formatted text
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.6.0 target:24.2.0 target:7.6...
Keywords:
: 88058 120611 (view as bug list)
Depends on:
Blocks: UNO-Command-New Formatting-Mark Writer-Enhancements
  Show dependency treegraph
 
Reported: 2017-03-15 18:49 UTC by Roman Kuznetsov
Modified: 2023-07-01 09:59 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
Quick Mock-up (52.86 KB, image/png)
2017-03-17 12:15 UTC, RGB
Details
Word - Show Direct Formatting Guides (515.69 KB, image/png)
2017-03-17 23:57 UTC, LibreTraining
Details
Adobe InDesign - Find - Select Direct Formatting Characteristics (250.36 KB, image/png)
2017-03-18 00:04 UTC, LibreTraining
Details
Adobe InDesign - Replace - Select Character Style (249.94 KB, image/png)
2017-03-18 00:06 UTC, LibreTraining
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2017-03-15 18:49:03 UTC
Description:
Adding highlighting of manual formatting to make it easier look place, that can spoil view of document

Steps to Reproduce:
no steps, it is enhancenment

Actual Results:  
no highlighting of manual formatting

Expected Results:
highlighting of manual formatting


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Comment 1 Buovjaga 2017-03-16 10:04:42 UTC
How would this feature function?

Maybe draw a sketch or something.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 Roman Kuznetsov 2017-03-16 11:14:11 UTC
(In reply to Buovjaga from comment #1)
> How would this feature function?
> 
> Maybe draw a sketch or something.

just highlighting by any color, that defined user, for example violet.

and need new option for activate this features

https://i.imgur.com/q7bIukZ.png
Comment 3 Buovjaga 2017-03-16 11:20:21 UTC
(In reply to kompilainenn from comment #2)
> and need new option for activate this features

Yes, this is what I am interested in. Please describe what you have in mind. I knew what highlighting looks like, but not what the function would look like to do it.
Comment 4 Buovjaga 2017-03-16 11:20:55 UTC
Or do you mean some menu entry "Highlight direct formatting"?
Comment 5 Buovjaga 2017-03-16 11:22:06 UTC
What if there was an option in Find & replace to define "any direct formatted text"? Then "Find all" would show them to you highlighted.
Comment 6 Roman Kuznetsov 2017-03-16 11:29:51 UTC
(In reply to Buovjaga from comment #4)
> Or do you mean some menu entry "Highlight direct formatting"?

yes
Comment 7 Roman Kuznetsov 2017-03-16 11:33:27 UTC
(In reply to Buovjaga from comment #5)
> What if there was an option in Find & replace to define "any direct
> formatted text"? Then "Find all" would show them to you highlighted.

no, it's bad idea, because i will delete manual formatting from one place, and all other place with manual formatting loses highlighting. need find it again

A individual function is better, IMHO
Comment 8 Buovjaga 2017-03-16 11:38:16 UTC
Let's throw this to the UX lions, then.
Comment 9 RGB 2017-03-17 12:15:04 UTC
Created attachment 131962 [details]
Quick Mock-up

While I agree that a way to show where direct formatting is is highly desirable, in my opinion the use of highlighting for that task is not a good idea because that automated highlighting will be easily confused with a real document formatting. Any system used to indicate where direct formatting is applied must be easily recognizable. See attached image for an idea.
Comment 10 Heiko Tietze 2017-03-17 16:17:46 UTC
I would go with the search approach. When highlighting the reference is not an option we could show the results in a sidebar deck as requested in bug 95405. See also bug 88489 for the enhancement request to highlight all results and bug 34390 about searching for styles.
Comment 11 LibreTraining 2017-03-17 23:57:08 UTC
Created attachment 131974 [details]
Word - Show Direct Formatting Guides

Word has a checkbox in the style sidebar to turn-on visual guides to show direct formatting.

The directly formatted text is highlighted with a light blue background and a darker blue outline. 

This is an extreme example to show what a formatting soup can look like.
Comment 12 LibreTraining 2017-03-18 00:04:21 UTC
Created attachment 131975 [details]
Adobe InDesign - Find - Select Direct Formatting Characteristics

After importing some Word-soup into InDesign you may want to convert these directly formatted pieces of text into character styles.

So you Find the characteristics, and Replace with a Character Style.

This is the dialog to select the characteristics to Find:
 - Font Family
 - Font Style
 - Size
 - etc.
Comment 13 LibreTraining 2017-03-18 00:06:20 UTC
Created attachment 131976 [details]
Adobe InDesign - Replace - Select Character Style

This is the InDesign dialog to select the Character Style for the replacement.
Comment 14 Buovjaga 2017-03-18 17:38:43 UTC
LibreTraining: nice research. Would you like to join the design team?
Comment 15 LibreTraining 2017-03-20 20:11:39 UTC
(In reply to Buovjaga from comment #14)
> LibreTraining: nice research. Would you like to join the design team?

Probably.
What is required?
Comment 16 Heiko Tietze 2017-03-20 20:19:14 UTC
(In reply to LibreTraining from comment #15)
> (In reply to Buovjaga from comment #14)
> > LibreTraining: nice research. Would you like to join the design team?
> 
> Probably.
> What is required?

All you ever wanted to know about the design team: https://wiki.documentfoundation.org/Design. We meet on Thursday 11am/UTC (12:00 Berlin time). Mailing list, not heavily used, is design at global dot libreoffice dot org. And of course: you are very welcome.
Comment 17 Yousuf Philips (jay) (retired) 2017-05-21 01:22:22 UTC
I think the highlighting option would be the best options and it could be integrated into formatting marks or separately, so a user could easily toggle it on and off, as shown in RGB's mockup (attachment 131962 [details]) and Mac Word (attachment 131974 [details]).

https://support.office.com/en-us/article/See-where-styles-are-applied-in-a-document-8896A7FF-4BA7-4D08-9516-B12E8F62F55B
Comment 18 Thomas Lendo 2018-10-15 19:24:26 UTC
*** Bug 120611 has been marked as a duplicate of this bug. ***
Comment 19 Timur 2019-01-03 09:15:29 UTC
*** Bug 88058 has been marked as a duplicate of this bug. ***
Comment 20 Timur 2021-02-21 18:50:07 UTC
Would be convenient if it worked in Style Inspector.
Comment 21 Heiko Tietze 2022-05-19 09:02:04 UTC
DF is covered in the Styles Highlighter proposal discussed on bug 38194. Whether via this complete solution or some special option, clear feedback about DF is crucial for well-styled documents. Removing UX keyword.
Comment 22 Commit Notification 2023-04-25 17:44:26 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4bc86f6477c3ed5f0e97b0a530acf7e102b613b3

tdf#38194 tdf#106556 Enhancement to highlight direct formatting,

It will be available in 7.6.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 V Stuart Foote 2023-04-28 17:31:51 UTC
So https://gerrit.libreoffice.org/c/core/+/150451 has landed in nightlys against 7.6.0 -- kind of feels necessary for the "Spotlight Character Direct Formatting" widget to be added to the main Format menu, adjacent to the "Clear Direct Formatting" by default.

Users can customize the Menu or a TB to add it now, but that spot on the Format menu seems natural.
Comment 24 Heiko Tietze 2023-05-03 05:55:43 UTC
Thanks Jim!
Comment 25 NC Dia-Schneebeli 2023-06-23 19:01:57 UTC
hello there, 

I am part of the documentation team and would really appreciate it if someone could give me a hand. 

I am currently working on the Styles Spotlight Help page and I am facing issues with enabling the direct formatting (DF) toggle.

I tried to enable to toggle in both the 7.6 version and the latest daily build version, but I am still struggling and I would really appreciate some help!

Any suggestions? Thank you!

Best
NC

(P.S. I suspect this isn't the place to ask such questions but thought I would give it a try! please feel free to redirect me to the correct place if needed. I also posted the same here: https://community.documentfoundation.org/t/direct-formatting-toggle-question/9501)
Comment 26 V Stuart Foote 2023-06-23 19:24:56 UTC
(In reply to NC Dia-Schneebeli from comment #25)

The toggle UNO action does not yet have an icon associated nor does it appear on either the standard Toolbar (where author Jim Raykowski demonstrated the command with a scratch “DF” icon) or on one of the menus.

You have to go Tools → Customize and select to UI element to modify. E.g. Menu → Format or Toolbar → Standard and then search the left column for the " Spotlight Character Direct Formatting" string. And add it with the arrow to the target element on the right side. It will attach at the bottom, so it will need to be moved upward to the place you want it.

The same command can be customized to multiple locations – Menu , Toolbar, Context menu even Keyboard. It just doesn’t have an Icon associated, and its text label is a little long for Toolbar use.
Comment 27 V Stuart Foote 2023-06-23 19:38:17 UTC
@Heiko, do you have cycles to push the UNO control onto the Format menu as in comment 23 for discoverability.  Don't think we want it on the Standard toolbar without icon and button handling.
Comment 28 V Stuart Foote 2023-06-27 14:02:26 UTC
(In reply to V Stuart Foote from comment #26)
> (In reply to NC Dia-Schneebeli from comment #25)
> 

@NC applying:

https://gerrit.libreoffice.org/c/core/+/153641 (24.2.0)
https://gerrit.libreoffice.org/c/core/+/153661 (7.6.0)

You'll have something to write up now.
Comment 29 Commit Notification 2023-06-28 08:11:24 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f1b0aca6bf520626d3c9a1fac67cd2de2c10c78c

Related tdf#106556 - Spotlight DF on the main menu

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Commit Notification 2023-06-28 08:12:28 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-7-6":

https://git.libreoffice.org/core/commit/c2b5ef0ea307203131fa2718984dd7b96e61e4d9

Related tdf#106556 - Spotlight DF on the main menu

It will be available in 7.6.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 Heiko Tietze 2023-06-28 09:23:08 UTC
I wonder if we shouldn't better have a menu entry "Spotlight" with the sub-items "Direct Character Formatting, Paragraph Style, Character Style". Makes it easier to translate and provides alternative access to the other options via the main menu.
Comment 32 V Stuart Foote 2023-06-28 21:38:23 UTC
(In reply to Heiko Tietze from comment #31)
> I wonder if we shouldn't better have a menu entry "Spotlight" with the
> sub-items "Direct Character Formatting, Paragraph Style, Character Style".
> Makes it easier to translate and provides alternative access to the other
> options via the main menu.

But those are styling, not DF. And the Style controls now are limited to the SB Styles deck [1]. Would need UNO implemented to highlight the Paragraph Style and the Character Style control?

NTL agree that "Spotlight" hinting from the Format menu--for either DF or Applied Styles--would be a logical grouping to place on the Format menu. Selecting the styling Spotlight would need to toggle the appropriate SB Styles deck active, as that is needed to show the coded legend of the style types.  What happens in UI now in SB when the 'Spotlight' checkbox is enabled.

Same UNO could be worked into MUFFIN NB flavors.

=-ref-=
[1]  control now is just a SB Styles deck widget, object class="GtkCheckButton" id="highlightstyles" would need UNO control for them to be added to standard Formatting menu. Or TB or NB.