Bug 106569 - FILEOPEN DOCX: EMF logo text appears to be a lot thicker than in Word (default rendering only)
Summary: FILEOPEN DOCX: EMF logo text appears to be a lot thicker than in Word (defaul...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:emf, notBibisectable, regression
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2017-03-16 12:29 UTC by Gabor Kelemen
Modified: 2017-08-30 18:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The document containing the logo (211.60 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-03-16 12:29 UTC, Gabor Kelemen
Details
The document in LO 5.3 and Word 2010 side by side (336.39 KB, image/png)
2017-03-16 12:32 UTC, Gabor Kelemen
Details
The image extracted from the docx file (507.79 KB, image/x-emf)
2017-03-16 12:36 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-03-16 12:29:57 UTC
Created attachment 131927 [details]
The document containing the logo

Attached company form contains a text logo in EMF format, which appears with a lot thicker, barely legible font in LO 5.3 on Win 7 and also in 5.2.3 on Win 8.1.

It is interesting that I could not reproduce the problem on Ubuntu 14.04 with LO 5.3.
Comment 1 Gabor Kelemen 2017-03-16 12:32:14 UTC
Created attachment 131928 [details]
The document in LO 5.3 and Word 2010 side by side
Comment 2 Gabor Kelemen 2017-03-16 12:36:20 UTC
Created attachment 131929 [details]
The image extracted from the docx file
Comment 3 Xisco Faulí 2017-03-16 16:28:07 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: d3b5bd4a07a619db6bee1c39c32280ac3c620532
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Aron Budea 2017-03-16 19:30:03 UTC
Reproduced with 5.3.0.3 / Windows 7, but only with default rendering, and not on Ubuntu 16.04, either.
Comment 5 Gabor Kelemen 2017-03-17 08:37:53 UTC
I have turned on GL support and it appears like in Word on the same machine.
We can say this is a workaround for now :). 
But it would be nice to fix the default renderer too, just in case.
Comment 6 Aron Budea 2017-03-25 19:00:05 UTC
Looks bad in 4.1.0.4, looks good in 4.0.0.3.
=> regression, but it's older than Windows bibisect repos, so not bibisectable
Comment 7 Timur 2017-08-24 18:15:56 UTC
Looks fine to me now with https://cgit.freedesktop.org/libreoffice/core/commit/?id=ebc11ae0b132eefd3b1b1a837a8d0ad3ba73b460.
Please confirm.
Comment 8 Xisco Faulí 2017-08-30 18:23:51 UTC
looks good in 

Version: 6.0.0.0.alpha0+
Build ID: 78960ad06faca055a6d97afbc764c902d5d07f6f
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-08-30_06:31:19
Locale: es-ES (es_ES); Calc: group