Bug Hunting Session
Bug 106584 - Figure/Table references disappear when exporting to Word (docx)
Summary: Figure/Table references disappear when exporting to Word (docx)
Status: RESOLVED DUPLICATE of bug 42346
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
: 106745 (view as bug list)
Depends on:
Blocks: DOCX Fields-Cross-Reference
  Show dependency treegraph
 
Reported: 2017-03-17 02:24 UTC by john
Modified: 2019-04-13 10:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example document to demonstrate the bug (18.97 KB, application/vnd.oasis.opendocument.text)
2017-03-17 02:25 UTC, john
Details
screenshot from Word (37.98 KB, image/png)
2017-03-17 02:25 UTC, john
Details
also showing a problem with Equation references. (28.09 KB, application/vnd.oasis.opendocument.text)
2017-03-17 02:52 UTC, john
Details
equation reference converted to from "Eq 1" to "Eq Text" (46.06 KB, image/png)
2017-03-17 02:55 UTC, john
Details

Note You need to log in before you can comment on or make changes to this bug.
Description john 2017-03-17 02:24:56 UTC
Description:
When exporting a .odt document to Word (docx) format, cross-references to Figures and Tables disappear. Text like "Figure 1" (odt) is converted to " Figure" (docx, note the missing space and number after 'Figure', and note the added preceding space).

This is a critical bug because it results in lost content when changing file format, and is much worse that the converse to static text mentioned in bug 42346, so I am reporting it as a separate, high-priority bug. 

This issue is high-priority due to the frequent requirement to communicate externally in docx/doc format in many contexts.

Steps to Reproduce:
1. Open attached document 'figure-cross-ref-bug.odt'
2. Save as Word (docx) format
3. Open the exported file in Word.

Actual Results:  
Figure cross-reference is messed up, see attached screenshot. "Figure 1" is replaced by " Figure"

Expected Results:
Even if the exported text is no longer dynamically linked to the actual figure (which would be ideal), it *AT LEAST* should still have the same static text 'Figure 1'.


Reproducible: Always

User Profile Reset: No

Additional Info:
See also bug 42346, which refers to the problem of xrefs being converted to static text, not to disappearing references.

Ranking as Critical, since data is lost in the file conversion.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 john 2017-03-17 02:25:32 UTC
Created attachment 131951 [details]
example document to demonstrate the bug
Comment 2 john 2017-03-17 02:25:53 UTC
Created attachment 131952 [details]
screenshot from Word
Comment 3 john 2017-03-17 02:52:36 UTC
Created attachment 131953 [details]
also showing a problem with Equation references.

Equation was creating using "fn <F3>" then reference was Insert->Cross Reference->Text->Category and Number (...but why that works in LibreOffice, I do not know)
Comment 4 john 2017-03-17 02:55:07 UTC
Created attachment 131954 [details]
equation reference converted to from "Eq 1" to "Eq Text"
Comment 5 Xisco Faulí 2017-03-17 10:21:33 UTC
COnfirmed in

- Version: 5.4.0.0.alpha0+
Build ID: d3b5bd4a07a619db6bee1c39c32280ac3c620532
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

- Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

- LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 6 Xisco Faulí 2017-03-24 23:23:51 UTC
*** Bug 106745 has been marked as a duplicate of this bug. ***
Comment 7 Timur 2018-03-22 15:26:42 UTC
"Error: Reference source not found" when open in LO and field updated in MSO.
Comment 8 Lars Jødal 2019-04-13 10:02:32 UTC
This bug was fixed in LO 6.0, see bug 42346. Just tested with LO 6.2.2
Comment 9 Lars Jødal 2019-04-13 10:03:04 UTC

*** This bug has been marked as a duplicate of bug 42346 ***