Download it now!
Bug 106606 - FILEOPEN DOCX: Bullet Pictures Lost on Lists with Resized Font
Summary: FILEOPEN DOCX: Bullet Pictures Lost on Lists with Resized Font
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Vitaliy
URL:
Whiteboard: target:5.4.0
Keywords: filter:docx
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2017-03-17 20:31 UTC by Luke
Modified: 2017-11-04 16:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example docx with Large Bullets (71.81 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-03-17 20:32 UTC, Luke
Details
Screenshot of Word vs Writer (63.06 KB, image/png)
2017-03-17 20:37 UTC, Luke
Details
Difference between MSO and LO (191.62 KB, image/png)
2017-04-05 11:07 UTC, Vitaliy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2017-03-17 20:31:01 UTC
Steps to Reproduce:
1. In word create a list with a picture bullet
2. Increase font size
3. Save 
4. Open in Writer

Expected Results 
Large picture bullet list, same as Word.

Actual Results:
Large plain bullet list.

The impress PPT importer correctly handles resized image bullets. For example, see attachment 131970 [details]
Comment 1 Luke 2017-03-17 20:32:51 UTC
Created attachment 131972 [details]
Example docx with Large Bullets
Comment 2 Luke 2017-03-17 20:37:13 UTC
Created attachment 131973 [details]
Screenshot of Word vs Writer
Comment 3 Xisco Faulí 2017-03-18 13:19:01 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: d3b5bd4a07a619db6bee1c39c32280ac3c620532
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Commit Notification 2017-03-30 08:15:12 UTC
Vitaliy Anderson committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2f2296d2c328fa8bf3671f8d3591d3a2bdf2752f

tdf#106606: Don't dispose NumPicBullet in sprm handler.

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Vitaliy 2017-04-05 11:07:14 UTC
Created attachment 132349 [details]
Difference between MSO and LO

I fixed it partially. I only can't to change picture size because there is difference between MSO and LO behaviors.

In MSO bullet pics size depends on height of the line.

In LO the pics depends on the rule.
Comment 6 Luke 2017-04-09 04:44:18 UTC
Vitaliy, 

Thanks for your patch. This is a nice improvement. 


> In MSO bullet pics size depends on height of the line.
> In LO the pics depends on the rule.


There's actually an enhancement request for this. 
Bug 73966 - FORMATTING: bullets images should resize with text

It might be worth looking at how the ppt importer handles this. It correctly scales up and down graphics of bullets. 

Miklos, 
Do you have any thoughts on this issue?
Comment 7 Miklos Vajna 2017-04-14 22:21:37 UTC
What Vitaliy writes is correct. I'm not sure if the ppt importer is relevant here, since Writer's numbering is a separate implementation from the editeng numbering.