Bug 106612 - UI: double click in navigator in Impress/Draw does nothing
Summary: UI: double click in navigator in Impress/Draw does nothing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-03-18 00:22 UTC by gilward.kukel
Modified: 2017-03-28 21:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gilward.kukel 2017-03-18 00:22:24 UTC
Description:
double click in navigator in Impress/Draw does nothing

Steps to Reproduce:
1. in the navigator in Impress or Draw, double click on a page/slide that is not the current page/slide


Actual Results:  
nothing happens

Expected Results:
that page/slide should become the current page/slide


Reproducible: Always

User Profile Reset: No

Additional Info:
the same in 5.3.1.2.
It works in 5.2.6.2.


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2017-03-18 13:53:16 UTC
I think this is the expected behaviour. However, let the UI experts comment on this...

The behaviour has been like this since LibreOffice 3.3
Comment 2 V Stuart Foote 2017-03-18 14:11:03 UTC

*** This bug has been marked as a duplicate of bug 90244 ***
Comment 3 gilward.kukel 2017-03-18 15:42:17 UTC
(In reply to Xisco Faulí from comment #1)
> The behaviour has been like this since LibreOffice 3.3

As I said, it works in 5.2.6.2.
Comment 4 gilward.kukel 2017-03-18 15:51:07 UTC
(In reply to V Stuart Foote from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 90244 ***

That's not a duplicate.
Comment 5 Regina Henschel 2017-03-18 18:38:51 UTC
It works in Version: Version: 5.3.0.0.alpha0+
Build ID: e2f6c7f0d0cc14f851d7028ff846c5dc658a81c6
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-10_23:08:02
Locale: de-DE (de_DE); Calc: group

It is broken in Version: 5.3.0.0.alpha0+
Build ID: 92874f2f134d28b77163a21ff5d04c5234ca65b2
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-14_23:23:40
Locale: de-DE (de_DE); Calc: group

I have no further versions in between.

Remove keyword needsUXEval.
Comment 7 V Stuart Foote 2017-03-18 18:57:19 UTC
(In reply to gilward.kukel from comment #4)
> (In reply to V Stuart Foote from comment #2)
> > 
> > *** This bug has been marked as a duplicate of bug 90244 ***
> 
> That's not a duplicate.

Yes sorry, there was a regression in Navigator handling as noted. With on hand builds I can also bracket it in master builds to somewhere between 2016-10-04 and 2016-10-20.

Regina looks to have pinned it down in comment 6.  But probably still could use a proper bibisect run.

@Caolán, any thoughts?
Comment 8 Xisco Faulí 2017-03-18 20:08:38 UTC
(In reply to gilward.kukel from comment #3)
> (In reply to Xisco Faulí from comment #1)
> > The behaviour has been like this since LibreOffice 3.3
> 
> As I said, it works in 5.2.6.2.

You're right, sorry for that.

Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2016-10-11 19:34:32 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2016-10-12 09:10:20 (GMT)
commit	4dc6e29dd6c531dc9c867bc75ef0128a78d99f33 (patch)
tree	be99d278decdcc2e531f5a732f05f3fe9fcdf8bd
parent	0bd4ae07ae99bf030a3f775b8e16db58f7d2cdba (diff)
convert impress/draw navigator to .ui

Adding Cc: to Caolán McNamara
Comment 9 Commit Notification 2017-03-20 11:53:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=879aa0f71d98969f6bf2e540f1e95c7c9e0e05bf

Resolves: tdf#106612 fix double click in draw/impress navigator

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2017-03-28 21:04:57 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9fd212c3fbc28868e15f5d8e8ae598ac34176991&h=libreoffice-5-3

Resolves: tdf#106612 fix double click in draw/impress navigator

It will be available in 5.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.