Bug 106667 - Hang when trying to open a dialog and the whole sheet is selected
Summary: Hang when trying to open a dialog and the whole sheet is selected
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.0.4
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2017-03-20 19:36 UTC by Xisco Faulí
Modified: 2018-03-28 09:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-03-20 19:36:15 UTC
Steps to Reproduce:
1. Open attachment 132016 [details]
2. Press CTRL+A
3. Go to Help - About LibreOffice

Observed behaviour: LibreOffice hangs
Comment 1 Xisco Faulí 2017-03-20 19:37:21 UTC
Regression introduced by:

author	Noel Grandin <noel@peralex.com>	2014-05-19 08:02:29 (GMT)
committer	Stephan Bergmann <sbergman@redhat.com>	2014-05-20 09:17:22 (GMT)
commit	8d54796bf152499ecbe61788be64c9035f725dfa (patch)
tree	9516219cf8e60bdd46597e522ca4e9fde9b8f407
parent	e4740dbecfce958c2c707d8cc92e6dbe52f4b71b (diff)
enhance pass-by-ref plugin to detect large arguments
Detect arguments larger than 64 chars passed by value.

Adding Cc: to Noel Grandin
Comment 2 Xisco Faulí 2017-03-20 19:41:35 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 2356bfdb1b99a93fcb35fefc0f587158e7d160c2
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-03-20_00:30:32
Locale: es-ES (es_ES); Calc: group
Comment 3 m.a.riosv 2017-03-20 21:33:37 UTC
Hi Xisco, Help Abou4 it's usually slow the first time it is called.

Not reproducible.
Version: 5.3.1.2 (x64)
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: es-ES (es_ES); Calc: group
Comment 4 Thomas Woltjer 2017-03-20 22:18:58 UTC
Could not reproduce. 

Version: 5.4.0.0.alpha0+
Build ID: 778d6ddc24e927260d1002e23cf0bbcc4a0ed74c
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 Thomas Lendo 2017-07-21 21:32:07 UTC
Steps in comment 0 with attached file reproduced in
Version: 5.4.0.2
Build-ID: 2b906d450a44f2bbe506dcd22c51b3fa11dc65fd
CPU-Threads: 4; Betriebssystem:Linux 4.8; UI-Render: Standard; VCL: gtk2; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
Comment 6 Commit Notification 2018-03-27 19:23:26 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4f1654c07ec58bc36d824e9434ab851b7900e9f

tdf#106667 Hang when trying to open a dialog and the whole sheet is selected

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-03-28 07:22:48 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3638dc92ce9b251327302fc903f17d6939fb334e&h=libreoffice-6-0

tdf#106667 Hang when trying to open a dialog and the whole sheet is selected

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-03-28 09:47:13 UTC
Recently I changed my hard drive to a SSD and I can't reproduce the issue per se.
However, comparing it before and after the commit, I see that with the commit in I can perform the steps one after the other instantly while before the commit, there was a delay, thus setting as VERIFIED.

Version: 6.1.0.0.alpha0+
Build ID: 8329f4541e27402d19729ae1588af8bfe61f7b49
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Thanks Noel!