Bug 106703 - Poor Performance on macOS 10.12.3
Summary: Poor Performance on macOS 10.12.3
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.1.2 release
Hardware: All Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, perf
Depends on:
Blocks: MacOS-Performance
  Show dependency treegraph
 
Reported: 2017-03-22 17:56 UTC by Christoph
Modified: 2018-02-24 17:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph 2017-03-22 17:56:53 UTC
Description:
It takes a very long time for LibreOffice to open or to save a document. When you print a document, it takes a boring time till LibreOffice works again...
I switched over to latest OpenOffice 4.3.1 that works well...


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_3) AppleWebKit/602.4.8 (KHTML, like Gecko) Version/10.0.3 Safari/602.4.8
Comment 1 Alex Thurgood 2017-03-23 10:55:14 UTC
Confirming with LO 5312
Comment 2 Ivan 2017-10-27 05:14:18 UTC
I confirm this bug with 5.4.2 and 5.3.6. It's very slow with draw too.
Comment 3 Telesto 2017-10-27 10:41:00 UTC
(In reply to Ivan from comment #2)
> I confirm this bug with 5.4.2 and 5.3.6. It's very slow with draw too.

Slow how exactly? Selecting drawing objects? Or opening dialogs? If it's about selecting drawing objects, disable the sidebar (view -> sidebar) (bug 105500)
Comment 4 Ivan 2017-11-10 23:08:34 UTC
(In reply to Telesto from comment #3)
> (In reply to Ivan from comment #2)
> > I confirm this bug with 5.4.2 and 5.3.6. It's very slow with draw too.
> 
> Slow how exactly? Selecting drawing objects? Or opening dialogs? If it's
> about selecting drawing objects, disable the sidebar (view -> sidebar) (bug
> 105500)

It work, thank you! Will it be fix?
Comment 5 Telesto 2017-11-11 08:36:50 UTC
(In reply to Ivan from comment #4)
> It work, thank you! Will it be fix?

You will know, when it's fixed if you add yourself to the CC List of bug 105500.
And the priority probably increased (at some point) with more people in the CC mailing list, so...
Comment 6 Telesto 2018-02-24 12:15:17 UTC
@Christoph
Is there still a performance lag with 5.4 or 6.0?
Comment 7 steve -_- 2018-02-24 17:22:34 UTC
Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Mac OS X 10.13.3; UI render: default; 
Locale: de-DE (de_DE.UTF-8); Calc: group

cannot reproduce major performance issues on opening / saving / printing.

Closing as WORKSFORME. @Christoph please re-open if major performance issues persist for you with a current LO release.