Bug Hunting Session
Bug 106738 - Impress hangs when right-clicking after typing letters in a textbox
Summary: Impress hangs when right-clicking after typing letters in a textbox
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-03-24 08:06 UTC by ChenAmy
Modified: 2018-01-02 10:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ChenAmy 2017-03-24 08:06:22 UTC
i found when i click right-mouse button one the letters in the text-box. The software seems be trapped into longtime waiting. And CPU turns a little bit high. And i still can not find a method to let letters go around the picture i put in.
hope to hear from you.
Comment 1 Xisco Faulí 2017-03-24 09:22:04 UTC Comment hidden (obsolete)
Comment 2 ChenAmy 2017-03-24 10:01:13 UTC
OK STEP BY STEP(i am not a native speaker so there maybe some grammar mistakes)
1.open the libreoffice choose impress
2.type some letters in the textbox 
3.then press the right button on the mouse
4.then you can not do anything it seems that the software halted
5.i check of the usage of CPU.the usage of libreoffice is more than 18%
6.after several minutes waiting ,the software can use again 



i do think if there is no option in right click,the software shouldn't halted.
Comment 3 ChenAmy 2017-03-24 10:02:49 UTC Comment hidden (obsolete)
Comment 4 V Stuart Foote 2017-03-24 11:41:40 UTC
With cursor focus into a Impress text box, a right mouse should open the context menu immediately. And if a character or word had been selected, the context menu should have Cut/Copy actions activated for use. It does so for me on Windows 10 Pro 64-bit en-US with 5.2.6.2, 5.3.1.2 and current master.

Guess it is possible to have delay like this on Windows builds if using some of the larger CJK fonts.  The font handling has been cleaned up quite a bit for the 5.3 release.

NEEDINFO:

What locale and what font are you working with in the presentation?

Please post the text from the Help -> About LibreOffice dialog.

Please install the 5.3.1 release (or 5.3.2 pre-release) and test behavior with that.
Comment 5 ChenAmy 2017-03-24 14:08:29 UTC
i will try it later thank you my system is chinese
Comment 6 tommy27 2017-05-06 15:35:02 UTC
please give feedback after upgrading to latest LibO 5.3.2.2 and answering questions in comment 4
Comment 7 QA Administrators 2017-12-04 12:45:18 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2018-01-02 10:18:03 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20180102