Bug 106757 - LO Crashes with fatal error if try to edit master page in sidebar
Summary: LO Crashes with fatal error if try to edit master page in sidebar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: wantBacktrace
: 112193 113199 (view as bug list)
Depends on:
Blocks: Sidebar-Master-Pages
  Show dependency treegraph
 
Reported: 2017-03-24 18:53 UTC by bordfeldt
Modified: 2018-02-07 22:28 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bordfeldt 2017-03-24 18:53:36 UTC
LO 5.3.0.3 on Windows 10 Pro 64bit

Steps to reproduce:

1. start LO
2. open a new empty presentation
3. in sidebar select master pages
4. make a right click on the master page "used in this presentation" (default) on the top of the sidebar
5. Select "edit master ..."
6. LO crashes with "fatal error" alert

always reproducable
Comment 1 Xisco Faulí 2017-03-24 19:40:31 UTC Comment hidden (obsolete)
Comment 2 bordfeldt 2017-03-25 12:16:00 UTC
Hi,

just installed 5.3.1.2. Problem still exists.
Comment 3 Julien Nabet 2017-03-31 23:47:57 UTC
Could you rename your LO directory profile and give a new try? (see https://wiki.documentfoundation.org/UserProfile#Windows)

If you still reproduce this, would it be possible you retrieve a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace)
Comment 4 Arnaud Versini 2017-04-02 13:07:28 UTC
Confirmed on openSUSE Tumbleweed with LibreOffice 5.3.1.2. But I can't have a backtrace, a fatal error dialog appears after the trouble.
Comment 5 Jean-Baptiste Faure 2017-04-02 15:11:55 UTC
Updated version and OS from description and comment #4.

Best regards. JBF
Comment 6 Arnaud Versini 2017-04-02 15:49:33 UTC
It seems your wrong :-)
Comment 7 Pierre C 2017-04-04 12:40:28 UTC
I confirm this bug with LO 5.3.2.1 x32 and 5.3.2.2 x64 Windows 10
Pierre
Comment 8 Xisco Faulí 2017-04-06 14:21:12 UTC

(In reply to Arnaud Versini from comment #4)
> Confirmed on openSUSE Tumbleweed with LibreOffice 5.3.1.2. But I can't have
> a backtrace, a fatal error dialog appears after the trouble.

I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 36641fb421240ec5763d7d1f7fba05f5834b38d8
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2017-04-05_23:36:59
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Could you please provide more information about the version of LibreOffice you are using ?
Comment 9 Pierre C 2017-04-09 14:28:53 UTC
I have no problem with Master branch  too 
This problem seuls to be specific to 5.3 branch 5.3.2
Comment 10 Arnaud Versini 2017-04-09 14:35:51 UTC
The only trace I got is :

#0  0x00007ffff36727bd in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007ffff02d6a86 in g_main_context_poll (priority=<optimized out>, n_fds=3, fds=0x6596820, timeout=<optimized out>, context=0x5e35b00) at gmain.c:4228
#2  0x00007ffff02d6a86 in g_main_context_iterate (context=0x5e35b00, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3924
#3  0x00007ffff02d6e12 in g_main_loop_run (loop=0xf0d3ec0) at gmain.c:4125
#4  0x00007fffdf0132c0 in gtk_dialog_run (dialog=0x60a8380 [GtkMessageDialog]) at gtkdialog.c:1397
#5  0x00007fffdf7d2dc7 in GtkSalSystem::ShowNativeDialog(rtl::OUString const&, rtl::OUString const&, std::__cxx11::list<rtl::OUString, std::allocator<rtl::OUString> > const&, int) () at /usr/lib64/libreoffice/program/libvclplug_gtk3lo.so
#6  0x00007ffff691bcbf in SalGenericSystem::ShowNativeMessageBox(rtl::OUString const&, rtl::OUString const&) () at /usr/lib64/libreoffice/program/libmergedlo.so
#7  0x00007ffff586a568 in desktop::(anonymous namespace)::FatalError(rtl::OUString const&) () at /usr/lib64/libreoffice/program/libmergedlo.so
#8  0x00007ffff5876b39 in desktop::Desktop::Main() () at /usr/lib64/libreoffice/program/libmergedlo.so
#9  0x00007ffff6873596 in ImplSVMain() () at /usr/lib64/libreoffice/program/libmergedlo.so
#10 0x00007ffff6873692 in SVMain() () at /usr/lib64/libreoffice/program/libmergedlo.so
#11 0x00007ffff589845a in soffice_main () at /usr/lib64/libreoffice/program/libmergedlo.so
#12 0x000000000040064b in main ()

This is the libreoffice provided by openSUSE Tumbleweed, and french localisation. Reproduced one time only on master
Comment 11 Julien Nabet 2017-09-03 18:56:49 UTC
*** Bug 112193 has been marked as a duplicate of this bug. ***
Comment 12 Kotaro Osada 2017-09-04 15:32:35 UTC
I'm the reporter of the bug marked as duplicate.

This bug is reproduced in:

Version: 5.4.1.2 (x64)
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 8; OS: Windows 6.1; UI render: default; 
Locale: ja-JP (ja_JP); Calc: group

Windows 7 Home Premium Service Pack 1 x64

Previously I was using LibreOffice 5.2.7 (x86),
then updated to 5.3.4 (x64). 5.4.1 (x64) is installed after that.
Comment 13 Xisco Faulí 2017-10-17 20:37:39 UTC
*** Bug 113199 has been marked as a duplicate of this bug. ***
Comment 14 umg 2017-10-17 20:45:57 UTC
Bug 113199 is the one that I reported and I experienced the issue in the end of last year / beginning of this year.
So would be nice if someone could resolve the issue, otherwise libreoffice impressive is a kind of useless for creating serious content with master slides.
Comment 15 Xisco Faulí 2017-10-17 20:54:53 UTC
Could you please download a debug build from here: http://dev-builds.libreoffice.org/daily/master/ ( the ones with -dbg at the end ), and get a backtrace as explain here: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace ?
Comment 16 Julien Nabet 2017-10-17 21:13:43 UTC
Just for the record, on pc Debian x86-64 with master sources updated today (+enable-dbgutil) or with LO Debian package 5.4.1.2, I don't reproduce the crash with gen/gtk/gtk3/kde4 rendering.

We really need a backtrace to pinpoint the cause of this.
Comment 17 umg 2017-10-17 21:45:33 UTC
So I downloaded the current dbg version in that link: http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF-dbg/current/

I didn't reproduce the crash in the dbg version. But the UI, or let's say the theme looked different compared to my locally installed libreoffice.

I started the application in the program folder with ./soffice --backtrace


In the following part you can see the output that I got from the terminal and the content of the gdbtrace.log file


_________________________________________________________________________
_________________________________________________________________________
Output of the terminal:
_________________________________________________________________________
_________________________________________________________________________


./soffice --backtrace
GNU gdb (GDB) 8.0.1
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /home/umg/Downloads/lo/LibreOfficeDev_6.0.0.0.alpha0_Linux_x86-64_archive/program/soffice.bin...done.
log will be saved as gdbtrace.log, this will take some time, patience...
(gdb) run
warn:opencl:6480:6480:desktop/source/app/opencl.cxx:137: Failed to initialize OpenCL for test
warn:legacy.osl:6480:6480:unotools/source/config/moduleoptions.cxx:478: unknown factory
warn:sfx:6480:6480:sfx2/source/control/thumbnailview.cxx:1259: caught exception while trying to access Thumbnail/thumbnail.png of file:///home/umg/Downloads/lo/LibreOfficeDev_6.0.0.0.alpha0_Linux_x86-64_archive/share/template/common/styles/Default.ott: N3com3sun4star3uno9ExceptionE msg: /tinderbox/buildslave/source/libo-master/package/source/xstor/xstorage.cxx:2372: 
warn:sfx:6480:6480:sfx2/source/control/thumbnailview.cxx:1286: caught exception while trying to access Thumbnails/thumbnail.png of file:///home/umg/Downloads/lo/LibreOfficeDev_6.0.0.0.alpha0_Linux_x86-64_archive/share/template/common/styles/Default.ott: N3com3sun4star3uno9ExceptionE msg: /tinderbox/buildslave/source/libo-master/package/source/xstor/xstorage.cxx:2372: 
warn:sfx:6480:6480:sfx2/source/control/thumbnailview.cxx:1259: caught exception while trying to access Thumbnail/thumbnail.png of file:///home/umg/Downloads/lo/LibreOfficeDev_6.0.0.0.alpha0_Linux_x86-64_archive/share/template/common/styles/Modern.ott: N3com3sun4star3uno9ExceptionE msg: /tinderbox/buildslave/source/libo-master/package/source/xstor/xstorage.cxx:2372: 
warn:sfx:6480:6480:sfx2/source/control/thumbnailview.cxx:1286: caught exception while trying to access Thumbnails/thumbnail.png of file:///home/umg/Downloads/lo/LibreOfficeDev_6.0.0.0.alpha0_Linux_x86-64_archive/share/template/common/styles/Modern.ott: N3com3sun4star3uno9ExceptionE msg: /tinderbox/buildslave/source/libo-master/package/source/xstor/xstorage.cxx:2372: 
warn:legacy.tools:6480:6480:sfx2/source/control/bindings.cxx:1749: No cache for OfficeDispatch!
warn:i18nlangtag:6480:6480:i18nlangtag/source/languagetag/languagetag.cxx:1410: LanguageTagImpl::convertLocaleToLang: with bAllowOnTheFlyID invalid 'en-GB-large'
warn:legacy.tools:6480:6480:sd/source/ui/slidesorter/controller/SlsPageSelector.cxx:84: PageSelector::DeselectAllPages: the selected pages counter is not 0
warn:legacy.tools:6480:6480:sd/source/ui/slidesorter/controller/SlsPageSelector.cxx:84: PageSelector::DeselectAllPages: the selected pages counter is not 0
warn:legacy.tools:6480:6480:sd/source/ui/slidesorter/controller/SlsPageSelector.cxx:84: PageSelector::DeselectAllPages: the selected pages counter is not 0
warn:legacy.tools:6480:6480:sd/source/ui/slidesorter/controller/SlsPageSelector.cxx:84: PageSelector::DeselectAllPages: the selected pages counter is not 0
warn:legacy.tools:6480:6480:sd/source/ui/slidesorter/controller/SlsPageSelector.cxx:84: PageSelector::DeselectAllPages: the selected pages counter is not 0
warn:legacy.tools:6480:6480:sd/source/ui/slidesorter/controller/SlsPageSelector.cxx:84: PageSelector::DeselectAllPages: the selected pages counter is not 0
warn:legacy.tools:6480:6480:basic/source/sbx/sbxobj.cxx:95: Object element with dangling parent
warn:legacy.tools:6480:6480:basic/source/sbx/sbxobj.cxx:95: Object element with dangling parent
warn:legacy.tools:6480:6480:basic/source/sbx/sbxobj.cxx:95: Object element with dangling parent
warn:legacy.tools:6480:6480:basic/source/sbx/sbxobj.cxx:95: Object element with dangling parent
warn:legacy.tools:6480:6480:basic/source/sbx/sbxobj.cxx:95: Object element with dangling parent
warn:legacy.tools:6480:6480:basic/source/sbx/sbxobj.cxx:95: Object element with dangling parent
warn:legacy.tools:6480:6480:basic/source/sbx/sbxobj.cxx:95: Object element with dangling parent
warn:legacy.tools:6480:6480:basic/source/sbx/sbxobj.cxx:95: Object element with dangling parent
warn:legacy.tools:6480:6480:basic/source/sbx/sbxobj.cxx:95: Object element with dangling parent
warn:legacy.tools:6480:6480:basic/source/sbx/sbxobj.cxx:95: Object element with dangling parent
warn:vcl.schedule.deinit:6480:6480:vcl/source/app/scheduler.cxx:158: DeInit task: Timer a: 1 p: 1 svtools::GraphicCache maReleaseTimer 10000ms (0x1801f20) (ignored)
warn:vcl.schedule.deinit:6480:6480:vcl/source/app/scheduler.cxx:174: DeInit active tasks: 1 (ignored: 1)
warn:unotools.config:6480:6480:unotools/source/config/configmgr.cxx:167: ConfigManager not empty
(gdb) quit












_________________________________________________________________________
_________________________________________________________________________
Output of the gdbtrace.log file:
_________________________________________________________________________
_________________________________________________________________________



warning: Currently logging to gdbtrace.log.  Turn the logging off and on to make the new setting effective.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffd9f35700 (LWP 6454)]
[New Thread 0x7fffd590c700 (LWP 6456)]
[New Thread 0x7fffd4ef9700 (LWP 6457)]
[Thread 0x7fffd590c700 (LWP 6456) exited]
[New Thread 0x7fffd590c700 (LWP 6458)]
[New Thread 0x7fffcce90700 (LWP 6459)]
[New Thread 0x7fffc1ed0700 (LWP 6460)]
[New Thread 0x7fffc0e64700 (LWP 6461)]
[New Thread 0x7fffbbfff700 (LWP 6464)]
[Thread 0x7fffc1ed0700 (LWP 6460) exited]
[Thread 0x7fffd4ef9700 (LWP 6457) exited]
[Thread 0x7fffd9f35700 (LWP 6454) exited]
[Thread 0x7fffc0e64700 (LWP 6461) exited]
[Thread 0x7fffcce90700 (LWP 6459) exited]
[Thread 0x7fffd590c700 (LWP 6458) exited]
[Thread 0x7ffff7f805c0 (LWP 6448) exited]
[Inferior 1 (process 6448) exited with code 0121]
/home/umg/Downloads/lo/LibreOfficeDev_6.0.0.0.alpha0_Linux_x86-64_archive/program/gdbtrace:9: Error in sourced command file:
No stack.
Starting program: /home/umg/Downloads/lo/LibreOfficeDev_6.0.0.0.alpha0_Linux_x86-64_archive/program/soffice.bin --backtrace
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffd9f35700 (LWP 6482)]
[New Thread 0x7fffd58fd700 (LWP 6484)]
[New Thread 0x7fffd4eea700 (LWP 6485)]
[Thread 0x7fffd58fd700 (LWP 6484) exited]
[New Thread 0x7fffd58fd700 (LWP 6486)]
[New Thread 0x7fffcce14700 (LWP 6487)]
[New Thread 0x7fffc3322700 (LWP 6488)]
[New Thread 0x7fffc2b21700 (LWP 6489)]
[New Thread 0x7fffc20d8700 (LWP 6490)]
[New Thread 0x7fffc12fb700 (LWP 6491)]
[Thread 0x7fffc12fb700 (LWP 6491) exited]
[New Thread 0x7fffc12fb700 (LWP 6492)]
[Thread 0x7fffc2b21700 (LWP 6489) exited]
[New Thread 0x7fffc2b21700 (LWP 6493)]
[Thread 0x7fffc2b21700 (LWP 6493) exited]
[New Thread 0x7fffc2b21700 (LWP 6494)]
[New Thread 0x7fffb3b4e700 (LWP 6497)]
[New Thread 0x7fffb30cd700 (LWP 6498)]
[Thread 0x7fffc2b21700 (LWP 6494) exited]
[Thread 0x7fffb3b4e700 (LWP 6497) exited]
[Thread 0x7fffc3322700 (LWP 6488) exited]
[New Thread 0x7fffc3322700 (LWP 6503)]
[Thread 0x7fffc3322700 (LWP 6503) exited]
[New Thread 0x7fffc3322700 (LWP 6504)]
[New Thread 0x7fffb3b4e700 (LWP 6505)]
[Thread 0x7fffb3b4e700 (LWP 6505) exited]
[New Thread 0x7fffb3b4e700 (LWP 6506)]
[Thread 0x7fffb3b4e700 (LWP 6506) exited]
[New Thread 0x7fffb3b4e700 (LWP 6507)]
[Thread 0x7fffb3b4e700 (LWP 6507) exited]
[New Thread 0x7fffb3b4e700 (LWP 6508)]
[Thread 0x7fffb3b4e700 (LWP 6508) exited]
[New Thread 0x7fffb3b4e700 (LWP 6509)]
[Thread 0x7fffb3b4e700 (LWP 6509) exited]
[Thread 0x7fffc3322700 (LWP 6504) exited]
[New Thread 0x7fffc3322700 (LWP 6510)]
warning: File "/home/umg/Downloads/lo/LibreOfficeDev_6.0.0.0.alpha0_Linux_x86-64_archive/program/libpython3.5m.so.1.0-gdb.py" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
To enable execution of this file add
	add-auto-load-safe-path /home/umg/Downloads/lo/LibreOfficeDev_6.0.0.0.alpha0_Linux_x86-64_archive/program/libpython3.5m.so.1.0-gdb.py
line to your configuration file "/home/umg/.gdbinit".
To completely disable this security protection add
	set auto-load safe-path /
line to your configuration file "/home/umg/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
	info "(gdb)Auto-loading safe path"
[Thread 0x7fffc3322700 (LWP 6510) exited]
[New Thread 0x7fffc3322700 (LWP 6511)]
[Thread 0x7fffc3322700 (LWP 6511) exited]
[New Thread 0x7fffc3322700 (LWP 6512)]
[Thread 0x7fffc3322700 (LWP 6512) exited]
[New Thread 0x7fffc3322700 (LWP 6513)]
[Thread 0x7fffc3322700 (LWP 6513) exited]
[New Thread 0x7fffc3322700 (LWP 6514)]
[New Thread 0x7fffb3b4e700 (LWP 6515)]
[Thread 0x7fffc3322700 (LWP 6514) exited]
[New Thread 0x7fffc3322700 (LWP 6523)]
[Thread 0x7fffc12fb700 (LWP 6492) exited]
[New Thread 0x7fffc12fb700 (LWP 6524)]
[Thread 0x7fffc12fb700 (LWP 6524) exited]
[New Thread 0x7fffc12fb700 (LWP 6525)]
[Thread 0x7fffc12fb700 (LWP 6525) exited]
[New Thread 0x7fffc12fb700 (LWP 6526)]
[Thread 0x7fffc12fb700 (LWP 6526) exited]
[New Thread 0x7fffc12fb700 (LWP 6527)]
[New Thread 0x7fffc2b21700 (LWP 6528)]
[Thread 0x7fffc2b21700 (LWP 6528) exited]
[Thread 0x7fffc12fb700 (LWP 6527) exited]
[New Thread 0x7fffc12fb700 (LWP 6529)]
[Thread 0x7fffc12fb700 (LWP 6529) exited]
[New Thread 0x7fffc12fb700 (LWP 6531)]
[Thread 0x7fffc12fb700 (LWP 6531) exited]
[New Thread 0x7fffc12fb700 (LWP 6538)]
[Thread 0x7fffc12fb700 (LWP 6538) exited]
[New Thread 0x7fffc12fb700 (LWP 6539)]
[Thread 0x7fffc12fb700 (LWP 6539) exited]
[New Thread 0x7fffc12fb700 (LWP 6540)]
[Thread 0x7fffc12fb700 (LWP 6540) exited]
[New Thread 0x7fffc12fb700 (LWP 6560)]
[Thread 0x7fffc12fb700 (LWP 6560) exited]
[New Thread 0x7fffc12fb700 (LWP 6564)]
[Thread 0x7fffc12fb700 (LWP 6564) exited]
[New Thread 0x7fffc12fb700 (LWP 6565)]
[Thread 0x7fffc12fb700 (LWP 6565) exited]
[New Thread 0x7fffc12fb700 (LWP 6566)]
[Thread 0x7fffc12fb700 (LWP 6566) exited]
[New Thread 0x7fffc12fb700 (LWP 6567)]
[Thread 0x7fffc20d8700 (LWP 6490) exited]
[Thread 0x7fffc12fb700 (LWP 6567) exited]
[New Thread 0x7fffc12fb700 (LWP 6568)]
[Thread 0x7fffc12fb700 (LWP 6568) exited]
[Thread 0x7fffb3b4e700 (LWP 6515) exited]
[Thread 0x7fffd4eea700 (LWP 6485) exited]
[Thread 0x7fffb30cd700 (LWP 6498) exited]
[Thread 0x7fffd9f35700 (LWP 6482) exited]
[Thread 0x7fffcce14700 (LWP 6487) exited]
[Thread 0x7fffd58fd700 (LWP 6486) exited]
[Thread 0x7ffff7f805c0 (LWP 6480) exited]
[Inferior 1 (process 6480) exited normally]
Comment 18 umg 2017-10-17 21:48:07 UTC
Now I tried to do the same with my locally installed libreoffice impress.

Here I can reproduce the crash and I get the following output:





_________________________________________________________________________
_________________________________________________________________________
Output of the terminal:
_________________________________________________________________________
_________________________________________________________________________


soffice --backtrace
GNU gdb (GDB) 8.0.1
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/lib/libreoffice/program/soffice.bin...(no debugging symbols found)...done.
log will be saved as gdbtrace.log, this will take some time, patience...

(soffice:5519): GLib-GObject-WARNING **: gsignal.c:3492: signal name 'selection_changed' is invalid for instance '0x7fffc4007b90' of type 'OOoAtkObjCompTxt'
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
(gdb) quit









_________________________________________________________________________
_________________________________________________________________________
Output of the gdbtrace.log file:
_________________________________________________________________________
_________________________________________________________________________



warning: Currently logging to gdbtrace.log.  Turn the logging off and on to make the new setting effective.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffdef76700 (LWP 5478)]
[New Thread 0x7fffda444700 (LWP 5479)]
[New Thread 0x7fffd9c43700 (LWP 5480)]
[New Thread 0x7fffd333a700 (LWP 5481)]
[New Thread 0x7fffd2b39700 (LWP 5482)]
[New Thread 0x7fffd1930700 (LWP 5483)]
[New Thread 0x7fffd112f700 (LWP 5484)]
[New Thread 0x7fffbda45700 (LWP 5487)]
[Thread 0x7fffd1930700 (LWP 5483) exited]
[Thread 0x7fffda444700 (LWP 5479) exited]
[Thread 0x7fffbda45700 (LWP 5487) exited]
[New Thread 0x7fffbda45700 (LWP 5488)]

Thread 1 "soffice.bin" received signal SIGSEGV, Segmentation fault.
0x00007fffa18d92b4 in ?? ()
#0  0x00007fffa18d92b4 in  ()
#1  0x0000000000000246 in  ()
#2  0x00007fffa18d9160 in  ()
#3  0x00007fffffffac60 in  ()
#4  0x00007fffffffac00 in  ()
#5  0x00007fffb19cd587 in  () at /usr/lib/jvm/java-8-openjdk/jre/lib/amd64/server/libjvm.so

Thread 10 (Thread 0x7fffbda45700 (LWP 5488)):
#0  0x00007ffff730a756 in pthread_cond_timedwait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007ffff7bb12a9 in osl_waitCondition () at /usr/lib/libreoffice/program/libuno_sal.so.3
#2  0x00007fffda67ff6e in  () at /usr/lib/libreoffice/program/../program/libconfigmgrlo.so
#3  0x00007ffff4565997 in salhelper::Thread::run() () at /usr/lib/libreoffice/program/libuno_salhelpergcc3.so.3
#4  0x00007ffff4565b9a in  () at /usr/lib/libreoffice/program/libuno_salhelpergcc3.so.3
#5  0x00007ffff7bbd9eb in  () at /usr/lib/libreoffice/program/libuno_sal.so.3
#6  0x00007ffff730408a in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007ffff76111bf in clone () at /usr/lib/libc.so.6

Thread 8 (Thread 0x7fffd112f700 (LWP 5484)):
#0  0x00007ffff760bbb9 in syscall () at /usr/lib/libc.so.6
#1  0x00007fffe8beccba in g_cond_wait_until () at /usr/lib/libglib-2.0.so.0
#2  0x00007fffe8b7c121 in  () at /usr/lib/libglib-2.0.so.0
#3  0x00007fffe8b7c6dc in g_async_queue_timeout_pop () at /usr/lib/libglib-2.0.so.0
#4  0x00007fffe8bcf58e in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007fffe8bceae5 in  () at /usr/lib/libglib-2.0.so.0
#6  0x00007ffff730408a in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007ffff76111bf in clone () at /usr/lib/libc.so.6

Thread 6 (Thread 0x7fffd2b39700 (LWP 5482)):
#0  0x00007ffff7606cbb in poll () at /usr/lib/libc.so.6
#1  0x00007fffe8ba7c09 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fffe8ba7fa2 in g_main_loop_run () at /usr/lib/libglib-2.0.so.0
#3  0x00007fffe16b8546 in  () at /usr/lib/libgio-2.0.so.0
#4  0x00007fffe8bceae5 in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007ffff730408a in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007ffff76111bf in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7fffd333a700 (LWP 5481)):
#0  0x00007ffff7606cbb in poll () at /usr/lib/libc.so.6
#1  0x00007fffe8ba7c09 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fffe8ba7d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007fffe8ba7d61 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007fffe8bceae5 in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007ffff730408a in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007ffff76111bf in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7fffd9c43700 (LWP 5480)):
#0  0x00007ffff7611eeb in accept () at /usr/lib/libc.so.6
#1  0x00007ffff7bb7fc1 in osl_acceptPipe () at /usr/lib/libreoffice/program/libuno_sal.so.3
#2  0x00007ffff791d053 in  () at /usr/lib/libreoffice/program/libsofficeapp.so
#3  0x00007ffff4565997 in salhelper::Thread::run() () at /usr/lib/libreoffice/program/libuno_salhelpergcc3.so.3
#4  0x00007ffff4565b9a in  () at /usr/lib/libreoffice/program/libuno_salhelpergcc3.so.3
#5  0x00007ffff7bbd9eb in  () at /usr/lib/libreoffice/program/libuno_sal.so.3
#6  0x00007ffff730408a in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007ffff76111bf in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7fffdef76700 (LWP 5478)):
#0  0x00007ffff730a756 in pthread_cond_timedwait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007ffff7b983a7 in  () at /usr/lib/libreoffice/program/libuno_sal.so.3
#2  0x00007ffff730408a in start_thread () at /usr/lib/libpthread.so.0
#3  0x00007ffff76111bf in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7ffff7f7c9c0 (LWP 5473)):
#0  0x00007fffa18d92b4 in  ()
#1  0x0000000000000246 in  ()
#2  0x00007fffa18d9160 in  ()
#3  0x00007fffffffac60 in  ()
#4  0x00007fffffffac00 in  ()
#5  0x00007fffb19cd587 in  () at /usr/lib/jvm/java-8-openjdk/jre/lib/amd64/server/libjvm.so
A debugging session is active.

	Inferior 1 [process 5473] will be killed.

Quit anyway? (y or n) [answered Y; input not from terminal]
warning: Currently logging to gdbtrace.log.  Turn the logging off and on to make the new setting effective.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffdef76700 (LWP 5524)]
[New Thread 0x7fffda444700 (LWP 5525)]
[New Thread 0x7fffd9c43700 (LWP 5526)]
[New Thread 0x7fffd333a700 (LWP 5527)]
[New Thread 0x7fffd2b39700 (LWP 5528)]
[New Thread 0x7fffd1930700 (LWP 5529)]
[New Thread 0x7fffd112f700 (LWP 5530)]
[New Thread 0x7fffbda45700 (LWP 5533)]
[Thread 0x7fffd112f700 (LWP 5530) exited]
[Thread 0x7fffda444700 (LWP 5525) exited]
[Thread 0x7fffbda45700 (LWP 5533) exited]
[New Thread 0x7fffbda45700 (LWP 5534)]
[Thread 0x7fffbda45700 (LWP 5534) exited]
[New Thread 0x7fffbda45700 (LWP 5535)]
[Thread 0x7fffbda45700 (LWP 5535) exited]
[New Thread 0x7fffbda45700 (LWP 5536)]
[Thread 0x7fffbda45700 (LWP 5536) exited]
[Thread 0x7fffd1930700 (LWP 5529) exited]
[New Thread 0x7fffd1930700 (LWP 5568)]
[Thread 0x7fffd1930700 (LWP 5568) exited]
[Thread 0x7fffd2b39700 (LWP 5528) exited]
[Thread 0x7fffd9c43700 (LWP 5526) exited]
[Thread 0x7fffdef76700 (LWP 5524) exited]
[Thread 0x7ffff7f7c9c0 (LWP 5519) exited]
[Inferior 1 (process 5519) exited with code 0115]
/usr/lib/libreoffice/program/gdbtrace:9: Error in sourced command file:
No stack.
Comment 19 umg 2017-10-17 21:49:04 UTC
Hope that I can help you with the information above. If you need further test's, please let me know :)
Comment 20 bordfeldt 2018-02-04 14:47:44 UTC
Just tested on 6.0.0.3 on Windows 10 problem seems to be fixed.
Comment 21 Julien Nabet 2018-02-04 19:43:37 UTC
Thank you for your feedback bordfeldt.

For the other people, is it ok for you with last LO version 6.0.0.3?
Comment 22 Xisco Faulí 2018-02-05 10:14:18 UTC
(In reply to bordfeldt from comment #20)
> Just tested on 6.0.0.3 on Windows 10 problem seems to be fixed.

Thanks for retesting it.
Let's close this as RESOLVED WORKSFORME as the original reporter can no longer reproduce the issue...
Comment 23 umg 2018-02-07 22:28:22 UTC
Same here!
I tested it under Arch Linux with v6.0.0.3 and it works fine.
Thanks you very much!!!