Bug 106799 - A DOC with nested tables imports incorrectly
Summary: A DOC with nested tables imports incorrectly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:5.4.0
Keywords: filter:doc
Depends on:
Blocks:
 
Reported: 2017-03-27 16:23 UTC by Mike Kaganski
Modified: 2017-09-09 05:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A sample DOC with nested tables where TTP marks go without Cell Marks (11.00 KB, application/msword)
2017-03-27 16:23 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2017-03-27 16:23:37 UTC
Created attachment 132174 [details]
A sample DOC with nested tables where TTP marks go without Cell Marks

Attached document has a 1-cell table, in which there is another 4x3 nested table. The nested table has its first row (4 cells) merged.

The document opens OK in MS Word. However, upon import into LO, the table is distorted.

This is caused by absence of sprmPFInnerTableCell (denoting Cell Mark) at the cell ends (0x0D) where sprmPFInnerTtp is defined (LO expects it to be always present at these places). See https://msdn.microsoft.com/en-us/library/dd907418 for documentation on this.
Comment 1 Mike Kaganski 2017-03-27 18:10:39 UTC
A patch is submitted to gerrit: https://gerrit.libreoffice.org/35763/
Comment 2 Commit Notification 2017-03-27 18:31:25 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=59af9cbbccee600408c89e872d548d153523ab1f

tdf#106799 WW8: Accept TTP Mark without Cell Mark

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 vihsa 2017-09-09 05:15:25 UTC Comment hidden (spam)