Bug 106902 - Decimal separator should be a point and not a comma in Spanish (El Salvador) locale
Summary: Decimal separator should be a point and not a comma in Spanish (El Salvador) ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: All All
: medium minor
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.4
Keywords:
Depends on:
Blocks: Decimal-Separator-Key
  Show dependency treegraph
 
Reported: 2017-04-01 01:53 UTC by Yimi Perla
Modified: 2017-10-27 09:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yimi Perla 2017-04-01 01:53:56 UTC
Description:
For Central America (but Costa Rica) the decimal separator is a point. El Salvador seems to be the only locale in this region that gets its separator wrong.

Actual Results:  
In calc for example, entering pi as 3.1416 is recognized as text and not as number since it expects 3,1416.

Expected Results:
In calc for example, entering pi as 3.1416 should be recognized as a number.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Julien Nabet 2017-04-01 07:46:30 UTC
I give it a try with https://gerrit.libreoffice.org/#/c/35995/
Comment 2 Julien Nabet 2017-04-06 20:57:01 UTC
Sorry my patch was wrong but someone else will certainly fix this.
Comment 3 Commit Notification 2017-04-27 20:45:36 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b605466a2304efd2b247595fe74ddf7c6d5a77d

Resolves: tdf#106902 swap [es-SV] decimal and group separator

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Eike Rathke 2017-04-27 21:13:23 UTC
Pending review https://gerrit.libreoffice.org/37044 for 5-3
Comment 5 Commit Notification 2017-04-28 20:41:29 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f527736aa5742ddd35562441ff098e445438ef94&h=libreoffice-5-3

Resolves: tdf#106902 swap [es-SV] decimal and group separator

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.