Download it now!
Bug 106904 - Undo paste broken for html, doesn't work.
Summary: Undo paste broken for html, doesn't work.
Status: RESOLVED DUPLICATE of bug 107394
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HTML-Paste
  Show dependency treegraph
 
Reported: 2017-04-01 11:08 UTC by kie000
Modified: 2018-03-10 14:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kie000 2017-04-01 11:08:53 UTC
Description:
Copying a bunch of stuff from a web-page to Calc can result in an unholy mess, hitting undo does not work fully, objects (and perhaps more) are not removed and have to then be manually deleted which can be very awkward as they have to be selected without accidentally selecting the prior original spreadsheet contents.

Steps to Reproduce:
1. Copy large bunch of stuff from webpage including objects / icons / images
2. Paste to Calc
3. Undo

Actual Results:  
Leaves mess behind

Expected Results:
Undo fully undoes the paste.


Reproducible: Always

User Profile Reset: N/A

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows 7
OS is 64bit: yes
Builds ID: LibreOffice 5.1.0.3


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2017-04-02 12:05:40 UTC Comment hidden (obsolete)
Comment 2 kie000 2017-04-02 18:04:43 UTC
Go to libreoffice home page, ctrl-A ctrl-C
Go to blank libreoffice calc, paste, ctrl-Z

The images are still there and the row heights are all wrong.
Latest version.
Comment 3 QA Administrators 2018-03-02 10:01:54 UTC Comment hidden (obsolete)
Comment 4 kie000 2018-03-02 14:42:23 UTC
Bug still in 6.0.2.1 (x64), Win7

The row heights remain as if information had been pasted, the heights do not return to as they were pre-paste.

The 'objects' from the paste also remain.

Sites:
http://www.bbc.com/news/business/market_data/overview/
http://road.cc/news

Nore: BBC objects did not remain if there were any, Road.cc objects did remain.
Comment 5 kie000 2018-03-02 14:53:47 UTC
Steps to repeat:

1. Visit almost any website (for example http://road.cc/news )

2. Ctrl-A, Ctrl-C, Wait until clipboard populated. OR select a big enough chunk of text and objects and Copy it.

3. In a blank calc: Ctrl-C, Wait until paste complete

4. Ctrl-Z

Row heights do not UNDO.
Pasted objects are not removed.
Comment 6 kie000 2018-03-02 14:54:55 UTC
Correction:
Step should Be Ctrl-V to paste not Ctrl-C,
Comment 7 Buovjaga 2018-03-10 14:30:13 UTC
Height issue is bug 107394.
Pictures issue is bug 39217

*** This bug has been marked as a duplicate of bug 107394 ***