Bug 106950 - FILEOPEN: RTF: centered paragraph attribute in title style is ignored
Summary: FILEOPEN: RTF: centered paragraph attribute in title style is ignored
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
QA Contact:
URL:
Whiteboard: target:5.5.0 target:5.4.0.1
Keywords: bibisected, bisected, filter:rtf, regression
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2017-04-04 14:25 UTC by Xisco Faulí
Modified: 2017-05-31 11:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-04-04 14:25:16 UTC
This is a follow-up bug of bug 105729

Steps to reproduce:
1. Open attachment  48870 [details] from bug 39053

Expected behaviour: Title 'Diagram Documentation' should be centered

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: fcad02149f3a9964f36522d97faaf303fc321788
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-03_06:21:10
Locale: es-ES (es_ES); Calc: group
Comment 1 Xisco Faulí 2017-04-04 14:26:19 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2017-01-03 07:49:43 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-01-03 10:56:29 (GMT)
commit	a9e029ace41562e28e9242d63230ad1ca275f5d3 (patch)
tree	605fee980e467c8a5896bdf5053fd7422865091a
parent	c9c5c94771f22919ec82351b3b9b3096af96a508 (diff)
tdf#104744 RTF import: fix unexpected zero para left margin wrt style dedup
See commit 1be0a3fa9ebb22b607c54b47739d4467acfed259 (n#825305:
writerfilter RTF import: override style properties like Word,
2014-06-17) for the details on style override in RTF.

Here the problem was that we added an unneeded "reset to 0" property, the
opposite situation that commit 657c6cc3acec0528209a8584b838cd6de581c437
(tdf#104228 RTF import: fix override of style left/right para margin,
2016-12-13) was fixing (there a "reset to 0" was missing).

bisected with bibisect-linux-64-5.4

Adding Cc: to Miklos Vajna
Comment 2 Commit Notification 2017-05-28 16:01:20 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e01c6a3ba7c0e6a089769187ee1ad241aa862280

Related: tdf#106950 sw: fix crash on opening this file

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2017-05-30 19:16:56 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=278bfe012a0e465cb8d08957fc07d2e5dcebdc81

tdf#106950 sw: support CharShadingValue property on paragraph styles

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2017-05-31 11:45:50 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a8889286995de5e51cd01e83101832f78e978fd9&h=libreoffice-5-4

Related: tdf#106950 sw: fix crash on opening this file

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-05-31 11:46:07 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a41b599b307f77aea4196c064ef015d03ca26a14&h=libreoffice-5-4

tdf#106950 sw: support CharShadingValue property on paragraph styles

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.