Download it now!
Bug 106980 - Touching "compatibility" options in LibO with X11 VCL breaks rulers in writer with MS Word documents
Summary: Touching "compatibility" options in LibO with X11 VCL breaks rulers in writer...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog Rulers
  Show dependency treegraph
 
Reported: 2017-04-05 18:40 UTC by sergio.callegari
Modified: 2018-06-24 16:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case (9.90 KB, application/vnd.oasis.opendocument.text)
2017-04-05 19:30 UTC, sergio.callegari
Details
Screenshot of testcase before touching compatibility options (13.27 KB, image/png)
2017-04-29 08:31 UTC, sergio.callegari
Details
Screenshot after pressing OK in the the compatibility options dialog (17.63 KB, image/png)
2017-04-29 08:32 UTC, sergio.callegari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2017-04-05 18:40:03 UTC
I am trying to work on a .doc file that was prepared by someone else on MS Word.
When I open the document with LibO, it looks fine. The document is formatted on an A4 page, with 20 mm left and right margin. The top ruler correctly shows numbers from 20 to 0 mm (the left margin), then the left margin and indent markers, then numbers from 0 to 170 mm (the paragraph space), then the right margin marker, then numbers from 170 to 190 mm, which looks fine, because the page is actually 210 mm wide, which is 20+190 mm.

Unfortunately, weird thing start to happen as soon as I touch the Tools->Options Libreoffice Writer->Compatibility dialog. Even if I do not change anything, as soon as I press the OK button, the ruler goes crazy.
now the ruler shows figures from about -24 to 0 mm for the left margin, then from 0 to 186mm for the left margin and from 186mm to 210 mm for the right margin, as if the page was ~ 243 mm wide.

In practice, the page width gets assigned to the paragraph space + right margin, rather than the left margin + paragraph space + right margin.

This makes it impossible to use the ruler to decide where tabs should go.
Comment 1 Xisco Faulí 2017-04-05 19:11:23 UTC
Hello,

Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 sergio.callegari 2017-04-05 19:30:15 UTC
Created attachment 132358 [details]
Test case

To reproduce:

1) Open test.odt (that is a doc file, saved as odt)
2) Go to Tools->Options->Libreoffice Writer->Compatibility
3) Press OK and see the top ruler go crazy

In the meanwhile I found a workaround too:

If, after 3 you save the document again and reopen it, it's fine.
Comment 3 Buovjaga 2017-04-23 16:04:23 UTC
No change here. Can you copy and paste the text in Help - About?

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.2.2
Build ID: 5.3.2-1
CPU Threads: 8; OS Version: Linux 4.10; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 4 sergio.callegari 2017-04-28 21:46:53 UTC
Here it is:

Version: 5.3.2.2
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: x11; Layout Engine: new; 
Locale: it-IT (en_US.utf8); Calc: single
Comment 5 Buovjaga 2017-04-29 05:33:32 UTC
(In reply to sergio.callegari from comment #4)
> Here it is:
> 
> Version: 5.3.2.2
> Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
> CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: x11; Layout
> Engine: new; 
> Locale: it-IT (en_US.utf8); Calc: single

Ok, that VCL: x11 is interesting. Could you try launching from the command line with

SAL_USE_VCLPLUGIN=gtk libreoffice

or

SAL_USE_VCLPLUGIN=gtk3 libreoffice

The change should be reflected in the Help - About - VCL.. Are you using Ubuntu? Perhaps you are missing the libreoffice-gtk3 package?
Comment 6 sergio.callegari 2017-04-29 08:15:53 UTC
Does not seem to make any difference:

- the breakage of the ruler when clicking OK in the compatibility options
  remains the same

- the about config dialog still reports VCL: x11

can this be because I do not have any gnome-integration or kde-integration package?
Comment 7 sergio.callegari 2017-04-29 08:31:15 UTC
Created attachment 132950 [details]
Screenshot of testcase before touching compatibility options
Comment 8 sergio.callegari 2017-04-29 08:32:06 UTC
Created attachment 132951 [details]
Screenshot after pressing OK in the the compatibility options dialog
Comment 9 sergio.callegari 2017-04-29 08:35:46 UTC
Haven't tested enough, but it looks like messing with the zoom is another way to get the correct ruler back.
Comment 10 Buovjaga 2017-04-29 15:20:12 UTC
(In reply to sergio.callegari from comment #6)
> can this be because I do not have any gnome-integration or kde-integration
> package?

Yep, please try installing libreoffice-gtk3 package. Are you on Ubuntu or something else?
Comment 11 sergio.callegari 2017-04-29 21:00:56 UTC
I'm on Kubuntu and using the LibO deb packages from Libreoffice rather than those from the distribution.
Comment 12 sergio.callegari 2017-04-29 21:05:13 UTC
The only packages that I do not install are the gnome-integration and the KDE-integration ones. This is because I'm on KDE, but in the past I found the kde integration to have minor annoyances. Cannot see a specific -gtk3 package.
Comment 13 Buovjaga 2017-04-30 07:35:13 UTC
(In reply to sergio.callegari from comment #12)
> The only packages that I do not install are the gnome-integration and the
> KDE-integration ones. This is because I'm on KDE, but in the past I found
> the kde integration to have minor annoyances. Cannot see a specific -gtk3
> package.

Then you should install the kde integration package and test.
Comment 14 sergio.callegari 2017-04-30 07:59:47 UTC
OK, now I see kde4 as the VCL and the issue with the ruler is gone. So the issue is with the default (x11) VCL.
Comment 15 Jean-Baptiste Faure 2018-06-24 16:56:02 UTC
Not reproducible for me with LibreOffice 6.1.0.0.beta2+ under Ubuntu 16.04 x86-64
with SAL_USE_VCLPLUGIN=gen

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF