Bug 106981 - The Repeat feature when you select an Inserted Video for it to play in a Loop during a slideshow no longer works (64-bit only)
Summary: The Repeat feature when you select an Inserted Video for it to play in a Loop...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected)
5.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
: 112864 113021 (view as bug list)
Depends on:
Blocks: Media
  Show dependency treegraph
Reported: 2017-04-05 18:44 UTC by branman2000
Modified: 2021-05-16 04:24 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description branman2000 2017-04-05 18:44:13 UTC
The Repeat feature when you select an Inserted Video for it to play in a Loop during a slideshow no longer works after Version of LibreOffice. The video will play for the allotted video time and then stop even if the repeat function has been selected on in the newer version of Libreoffice/impress. Version would allow the Video, such as motion backgrounds, to loop perfectly.

THank You for any help/fixes :)
Comment 1 Buovjaga 2017-04-23 13:33:52 UTC
Confirmed on Windows. Linux works, but there is a different bug and I created a report: bug 107368

Version: (x64)
Build ID: 193f8966135064a32164c9da08d01dab9c1fc15d
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-03-25_02:08:45
Locale: fi-FI (fi_FI); Calc: group
Comment 2 Aron Budea 2017-04-24 00:55:52 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2017-04-24 03:39:32 UTC
(In reply to Aron Budea from comment #2)
> I'm not seeing this, not in or an 5.4 master daily build
> (2017-04-13_15:11:43) / Windows 7.
> Is there a chance this depends on video format?

Well I tried with attachment 132767 [details]
Comment 4 branman2000 2017-04-24 17:17:33 UTC
The files I used were .WMV files from a site called MotionWorship.com.
Comment 5 Iceflower S 2017-06-10 18:56:17 UTC
Tried it with .avi, it is not working. (Daily Build 10.6. v5.5.0 win64)
Comment 6 raal 2017-10-05 19:14:03 UTC
*** Bug 112864 has been marked as a duplicate of this bug. ***
Comment 7 Mike 2017-10-07 18:08:22 UTC
The problem seems to be limited to the 64bit-version.

I did some testing with the same presentation:
- crashed,,, (x64)
- played once,,,, (x64)

- repeating (x32), (x32), (x32)

Being new to bugzilla I didn't change version or hardware for this bug report
Comment 8 Aron Budea 2017-10-07 22:35:20 UTC
Mike, that was very helpful, thanks! With a 64-bit release I can also repro. 
I'm adding that to the summary, and adjusting the version field to the oldest known version.

Also removing regression-related keywords, since it doesn't seem to be one. Branman2000, if you're certain the older versions where it worked were 64-bit as well, let us know.
Comment 9 R. Bingham 2017-10-09 18:53:46 UTC
See also bug 113021 which extends this bug with another instance and additional platform details.
Comment 10 R. Bingham 2017-11-10 01:21:04 UTC
*** Bug 113021 has been marked as a duplicate of this bug. ***
Comment 11 QA Administrators 2018-11-11 03:46:36 UTC Comment hidden (obsolete)
Comment 12 Roman Kuznetsov 2018-11-11 16:52:24 UTC
still repro in

Version: (x64)
Build ID: 0b2d153f58c83fb289c96b348631e44e553b1a9a
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2018-11-02_21:11:48
Locale: ru-RU (ru_RU); Calc: threaded
Comment 13 Paul Unger 2019-01-23 00:00:32 UTC
Also repro in stable release:
Version: (x64)
Build ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: en-CA (en_CA); Calc: group
Comment 14 Cor Nouws 2019-03-16 12:19:45 UTC
conform 112864, the bug is on Linux too.
Comment 15 Richard Marchessault 2019-09-08 20:04:09 UTC
I solved this problem on my 64 bit Windows 10 laptop by uninstalling the 64 bit version of LibreOffice and installing the 32 bit version Version: (x86). Looping now works just fine.
Comment 16 Richard Marchessault 2019-11-29 20:44:52 UTC
Tried the 64 bit version today. Video looping is still a problem. reverted to 32 bit version and video looping works just fine.
Comment 17 Xisco Faulí 2019-12-11 16:21:47 UTC
@Mark, I thought you might be interested in this issue
Comment 18 Timur 2021-05-04 12:20:18 UTC
I reproduced with LO 5.4 x64 for both OpenGL and GDI (no OpenGL).
With 6.4, GDI was OK, but OpenGL wasn't. 
With 7.1, both GDI and Skia (that replaced OpenGL) loop. 
So WFM per test in Windows with Webm attachment 132767 [details].

In my Linux, this file doesn't load, black screen. 
Whatever existing or new bug, it's for See Also.