Bug 106989 - LibreOffice is not treating dot the same way it does comma when spell checking
Summary: LibreOffice is not treating dot the same way it does comma when spell checking
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2017-04-06 12:43 UTC by Kruno
Modified: 2019-01-15 22:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kruno 2017-04-06 12:43:21 UTC
LibreOffice is not treating dot the same way it does comma when spell checking. LibreOffice will break 'word1,word2' appropriately and check every part separately but in 'word1.word2' LO will see the whole thing as one word which fails to provide good suggestion.

Workaround is to add 'BREAK .' in affix file but Hunspell do this right in command line (although it does dots (abbreviations) badly in general).

This trips some grammar checking rules such as adding space when two words are accidentally concatenated with dot: word1.word2 (> word1. word2) because LO is just showing red underline and there is now way user can access grammar checking suggestion by right mouse click on misspelled words. Spell checker can't provide good suggestion for this and a grammar checker is ignored completely.

Maybe for another bug report: if grammar checker is fired for the same error as that checker, both suggestion should be available with right click. Maybe even grammar checker's suggestion before that of spell checker.

Thanks
Comment 1 Kruno 2017-04-08 08:27:49 UTC
It's also bitting “ if there is no opening mark: tezt“ > test.

It will work fine in example: „This is tezt“
Comment 2 Kruno 2017-04-09 12:08:47 UTC
Can't reproduce every time. Sometimes depend if “ or ” used as closing mark. But problem with dot is constant.
Comment 3 Xisco Faulí 2017-04-11 12:28:54 UTC
Hello Kruno,

it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 4 Kruno 2017-04-11 13:50:21 UTC
Hi, behavior is the same with 5.2.6. This is not marked as misspelled: this,is,test; but then this is: This.is.test.

Grammar checking should propose space but those three words should not be treated as one. Workaround is to put

BREAK 1
BREAK .

in Hunspell's dictionary. I consider this to be a bug because one doesn't need 'BREAK ,' and LO still doesn't treat 'this,this' as one word.

I know 5.2.6 is not 'fresh' but I compiled it to test changes to locale file I plan to include in 5.4 but now I see that I can't 'make uninstall' to uninstall.

I'll test with fresh as soon I uninstall 5.2.6.
Comment 5 Kruno 2017-04-12 18:16:13 UTC
Just tested in 5.3.2, same: this.is.all.one.big.word. and suggestion for that word is unrelated to it's components.
Comment 6 Buovjaga 2017-04-26 09:10:57 UTC
Reproduced.

Win 7 Pro 64-bit, Version: 5.3.1.2 (x64)
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: fi-FI (fi_FI); Calc: CL
Comment 7 QA Administrators 2018-04-27 02:30:51 UTC Comment hidden (obsolete)
Comment 8 Kruno 2018-05-12 08:29:28 UTC
Still here on LibreOffice 6.0.4.1 on Debian Buster (curr testing).