Download it now!
Bug 106993 - Unable to apply/modify direct formatting of bullet/numbering character in the Bullets&Numbering Dialog
Summary: Unable to apply/modify direct formatting of bullet/numbering character in the...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bullet-Numbering-Dialog
  Show dependency treegraph
 
Reported: 2017-04-06 14:44 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-04-07 14:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast (2.55 MB, video/webm)
2017-04-06 14:44 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-04-06 14:44:28 UTC
Created attachment 132376 [details]
screencast

Steps:
1. Open Writer
2. Insert a bullet point and some text next to it
3. Click at bullet character and the notice the gray highlight color will appear around the bullet
4. Change the bullet font size from 12 to 32 and its color
5. Right-click > Bullets and Numbering...
6. There is no means in the dialog to modify these same formatting settings that i did in the document

Version: 5.4.0.0.alpha0+
Build ID: 0c551c86f701c1f1865760e122d901c933b8fbe5
CPU threads: 2; OS: Linux 3.19; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-04-06_00:40:42
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Cor Nouws 2017-04-06 15:06:21 UTC
Hi Jay,

I confirm the behavior :)
What is it that you want to achieve?
Obviously you do know that formating of these elements is by the associated character style.
(delaying setting of priority for now)

Ciao - Cor
Comment 2 Yousuf Philips (jay) (retired) 2017-04-06 15:18:40 UTC
(In reply to Cor Nouws from comment #1)
> Hi Jay,

Hi Cor,

> I confirm the behavior :)

Setting it to NEW. :D

> What is it that you want to achieve?
> Obviously you do know that formating of these elements is by the associated
> character style.

Yes i'm aware you can format it with character style, but if you can format it with direct formatting in the document, you should also be able to do so within the dialog, especially when the direct formatting formatting is overwriting the assigned character style.
Comment 3 Heiko Tietze 2017-04-06 15:59:21 UTC
Did the same as Jay and wasn't able to select just the bullet (LibO fresh on LXQt/Kwin/Breeze Dark). The only option for me is to go the hard way of character style - or to modify the complete item including the text. 

Rather than making it easier I'd suggest to disallow the direct formatting 

(And even drop the character style from the bullets/numbering, but that's how ODF defined it.)
Comment 4 Yousuf Philips (jay) (retired) 2017-04-06 16:19:16 UTC
(In reply to Heiko Tietze from comment #3)
> Did the same as Jay and wasn't able to select just the bullet (LibO fresh on
> LXQt/Kwin/Breeze Dark). The only option for me is to go the hard way of
> character style - or to modify the complete item including the text. 

I'd file a bug for that.

> Rather than making it easier I'd suggest to disallow the direct formatting 

Disabling direct formatting isnt really an option when you have existing documents already created in such a manner, not only in LO but also in MSO.

@Regina: Any thoughts?
Comment 5 Cor Nouws 2017-04-06 16:23:13 UTC
(In reply to Heiko Tietze from comment #3)
> Did the same as Jay and wasn't able to select just the bullet (LibO fresh on
> LXQt/Kwin/Breeze Dark). 

Clicking just in front of the bullet usually helps.

> Rather than making it easier I'd suggest to disallow the direct formatting 

Hèhè ;)

> (And even drop the character style from the bullets/numbering, but that's
> how ODF defined it.)

Hmm, that function allows me to set & manage different formatting for different list(styles).
Comment 6 Cor Nouws 2017-04-06 16:24:49 UTC
I'm tempted to say that it is logic that you'r not allowed to do direct formatting in the bullet/list styles dialog (also the 'default' numbering/bullets is a style, from what I'm told).

So then I would close this one as NotABug..
Comment 7 Regina Henschel 2017-04-06 18:03:29 UTC
If you change the appearance of the bullet "directly", then it is no really direct, but you are changing the associated character style. For the bullet list, which you get by the icon, it is "Bullets", for the numbered list, it is "Numbering Symbol". Such change affects all lists, which have this character style set for their symbol. 

To get the same from the "Bullet and Numbering" dialog, a button "Edit style" could be added, in case the style is not "None".

If the character style of the bullet is "None", (which means, that the setting of the paragraph is used), then you cannot change the bullet "directly", because there is no place to store the information.

Strangely, the character style is very inconsistent set in the default lists. The small dots from the presets have "Bullets", the large dots have "None" and the style List1 has "Numbering Symbols".
Comment 8 Yousuf Philips (jay) (retired) 2017-04-06 21:04:06 UTC
(In reply to Regina Henschel from comment #7)
> If you change the appearance of the bullet "directly", then it is no really
> direct, but you are changing the associated character style. For the bullet
> list, which you get by the icon, it is "Bullets", for the numbered list, it
> is "Numbering Symbol". Such change affects all lists, which have this
> character style set for their symbol. 

Thanks for the insight.

> To get the same from the "Bullet and Numbering" dialog, a button "Edit
> style" could be added, in case the style is not "None".

Already filed that one today (bug 107001).

> If the character style of the bullet is "None", (which means, that the
> setting of the paragraph is used), then you cannot change the bullet
> "directly", because there is no place to store the information.

Interesting. :D

> Strangely, the character style is very inconsistent set in the default
> lists. The small dots from the presets have "Bullets", the large dots have
> "None" and the style List1 has "Numbering Symbols".

That is bad. Please file a bug for this and CC me. Would be good to know why this has implemented so badly, but likely is from OOo days.
Comment 9 Thomas Lendo 2017-04-06 21:38:06 UTC
Is bug 57337 (FORMATTING: Configurable Default Bullet Styles) related to this?
Comment 10 Regina Henschel 2017-04-07 13:57:33 UTC
Yes bug 57337 is connected in the sense, that it is too about the fact, that direct formatting of bullet characters does not exist. So perhaps not close it as "invalid" but as "duplicate"

*** This bug has been marked as a duplicate of bug 57337 ***
Comment 11 Cor Nouws 2017-04-07 14:30:02 UTC
(In reply to Regina Henschel from comment #10)
> Yes bug 57337 is connected in the sense, that it is too about the fact, that
> direct formatting of bullet characters does not exist. So perhaps not close
> it as "invalid" but as "duplicate"
> 
> *** This bug has been marked as a duplicate of bug 57337 ***

The others complain that you can't change the default bullets. True, but moot when you just use the list styles.

IMO, not being able to change direct formatting in the dialogs of the lists, simply is NotABug.