Download it now!
Bug 106999 - Add feedback behaviour to style applying UNO commands, so that style is marked in menu and toolbar, when in use in text with focus
Summary: Add feedback behaviour to style applying UNO commands, so that style is marke...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks: Main-Menu Styles Toolbars Writer-Toolbar-Formatting-Styles Style-Formatting-Writer-Toolbar
  Show dependency treegraph
 
Reported: 2017-04-06 16:41 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-04-15 19:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-04-06 16:41:22 UTC
When using style applying UNO commands like .uno:StyleApply?Style:string=Standard&FamilyName:string=ParagraphStyles in the toolbar and menu bar, they dont provide feedback behaviour that it is applied, and this would be useful to have in the form of a toggle in button in the toolbar and a checkmarked entry in the menu bar.

@Maxim: Any thoughts if this is possible, or should we care a new UNO command for such a feature?
Comment 1 Cor Nouws 2017-04-06 17:34:19 UTC
Hi Jay,

Isn't the visible change in the doc, as with using the list Apply Style, enough?
IOW, what exactly do you mean?
Comment 2 Yousuf Philips (jay) (retired) 2017-04-06 17:44:11 UTC
(In reply to Cor Nouws from comment #1)
> Hi Jay,

Hi Cor,

> Isn't the visible change in the doc, as with using the list Apply Style,
> enough?

Go to the Style menu and click any of the styles, then open up the menu again, can you see which style has been applied?

No need to reset enhancements to UNCONFIRMED. :D
Comment 3 Maxim Monastirsky 2017-05-09 14:21:24 UTC
Let's try this one.
Comment 4 Yousuf Philips (jay) (retired) 2017-05-10 04:28:26 UTC
(In reply to Maxim Monastirsky from comment #3)
> Let's try this one.

Thanks.
Comment 5 Commit Notification 2017-05-14 09:10:55 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b91fb08fd63207e663dca83abe1305d8025b4b48

tdf#106999 Feedback for style commands

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Thomas Lendo 2017-05-16 21:21:52 UTC
Maxim, you're great!
Set to VERIFIED FIXED.

Tested with Writer, Calc and Draw.
In Impress I couldn't test it successfully because I don't understand its style system.

Version: 5.4.0.0.alpha1+
Build ID: 666901bc82fab69f9a80b564f97b5456d0ef684e
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-16_03:33:45
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 7 Yousuf Philips (jay) (retired) 2017-05-17 15:52:40 UTC
Thanks Maxim. It looks great. Any way to disable the feature for particular entries as Insert > Horizontal Line shouldnt look like a checkbox.