Bug 107006 - Form control properties / Background color / Can only apply recently-used colors
Summary: Form control properties / Background color / Can only apply recently-used colors
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.1.2 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, regression
Depends on:
Blocks: Color-Picker-Dialog Form-Controls
  Show dependency treegraph
 
Reported: 2017-04-06 20:45 UTC by Mike
Modified: 2018-05-11 20:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots to illustrate the issue (45.47 KB, image/png)
2017-04-06 21:32 UTC, Mike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2017-04-06 20:45:08 UTC
Description:
In Writer, the only way to change the background color of a form control is to select a color from the recently-used colors. Selecting a color from the default options will not change the color.

Steps to Reproduce:
1. In Writer, create a form control, such as list box or combo box.
2. The control's Properties box, open "Background color".
3. Select any color. 
   The control will NOT change to that color.
   The color WILL be added to the collection of recently used colors.
4. Click any color from the recently-used colors.
   The control WILL change to the color you clicked.


Actual Results:  
All is described in the Steps to Reproduce

Expected Results:
All is described in the Steps to Reproduce


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Mike 2017-04-06 20:50:48 UTC
To be more accurate, it's not that clicking a color from the palette does nothing; that action turns the control white. 

To demonstrate, turn the control a different color by selecting a recently-used color. Then click a color from the palette. The control will not remain the same color--it will turn white.
Comment 2 Mike 2017-04-06 21:32:26 UTC
Created attachment 132388 [details]
Screenshots to illustrate the issue
Comment 3 Alex Thurgood 2017-04-07 11:21:35 UTC
Probably due to the changes in colour palette management that were recently introduced.

Confirming ==>> regression


Tested on 

Version: 5.3.1.2
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
Threads CPU : 8; Version de l'OS :Mac OS X 10.12.3; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 4 Alex Thurgood 2017-04-07 11:27:38 UTC
No problems with

ersion: 5.2.6.2
Build ID: a3100ed2409ebf1c212f5048fbe377c281438fdc
Threads CPU : 8; Version de l'OS :Mac OS X 10.12.3; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

which uses the old colour palette management
Comment 5 Alex Thurgood 2017-04-07 11:28:37 UTC
@Heiko : this is a rather annoying side-effect of the new colour palette management and selection.
Comment 6 Heiko Tietze 2017-04-07 12:16:09 UTC Comment hidden (obsolete)
Comment 7 Heiko Tietze 2017-04-07 12:23:39 UTC
Once again in English ;-)

The color picker looks like everywhere else and you can select palettes and colors. But the picked color isn't applied to the control. However, it works when the recent colors are uses.

Version: 5.3.1.2
Build ID: 5.3.1-1
CPU Threads: 8; OS Version: Linux 4.10; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 8 QA Administrators 2018-05-11 02:33:12 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug