Download it now!
Bug 107011 - Flow of text in a cell behave strangely in print/PDF
Summary: Flow of text in a cell behave strangely in print/PDF
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export Print
  Show dependency treegraph
 
Reported: 2017-04-07 08:42 UTC by Marco Gaiarin
Modified: 2018-07-03 14:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File (27.59 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-04-07 08:42 UTC, Marco Gaiarin
Details
pdf print (37.40 KB, application/pdf)
2017-04-07 08:43 UTC, Marco Gaiarin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Gaiarin 2017-04-07 08:42:40 UTC
Created attachment 132392 [details]
File

Attached a OpenDocument Spreadsheet document created with Calc, that behave strangely on LO 5.2 when printed (preview or print) or converted to PDF (test conversion attached).

As you can see, raw 9 and 41 look correctly on file, but print wrong.
Seems not a simple matter of cell dimension/spacing.

Also, i've tried to open the file with LO 5.1 (5.1.6.2, Ubuntu) and behave correctly, correctly displaying in program and in print/preview/pdf.

Thanks.
Comment 1 Marco Gaiarin 2017-04-07 08:43:07 UTC
Created attachment 132393 [details]
pdf print
Comment 2 Sebastien edouard 2017-04-16 22:38:41 UTC
could not reproduce bug. No text overlay

Version 5.3.2 Windows 10 64bit
Comment 3 Xisco Faulí 2017-04-17 10:11:35 UTC
Hello Marco,

Thank you for reporting the bug.

I can't reproduce it in
Version: 5.3.2.2
Build ID: 1:5.3.2~rc2-0ubuntu1~yakkety0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: es-ES (ca_ES.UTF-8); Calc: group

Could you please try to reproduce it with version 5.3.2.2 of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 4 Marco Gaiarin 2017-05-12 09:32:01 UTC
Sorry, i was busy on other things, and i've not found the time to test LO 'fresh' (5.3).

But i've just upgrade to LO 5.2.7, and the bug desappeared!

I've tried to look at:
 https://wiki.documentfoundation.org/Releases/5.2.7/RC1#List_of_fixed_bugs
 https://wiki.documentfoundation.org/Releases/5.2.7/RC2#List_of_fixed_bugs

but i've found nothing relevant (at least for me).


Anyway, thanks.
Comment 5 Xisco Faulí 2017-11-13 17:55:14 UTC
Hi Marco,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
Comment 6 QA Administrators 2018-05-30 16:39:51 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2018-07-03 14:19:09 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20180703