Bug 107016 - EMF+ EmfPlusRecordTypeDrawRects is not implemented
Summary: EMF+ EmfPlusRecordTypeDrawRects is not implemented
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All All
: medium normal
Assignee: Bartosz
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.2.8 target:5.3.4
Keywords:
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2017-04-07 12:41 UTC by Bartosz
Modified: 2017-04-28 21:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File on which the border is not displayed (19.58 KB, image/emf)
2017-04-07 12:42 UTC, Bartosz
Details
How it should looks likeb (4.64 KB, image/png)
2017-04-07 15:13 UTC, Bartosz
Details
Affected file which do not display border (21.48 KB, image/x-emf)
2017-04-12 11:09 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz 2017-04-07 12:41:53 UTC
Description:
The EmfPlusRecordTypeDrawRects record for EMF+ is not implemented.

Steps to Reproduce:
1. Open attached EMF file in Writer


Actual Results:  
Black border around box is not existing.

Expected Results:
Black border around box should be displayed


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/56.0.2924.76 Chrome/56.0.2924.76 Safari/537.36
Comment 1 Bartosz 2017-04-07 12:42:38 UTC
Created attachment 132397 [details]
File on which the border is not displayed
Comment 2 Bartosz 2017-04-07 12:52:47 UTC
Review:
https://gerrit.libreoffice.org/#/c/36261/1
Comment 3 Bartosz 2017-04-07 15:13:15 UTC
Created attachment 132400 [details]
How it should looks likeb
Comment 4 Commit Notification 2017-04-11 09:03:51 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a45feba83e5fb35eee1884887e8dbe795ebacde5

tdf#107016 EMF+ Add support of import EmfPlusRecordTypeDrawRects record

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Bartosz 2017-04-12 11:09:45 UTC
Created attachment 132516 [details]
Affected file which do not display border
Comment 6 Commit Notification 2017-04-13 17:48:55 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3f09dcbd5e6aafe42d02c7b51497007abcdf1f7&h=libreoffice-5-2

tdf#107016 EMF+ Add support of import EmfPlusRecordTypeDrawRects record

It will be available in 5.2.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2017-04-28 21:05:07 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=08fe3b0f1c1e72f15db1cd70d85effa3d63db276&h=libreoffice-5-3

tdf#107016 EMF+ Add support of import EmfPlusRecordTypeDrawRects record

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.