Download it now!
Bug 107065 - VIEWING: Table border edges are incorrectly displayed
Summary: VIEWING: Table border edges are incorrectly displayed
Status: RESOLVED DUPLICATE of bug 81643
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2017-04-10 11:06 UTC by Thomas Lendo
Modified: 2017-04-11 18:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Table border edges test file (LibO 5.3.2.1) (9.43 KB, text/odt)
2017-04-10 11:06 UTC, Thomas Lendo
Details
Table border screenshot with LibO 3.3.0 (27.96 KB, image/png)
2017-04-10 11:10 UTC, Thomas Lendo
Details
Table border screenshot with LibO 5.3.1.2 (28.23 KB, image/png)
2017-04-10 11:11 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-04-10 11:06:24 UTC
Created attachment 132444 [details]
Table border edges test file (LibO 5.3.2.1)

In normal view and print preview, the table border edges are incorrectly displayed. They're shown as if 2 bars were put together but only to their centerlines and not to their outer edges.

Prints (on paper or in PDF files) are OK and don't show this issue.

It must be a regression in LibO because in OOo the edges look fine also in normal and print view.

STR:
- Open Writer and insert a table.
- Go to "Table properties..." (in context menu) > Borders.
- Activate "Set outer border and all inner lines" (or outer border only).
- Set a big width (e.g. 9 pt).

Actual result:
Table borders are incorrectly displayed in normal view and print preview.

Expected result:
Table borders should be displayed as in prints with full edges.

Tested with

Version: 5.3.1.2
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; Locale: de-DE (de_DE); Calc: CL

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 1 Thomas Lendo 2017-04-10 11:10:45 UTC
Created attachment 132445 [details]
Table border screenshot with LibO 3.3.0
Comment 2 Thomas Lendo 2017-04-10 11:11:10 UTC
Created attachment 132446 [details]
Table border screenshot with LibO 5.3.1.2
Comment 3 Regina Henschel 2017-04-10 11:34:19 UTC
It is OK in Version: 4.2.0.0.alpha0+
Build ID: 8624906bc437b242ea0df17801bc77d0f273f32c
TinderBox: Win-x86@6, Branch:master, Time: 2013-07-05_04:07:10

It is broken in Version: 4.2.2.1
Build-ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f

(I haven't got any version in between.)
Comment 4 Xisco Faulí 2017-04-11 15:22:46 UTC
Regression introduced by 15974abe63f0d4fc88099634d5cd2ddb9760ec23
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 81643 ***
Comment 5 Thomas Lendo 2017-04-11 18:37:39 UTC
Huh, sorry, haven't found that bug or its 7(!) duplicates.

Target 4.4.0 is a long time ago ...