Bug 107082 - FILEOPEN XLSX: Autofiltered date cell is hidden, but does not appear as filtered in the list
Summary: FILEOPEN XLSX: Autofiltered date cell is hidden, but does not appear as filte...
Status: RESOLVED DUPLICATE of bug 116818
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX-Autofilter
  Show dependency treegraph
 
Reported: 2017-04-10 20:22 UTC by Gabor Kelemen (allotropia)
Modified: 2021-01-21 11:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The problematic document (8.24 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-04-10 20:22 UTC, Gabor Kelemen (allotropia)
Details
Same document in ODS (10.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-04-10 20:23 UTC, Gabor Kelemen (allotropia)
Details
Screenshot of the problem 2016 shown as enabled (104.57 KB, image/png)
2017-04-10 20:26 UTC, Gabor Kelemen (allotropia)
Details
Correct in ODS (104.06 KB, image/png)
2017-04-10 20:26 UTC, Gabor Kelemen (allotropia)
Details
Screenshot in Excel, the value of 2016... is disabled (7.34 MB, image/jpeg)
2017-04-10 20:28 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2017-04-10 20:22:48 UTC
Created attachment 132457 [details]
The problematic document

Attached XLSX file from Excel 2013 has some Date type cells with autofilter set to filter out the value in row 3.
When opened in LO 5.4 alpha the row is hidden, but in the autofilter list the value appears as still enabled.

Saving the document in ODS, filtering out the 3rd row and reopening shows correctly the value as filtered out.
Comment 1 Gabor Kelemen (allotropia) 2017-04-10 20:23:15 UTC
Created attachment 132458 [details]
Same document in ODS
Comment 2 Gabor Kelemen (allotropia) 2017-04-10 20:26:02 UTC
Created attachment 132459 [details]
Screenshot of the problem 2016 shown as enabled
Comment 3 Gabor Kelemen (allotropia) 2017-04-10 20:26:24 UTC
Created attachment 132460 [details]
Correct in ODS
Comment 4 Gabor Kelemen (allotropia) 2017-04-10 20:28:00 UTC
Created attachment 132461 [details]
Screenshot in Excel, the value of 2016... is disabled
Comment 5 m.a.riosv 2017-04-10 20:59:45 UTC
Reproducible.
Version: 5.3.2.2 (x64)
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: es-ES (es_ES); Calc: group
Comment 6 Eike Rathke 2017-06-30 15:08:53 UTC
Seems the OOXLM filter doesn't import/handle the <dateGroupItem> elements yet, of <autoFilter><filterColumn><filters>. See sc/source/filter/oox/autofilterbuffer.cxx DiscreteFilter context created from sc/source/filter/oox/autofiltercontext.cxx FilterColumnContext::onCreateContext()
Comment 7 Balázs Varga 2021-01-21 11:35:54 UTC

*** This bug has been marked as a duplicate of bug 116818 ***