Bug 107105 - Implement context menu in the formula bar
Summary: Implement context menu in the formula bar
Status: RESOLVED DUPLICATE of bug 57000
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2017-04-11 23:29 UTC by fiftyigfuci_f_mi
Modified: 2017-04-18 15:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fiftyigfuci_f_mi 2017-04-11 23:29:38 UTC
Description:
It would be useful if a user can use a edit context menu such as copy, paste, cut... in the formula bar.

Steps to Reproduce:
1. Focus to the formula bar
2. Click a right mouse button

Actual Results:  
Nothing happened.

Expected Results:
Open a context menu.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Buovjaga 2017-04-17 17:14:06 UTC
Keyboard shortcuts work. Design team: what do you say?
Comment 2 V Stuart Foote 2017-04-17 18:35:06 UTC
Similar request for context menu in the sm Formula input field as well (see also bug 106479), as there, the Formula Input line field responds to OS clipboard and the main menu Edit -> Select, Cut, Copy, Paste are all enabled working in the control.

So, should be able to create the context menu controls.

Maxim?
Comment 3 Yousuf Philips (jay) (retired) 2017-04-18 13:47:56 UTC

*** This bug has been marked as a duplicate of bug 57000 ***
Comment 4 V Stuart Foote 2017-04-18 14:40:39 UTC
Thanks Jay! I thought there was an open issue for it--but I couldn't locate it.
Comment 5 Yousuf Philips (jay) (retired) 2017-04-18 15:28:23 UTC
(In reply to V Stuart Foote from comment #4)
> Thanks Jay! I thought there was an open issue for it--but I couldn't locate
> it.

Knew it must have been there, but unfortuantely it wasnt in the meta bug, so i added it. :D