Download it now!
Bug 107118 - EDITING displayed values of size attributes of objects are wrong, possible conversion or rounding error, affects actual size when edited
Summary: EDITING displayed values of size attributes of objects are wrong, possible co...
Status: RESOLVED DUPLICATE of bug 99711
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.2.6.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-12 12:45 UTC by file-a-bug
Modified: 2017-04-12 14:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description file-a-bug 2017-04-12 12:45:11 UTC
Description:
When you use the dialog box to edit the position and size attributes of a shape the post decimal positions of the displayed size values change by themselves. Position and size remain correct though.

This error will have impact on the actual size when one of the values is edited because the other value will be set according to the faulty display value.

Steps to Reproduce:
1. open a new draw document
2. use the rectangle tool to draw a new shape by mouse
3. edit position and size in the dialog box or the sidebar
4. position the object at 0cm/0cm and set its size to 6cm/4cm
5. use the rectangle tool to draw a second rectangle
6. position the second rectangle at 6cm/4cm and resize it to 2cm/2cm using the dialog box or the side bar
7. zoom in to see that the lower right corner of the first shape and the upper left corner of the second shape meet perfectly
8. click on the first shape and check its values. you will notice that it is still positioned ad 0cm/0cm but its size is displayed 5.99cm/3.99cm.
9. click on the second shape and you will see a position of 6.00cm/4.00cm and a displayed size of 2.01cm/2.01cm
10. click on the first shape again and set its width to 6.1cm.
11. notice that the wrong height value of 3.99 has been set, too.


Actual Results:  
Displayed values do not match actual values.
Faulty display values affect actual values when editing.

Expected Results:
Displayed values should match actual values.
Attribute values not altered in editing should not erroneously be changed.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 file-a-bug 2017-04-12 12:51:40 UTC
I'm sorry I've been unclear about the fact, that it doesn't matter if you set the original values by dialog box or side bar but only the values displayed in the sidebar are affected by this bug.
Comment 2 Regina Henschel 2017-04-12 13:39:22 UTC
Please look, whether bug 100632 describes the same problem.
Comment 3 Regina Henschel 2017-04-12 13:53:33 UTC
Excuse me, wrong number, see bug 99711
Comment 4 file-a-bug 2017-04-12 14:33:51 UTC
Yes, bug 99711 seems to describe the same problem.
Comment 5 file-a-bug 2017-04-12 14:34:16 UTC

*** This bug has been marked as a duplicate of bug 99711 ***