Bug Hunting Session
Bug 107167 - [EDITING] Space at the end of the line when there is ligature using font Linux Libertine G
Summary: [EDITING] Space at the end of the line when there is ligature using font Linu...
Status: RESOLVED DUPLICATE of bug 105913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-04-14 19:39 UTC by Vera
Modified: 2018-04-27 03:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document for the issue (6.91 MB, application/vnd.oasis.opendocument.text)
2017-04-14 19:43 UTC, Vera
Details
Screen shot (80.23 KB, image/png)
2017-04-26 16:21 UTC, Vera
Details
Sample document with justified text (6.91 MB, application/vnd.oasis.opendocument.text)
2017-04-26 16:22 UTC, Vera
Details
Space at the end of the line without ligature (12.42 KB, application/vnd.oasis.opendocument.text)
2017-04-29 16:40 UTC, Vera
Details
Space position without ligature (74.04 KB, image/png)
2017-04-29 16:41 UTC, Vera
Details
Sample file without any ligatures (12.45 KB, application/vnd.oasis.opendocument.text)
2017-04-29 17:24 UTC, Vera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera 2017-04-14 19:39:44 UTC
Description:
When I use font Linux Libertine G, and a word ends with ligature and that word is the last in the line, there is a space at the end of the line.

I tried with:
LibreOffice versions: 4.2.8.2, 5.0.5.2, 5.1.2.2, 5.1.4.2, 5.1.5.2, 5.2.2.2, 5.3.1.2 and 5.3.2.2
Linux Libertine G version: 5.1.3
OS: Ubuntu 14.04, Ubuntu 16.04, Xubuntu 16.04, Ubuntu 16.10, Ubuntu 17.04, Windows 7, Windows 10



Steps to Reproduce:
1. Create new document in Writer using font Linux Libertine G and enabled ligatures
2. Write some text in a line
3. Write a word which ends with ligature (for example "tt", "ft", "ff") as a last word in the line
4. Display nonprinting characters (Ctrl+F10)
5. Zoom to see the space at the end of the line if needed


Actual Results:  
There is a space at the end of the line.

Expected Results:
There should be no space at the end of the line.


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Vera 2017-04-14 19:43:31 UTC
Created attachment 132574 [details]
Sample document for the issue

I attached a test document with embedded fonts which is created by LibreOffice Writer 5.3.2.2 on Xubuntu 16.04.
Comment 2 Buovjaga 2017-04-26 11:59:59 UTC
(In reply to Vera from comment #0)
> Expected Results:
> There should be no space at the end of the line.

Why? Is this some rule regarding ligatures that the space at the end of the line should be hidden?
Comment 3 Vera 2017-04-26 16:21:14 UTC
Created attachment 132867 [details]
Screen shot
Comment 4 Vera 2017-04-26 16:22:09 UTC
Created attachment 132868 [details]
Sample document with justified text
Comment 5 Vera 2017-04-26 16:23:23 UTC
(In reply to Buovjaga from comment #2)
> (In reply to Vera from comment #0)
> > Expected Results:
> > There should be no space at the end of the line.
> 
> Why? Is this some rule regarding ligatures that the space at the end of the
> line should be hidden?

The space at the end of the line is hidden when the word is "regular" (there is no ligature at the end of the word), and should be hidden regardless of the ligature at the end of the word.


The space at the end of the line is really annoying when the text alignment is justified. I attached a screen shot and the ODT.
Comment 6 Buovjaga 2017-04-26 17:20:37 UTC
(In reply to Vera from comment #4)
> Created attachment 132868 [details]
> Sample document with justified text

Thanks, I see it with mellett and bélyesefi.

We would be very happy to see you continue doing quality assurance:
https://wiki.documentfoundation.org/QA/GetInvolved
https://wiki.documentfoundation.org/QA/IRC

Confirmed with:
Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: f69424ff90f83136027df3063d4c8ddafdf79faa
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 25th 2016
Comment 7 Khaled Hosny 2017-04-26 21:59:01 UTC
My guess is the character width (aka DXArray) calculation is broken by the presence of the ligatures,  as evidenced by the misplaced cursor and space bullet as soon as ligatures are encountered.

This is most likely the same underlying issue as bug 105913.
Comment 8 Vera 2017-04-29 16:40:26 UTC
Created attachment 132953 [details]
Space at the end of the line without ligature
Comment 9 Vera 2017-04-29 16:41:12 UTC
Created attachment 132954 [details]
Space position without ligature
Comment 10 Vera 2017-04-29 17:24:48 UTC
Created attachment 132955 [details]
Sample file without any ligatures

Without ligatures there is no problem with the cursor and space positions.
Comment 11 Vera 2017-04-29 17:32:37 UTC
Hi all,

I modified the previous sample file to have no ligature at the end of the line. I thought the space will disappear from the end of the line, but it stays. See attachment 132953 [details].

I discover that I can not position the cursor right before given words for example "regen" from the second line and "hegényből" from the fourth line. But there is another "hegényből" in the fifth line which is good. See attachment 132954 [details].

It is interesting, so I investigated that words. If you notice, before "regen" and "hegényből" from the fourth line there are words which ends with ligature. If I remove the ligatures, the cursor position will be good and there will be no space at the end of the line. See attachment 132955 [details].

If there is anything else I can do, please let me know.



I tried in LibreOffice
Version: 5.3.2.2
Build ID: 1:5.3.2~rc2-0ubuntu1~xenial0
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: hu-HU (hu_HU.UTF-8); Calc: single

and

Version: 5.4.0.0.alpha0+
Build ID: 74ccd02eda2d6325a27266fd935aba29b3d75020
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-04-27_23:51:14
Locale: hu-HU (hu_HU.UTF-8); Calc: group
Comment 12 Khaled Hosny 2018-04-27 03:37:29 UTC

*** This bug has been marked as a duplicate of bug 105913 ***