Bug 107198 - Delay when opening popup menu in empty area of Slides pane with Skia or OpenGL enabled
Summary: Delay when opening popup menu in empty area of Slides pane with Skia or OpenG...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Main-Loop Skia
  Show dependency treegraph
 
Reported: 2017-04-16 05:49 UTC by Aron Budea
Modified: 2022-09-16 17:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-04-16 05:49:54 UTC
Right click in empty area of Slides pane in Impress.
There is a noticeable lag between the appearance of the grey rectangle in place of the popup's area and its contents (both with default and GL rendering). There's no delay when you right click over a slide.

Reproduced with 5.3.2.2 and 5.0.0.5 / Windows 7. Not reproduced with 4.4.0.3
=> regression.

Bibisected to the following range:
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=e6e8a060ecc6e4fd51cfe88e00d841d546ed5915..9b4abcd1c45a646a1ac9120fe1c489ba6bb44e95

This is the same range as raal's for bug 94038's, so the two issues seem to be related. However, I found no evidence that the cause is the exact same, so I'm opening a separate report.
Comment 1 Aron Budea 2017-04-16 05:50:52 UTC Comment hidden (bibisection)
Comment 2 Telesto 2017-04-16 10:49:19 UTC
Confirming with:
Version: 5.4.0.0.alpha0+
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-05_23:32:27
Locale: nl-NL (nl_NL); Calc: CL

and no repro with:
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL

Setting to NEW
Comment 3 Xisco Faulí 2017-09-13 18:09:15 UTC
Hi Aron,
bug 94038 has been closed as RESOLVED WORKSFORME. Could you please check whether this one has faced the same destiny ?
Comment 4 Aron Budea 2017-09-13 18:39:23 UTC
Hi Xisco,

With default rendering the delay is gone (it's there in 5.4.1.2, so the fix happened since, possibly during scheduler changes).

With GL rendering the delay persists, which is strange.
Tested with a build from a couple of days ago (2e409c0ffe311eca849c1153d013e7a5260993bd).
Comment 5 Xisco Faulí 2017-09-14 10:34:48 UTC Comment hidden (bibisection)
Comment 6 Aron Budea 2018-02-15 18:50:22 UTC
I was curious, it's the following commit that fixed this issue with default rendering:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b22526b8ad88f5061b1901914e280ba9c8db1fe7
author		Jan-Marek Glogowski <glogow@fbihome.de>	2017-01-25 15:49:44 +0100
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2017-07-13 12:10:22 +0200

Introduce a scheduler stack
Comment 7 Telesto 2019-07-08 20:35:01 UTC
Repro with
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 849b837d1a3b185a8dd893a8f6eaed53605bcab1
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-05_03:53:49
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 8 Buovjaga 2020-08-28 13:15:41 UTC
As Skia with Vulkan will replace OpenGL UI rendering on all platforms, it does not make sense to keep OpenGL UI reports open.

Details about Skia: https://www.collaboraoffice.com/success-story/implementing-vulkan-capable-libreoffice-user-interface-using-the-skia-library/
Comment 9 Telesto 2020-08-28 18:47:42 UTC
Still present with Skia
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 6640d7f405d2970ba2825a9455926cc803284d01
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

I'm already a large number of bugs attached to my account, so leave it to somebody else to create a new one or reopen/recycling this one
Comment 10 QA Administrators 2022-08-29 06:42:49 UTC Comment hidden (obsolete)
Comment 11 Roman Kuznetsov 2022-09-16 17:58:58 UTC
Still repro in

Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: bff60eadeac348024849d710690435ee9580831b
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded