Bug 107206 - form control List Box drop down does not work
Summary: form control List Box drop down does not work
Status: RESOLVED DUPLICATE of bug 95852
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 114146 (view as bug list)
Depends on:
Blocks: Form-Controls
  Show dependency treegraph
 
Reported: 2017-04-16 16:58 UTC by Regina Henschel
Modified: 2018-10-16 16:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test file with drop down list box (8.19 KB, application/vnd.oasis.opendocument.graphics)
2017-04-16 16:58 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2017-04-16 16:58:57 UTC
Created attachment 132609 [details]
Test file with drop down list box

Add a form control "List Box" to a Draw document without connecting to a data base. Add some items to field "list entries" in the tab "General" in the properties dialog. Set field "DropDown" to "Yes" and "Multiselection" to "No".
Switch off edit mode.
Test, the drop down list. It does nothing. No selection possible.

The same works in Writer without problems.

It was OK in Version: 4.4.0.0.alpha0+
Build ID: aa453de65b8b44f9c1e6012caaeef11df9ff65fc
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-24_13:45:34

It fails since Version: 4.4.0.3
Build-ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Gebietsschema: de_DE
Comment 1 Xisco Faulí 2017-04-16 20:14:52 UTC
Regression introduced by:

author	Marco Cecchetti <mrcekets@gmail.com>	2014-11-05 19:15:32 (GMT)
committer	Marco Cecchetti <mrcekets@gmail.com>	2014-11-05 19:21:43 (GMT)
commit 967a386bccb15b99915a1e878e42450fbe9a2d0e (patch)
tree 7ed8cae5a3a1967b0661a0bec579d79bc5035d14
parent a9a9718bb1f64318429562ecdaa3d3763d9e2f4a (diff)
Fix for SUSE L3 bug 624546 (freedesktop 83733)

Adding Cc: to Marco Cecchetti
Comment 2 Regina Henschel 2017-04-17 20:40:58 UTC
Likely the same reason: You cannot enter any text into a List Box -control in Draw. So after fixing this bug, try the other controls too.
Comment 3 Buovjaga 2017-11-29 16:47:13 UTC
*** Bug 114146 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2018-10-16 16:03:30 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=967a386bccb15b99915a1e878e42450fbe9a2d0e which is the same as in bug 95852
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 95852 ***