Bug Hunting Session
Bug 107208 - Blue warning dialog 'document is in read-only mode 'stays behind after clicking Edit Document with a DOC file
Summary: Blue warning dialog 'document is in read-only mode 'stays behind after clicki...
Status: RESOLVED DUPLICATE of bug 106366
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-04-16 19:22 UTC by Telesto
Modified: 2017-05-12 15:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (9.00 KB, application/msword)
2017-04-16 19:22 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-04-16 19:22:17 UTC
Description:
Blue warning dialog 'document is in read-only mode' stays behind after clicking Edit Document with a DOC file. The file can be edited. No issue with odt and docx

Steps to Reproduce:
1. Open attached file.
2. Click Edit Document

Actual Results:  
Blue warning dialog 'document is in read-only mode' stay's behind after clicking Edit Document

Expected Results:
The dialog should disappear


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-05_23:32:27
Locale: nl-NL (nl_NL); Calc: CL

but not in
Versie: 5.3.0.3 
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; Layout-Engine: nieuw; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-04-16 19:22:36 UTC
Created attachment 132616 [details]
Example file
Comment 2 Xisco Faulí 2017-04-17 10:37:11 UTC
regression introduced by:

author	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2017-02-23 14:12:34 (GMT)
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2017-02-23 15:35:33 (GMT)
commit	aa8efc72d43c2000cb3b5571fdc6b48617eb9b94 (patch)
tree	e6c7df22af47e2d14fbfa3d4970b1c8586530e3b
parent	544104b957e72cfb5701cd949bca5184324d20ed (diff)
tdf#101652 No infobar when doc attr is readonly
One can set the a document attribute to open the doc read-only.
In this case the read-only infobar should not be shown.

bisected with bibisect-linux-64-5.4.

Adding Cc: to Samuel Mehrbrodt
Comment 3 Telesto 2017-05-12 15:06:45 UTC

*** This bug has been marked as a duplicate of bug 106366 ***