Bug 107229 - [LOCALHELP] Review help pages for Templates
Summary: [LOCALHELP] Review help pages for Templates
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: target:5.4.0 target:5.4.0.1 target:7....
Keywords:
Depends on: 94454
Blocks: HelpGaps-NewFeatures 107299
  Show dependency treegraph
 
Reported: 2017-04-17 10:39 UTC by Olivier Hallot
Modified: 2021-01-14 16:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
proposal for guide page about file locations and name and template manager (198.52 KB, application/vnd.oasis.opendocument.graphics)
2020-12-24 09:11 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2017-04-17 10:39:33 UTC
With the current Template manager dialog and the changes in the menus for templates, many help pages are outdated and obsolete.

Some of the files to review are

text/shared/guide/aaa_start.xhp
text/shared/guide/standard_template.xhp
text/shared/01/01110000.xhp
text/shared/01/01110300.xhp
text/shared/01/01110400.xhp
text/shared/01/01020000.xhp
text/swriter/guide/template_default.xhp
text/swriter/guide/template_create.xhp
text/swriter/guide/templates_styles.xhp
Comment 1 Xisco Faulí 2017-04-17 10:51:56 UTC
*** Bug 107227 has been marked as a duplicate of this bug. ***
Comment 2 Xisco Faulí 2017-04-17 10:52:00 UTC
*** Bug 107228 has been marked as a duplicate of this bug. ***
Comment 3 Gabor Kelemen 2017-04-22 10:07:08 UTC
source/text/shared/01/01010100.xhp as well.
Comment 4 Gabor Kelemen 2017-05-12 22:54:10 UTC
An overview of what is ahead of us:

text/shared/guide/aaa_start.xhp
Short mention of the window, one element needs a rename. 

text/shared/guide/standard_template.xhp 
Changing Default Templates: How to save a template and set it as default.  

text/shared/01/01110000.xhp
File - Templates menu item description. Needs a rewrite.

text/shared/01/01110300.xhp
File - Templates - Save as Template menu item (.uno:SaveAsTemplate) description. Needs a rewrite.

text/shared/01/01110400.xhp
File - Templates - Open Template menu item (.uno:OpenTemplate) description. Needs some updates.

text/shared/01/01020000.xhp
File - Open menu item description. Needs some updates on its own and apart from that this has some long dead template-related features documented which probably can be dropped. 

text/swriter/guide/template_default.xhp
Changing the Default Template: How to save a new document as a template and how to set it as default. Sounds familiar :).

text/swriter/guide/template_create.xhp
Creating a Document Template: How to save a new document as a template and how to open it as one. This describes mostly the current UI, so probably this can stay out of the three similar pages. 

text/swriter/guide/templates_styles.xhp
Templates and Styles: definitions and related topics. Mostly okay but short. Maybe some tweaks and longer explanations could be useful.

text/shared/01/01010100.xhp
The old Templates Manager dialog description. Maybe some tips or notes could be recycled, but generally the new page just replaced this.

text/shared/04/01010000.xhp and text/shared/guide/startcenter.xhp
These refer to the "Templates and Documents" window, which is now just "Templates"
Comment 5 Commit Notification 2017-05-15 07:04:43 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=e16902a941018fc12d04ae1137328fc1acf3b31f

tdf#107229 Adapt First Steps page to new Templates window
Comment 6 Commit Notification 2017-05-15 07:05:54 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=d67bce5a4c44001fbf7ac384c2da23a909d4a8e5

tdf#107229 Translate a German section id
Comment 7 Commit Notification 2017-05-15 07:06:29 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=cad09f1811c9de671285a994e11c9fd351861ef5

tdf#107229 Fix Templates dialog title reference
Comment 8 Commit Notification 2017-05-15 07:11:30 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=8f6a82ee50714e2d768f8fe49c60ce78a6764c51

tdf#107229 Update Save as Template window help page
Comment 9 Commit Notification 2017-05-15 07:12:05 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=298b223bd6e57829ca6e616eca6995622dcc1201

tdf#107229 Update Open Template menu command page
Comment 10 Commit Notification 2017-05-15 07:12:40 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=c4340e7c2552d915165810443c12ebb3bea262de

tdf#107229 Fix File - Templates menu page
Comment 11 Commit Notification 2017-05-19 14:48:37 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=7c9323ff02e580187576204b014e04fa6f732c07

tdf#107229 Drop old Template Manager help
Comment 12 Commit Notification 2017-05-19 14:50:12 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=eb56f83ad99b8282f7aa8785aa840733ba5d7fed&h=libreoffice-5-4

tdf#107229 Drop old Template Manager help
Comment 13 Commit Notification 2017-05-23 07:49:15 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=98f16894574b039fc5e7ead6934aa4a0488472b0

tdf#107229 Fix reference to the Save as Template menu item
Comment 14 Commit Notification 2017-05-30 08:44:16 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=533edb4dda97c6630ee5329627dc63afedf4b5a2&h=libreoffice-5-4

tdf#107229 Fix reference to the Save as Template menu item
Comment 15 Xisco Faulí 2017-07-14 13:26:18 UTC
Polite ping: is this bug fixed? if so, please close it as RESOLVED FIXED
Comment 16 Gabor Kelemen 2017-07-14 16:16:20 UTC
(In reply to Xisco Faulí from comment #15)
> Polite ping: is this bug fixed? if so, please close it as RESOLVED FIXED

Hi 

This is not yet done, there are still a few pages left to modify, i.e. the guide ones from comment #0
Comment 17 Xisco Faulí 2017-10-14 09:19:53 UTC
Dear Gabor Kelemen,
This bug has been in ASSIGNED status for more than 3 months without any activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 18 sdc.blanco 2020-11-16 00:55:49 UTC
I would propose deleting

text/swriter/guide/template_default.xhp
text/swriter/guide/template_create.xhp

and collecting all procedures for creating and modifying templates (both default and custom) in:

text/shared/guide/standard_template.xhp

(AFAIK, the procedures for creating and modifying templates are equivalent for all modules, so it is an advantage to have it located in text/shared/guide/standard_template.xhp  -- rather than separate files for writer.)

https://gerrit.libreoffice.org/c/help/+/105855  provides an example that collects all the procedures onto:  text/shared/guide/standard_template.xhp

(but does not make any modifications in relation to template_default.xhp and template_create.xhp)

If that patch seems ok, then after it is submitted, I would remove template_default.xhp and template_create.xhp  (because their content is addressed (and updated) in standard_template.xhp), and address the consequences of their removal in other .xhp files. [Not so hard, because the two files are mostly only part of "related topics" or overview lists, which can replaced with embeds from standard_template.xhp].


There is also, text/shared/optionen/01040301.xhp  which embeds more or less all of text/shared/guide/standard_template.xhp   (which is then embedded in text/shared/optionen/01040300.xhp).  Adds unnecessary obscurity, which can be made more transparent.
Comment 19 Commit Notification 2020-12-06 12:02:12 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/a2bd1ce7cf53abd37db55422c9b99a4e50d9d463

tdf#105719 tdf#122720 tdf#107229 help for making default template
Comment 20 Commit Notification 2020-12-07 07:34:22 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/help/commit/e2c545ce9755cbdbcd02be09c963da8566386446

tdf#105719 tdf#122720 tdf#107229 help for making default template
Comment 21 Commit Notification 2020-12-08 11:49:19 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/452d30de3107e088c203c61e761a1319b528d789

tdf#107229 replace links from template_{create,default} with standard
Comment 22 Commit Notification 2020-12-08 11:54:58 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/help/commit/d6aef8e38dc5f623b7c1b79d817c94e546ecb86c

tdf#107229 replace links from template_{create,default} with standard
Comment 23 Commit Notification 2020-12-10 11:21:57 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/1f5e7cbaf41f21b72713814f1517be23f933258d

tdf#107229 simplify embedding for default template help
Comment 24 Commit Notification 2020-12-10 12:36:16 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/help/commit/8ec8c9e42a5f4a98d36029b67711cc89c5e33a3f

tdf#107229 simplify embedding for default template help
Comment 25 Commit Notification 2020-12-10 14:26:40 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/c9f02245818790a55c64b9dc66da43cdbb20af6a

Resolves: tdf#107229  remove unreferenced file
Comment 26 Commit Notification 2020-12-11 12:48:07 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/a5b9c9c43de5d8d99aff4a739765551bcf30c059

tdf#107229 remove two more obsolete template guide files
Comment 27 sdc.blanco 2020-12-11 17:15:13 UTC
I think there is more work to do.  As noted in comment 4

> text/shared/01/01020000.xhp
> File - Open menu item description. Needs some updates on its own and apart
> from that this has some long dead template-related features documented which
> probably can be dropped. 

Some of the material there is relevant for templates, but probably should not be in File > Open, which is the main topic of that page.  Other material (from 2008) is about updating and applying styles -- which have already been discussed on other pages.
Comment 28 Commit Notification 2020-12-12 17:40:32 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/7069de582ee20b0b70f13612a61559f92ab2c85f

tdf#107229 revise template section of start center help
Comment 29 Commit Notification 2020-12-13 18:01:59 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/e784d298ec11c408d1dcdb8493541033cf271922

tdf#107229  add links to related topics for template help pages
Comment 30 Commit Notification 2020-12-13 18:13:14 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/bcd9a10a15166be315cf9806f9ee7db0c962b43c

tdf#107229 add links to related topics between template help pages
Comment 31 Commit Notification 2020-12-14 18:00:24 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/help/commit/80f326abfdf2c364ecf41ae1ba0cf769b1d28dfc

tdf#107229 revise template section of start center help
Comment 32 Commit Notification 2020-12-15 03:00:36 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/help/commit/83a954cd538bf5b56292067c3897971f685afb04

tdf#107229  add links to related topics for template help pages
Comment 33 Commit Notification 2020-12-18 02:56:05 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/f5ff6097a41055bb91d73a9c9fa847f03212431c

tdf#107229 repair links to standard_template
Comment 34 sdc.blanco 2020-12-24 09:11:59 UTC
Created attachment 168461 [details]
proposal for guide page about file locations and name and template manager

Attached is proposed new page that addresses bug 122720 about "Handling of templates potentially unclear in respect to where files are stored"
Comment 35 Commit Notification 2020-12-29 06:41:59 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/90f2b391658858e1faa15f78c989225cc867d6b2

tdf#107229 update and move template path location information
Comment 36 Commit Notification 2021-01-06 19:42:35 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/ef042f162e7403d0afb776b2efe81590e5242012

tdf#107229 update help page for template manager
Comment 37 Commit Notification 2021-01-06 19:49:51 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/491c08b20af8a0d1b2fcf3caf74926202fbcb541

tdf#107229  update "Save as Template" help
Comment 38 Commit Notification 2021-01-07 22:14:18 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/cb92b1c7175df1d38637a5b944f9f96314d26f8b

tdf#122720 tdf#107229 new help guide about paths and templates
Comment 39 Commit Notification 2021-01-09 09:25:40 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/1a448c30bca44a332348446afce82a3f5294461a

tdf#107229 final tweaks in template manager help - import and relatedtopics
Comment 40 sdc.blanco 2021-01-09 09:57:23 UTC
have reviewed all template pages, added links in related topics and in swriter.tree.  Will close this bug as FIXED.  Further problems with template help pages should open a new bug report.
Comment 41 Commit Notification 2021-01-14 16:51:33 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/319b987c6acfd51ba009e6c2e63284bf2eec92c7

tdf#107229 (related to tdf#138846) update "settings" label to "tools"