Bug 107245 - Autofiltering Dates filters out everything if one month is deselected. Depends on date format.
Summary: Autofiltering Dates filters out everything if one month is deselected. Depend...
Status: RESOLVED DUPLICATE of bug 106214
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-18 15:25 UTC by Wolfgang Jäger
Modified: 2017-04-28 22:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Demonstration of the bug (15.36 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-04-18 15:25 UTC, Wolfgang Jäger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Jäger 2017-04-18 15:25:47 UTC
Created attachment 132656 [details]
Demonstration of the bug

Steps to reproduce the bug:
Create in one column a short list of dates from more than one months (or years) and format it in English(UK) default date format (DD/MM/YY). 
Apply Autofilter to the column.
Use the dropdown to DEselect one month (or one year).

Expected: Correct filtering.
Observed: All the date rows get hidden (filtered out).

The date format set to ISO 8601 conforming YYYY-MM-DD, the AutoFilter works correctly. 
See also the attachment.
Comment 1 Xisco Faulí 2017-04-18 16:52:53 UTC
Hello Wolfgang,
Thanks for reporting the bug. It's a duplicate of bug 106214 and it will be fixed in LibreOffice 5.3.3.
Regards

*** This bug has been marked as a duplicate of bug 106214 ***
Comment 2 m.a.riosv 2017-04-28 22:42:33 UTC
*** Bug 107472 has been marked as a duplicate of this bug. ***