Download it now!
Bug 107308 - Not saving printing area when exporting to xlsx
Summary: Not saving printing area when exporting to xlsx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:ooxml, filter:xlsx
Depends on:
Blocks: Print-Range XLSX
  Show dependency treegraph
 
Reported: 2017-04-20 19:43 UTC by Mikhail Novosyolov
Modified: 2017-07-31 13:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example document with printing area (85.56 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-04-20 19:43 UTC, Mikhail Novosyolov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Novosyolov 2017-04-20 19:43:53 UTC
Created attachment 132724 [details]
example document with printing area

To reproduce:
take the example file or any other in xlsx or save the ods as xlsx, change the printing area and exports/save as xlsx. The change of the printing area will not be saved. However, it is not present with xls.
Comment 1 Bartosz 2017-04-26 21:16:02 UTC
Unfortunately I cannot reproduce that issue.
Could you please attach the screenshot before and after export to .xlsx?
Comment 2 Mikhail Novosyolov 2017-04-26 21:23:03 UTC
To reproduce:
1. Open the file
2. Drag the blue printing area, lick 'Save', agree to save in xlsx instead of ODS
3. Close the file
4. Open it again. I will be the same as before step 1.

There is nothing to screenshot, maybe make a screencast if you still cannot reproduce.
Comment 3 Xisco Faulí 2017-06-08 09:38:02 UTC
This bug was incorrectly moved from NEEDINFO to NEW. Putting back to
UNCONFIRMED.
Comment 4 Buovjaga 2017-06-11 13:55:35 UTC
I repro with file and steps.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: 2802dca10eef67554a81cb2347d5f648fa6fcd63
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 10th 2017

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 5 Mikhail Novosyolov 2017-07-31 12:58:47 UTC
Fixed in 5.4 release