Download it now!
Bug 107311 - "Named range" option always grayed out in Pivot Table
Summary: "Named range" option always grayed out in Pivot Table
Status: RESOLVED DUPLICATE of bug 37268
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-21 03:21 UTC by David Strozzi
Modified: 2019-09-01 12:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test file (8.78 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-04-21 14:26 UTC, David Strozzi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Strozzi 2017-04-21 03:21:13 UTC
Description:
In Calc, I make a simple spreadsheet, select two columns, and do Data -> Define Range.  I give it a name.  I then do Data -> Pivot Table.  The "Named range" option is always grayed out.

Steps to Reproduce:
See description.

Actual Results:  
Named Range grayed out

Expected Results:
Named Range active, I can select one.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2017-04-21 09:11:36 UTC Comment hidden (obsolete)
Comment 2 David Strozzi 2017-04-21 14:26:57 UTC
Created attachment 132741 [details]
test file

Test case.  But the data is trivial, it's the actions that show the bug.
Comment 3 GerardF 2017-04-21 17:18:18 UTC
Test with 5.2.6 on Windows Vista.

Confirmed when a *database* range is created. (Data > Define range)

Works when a *named range* is created whith Insert > Named expression or range.

I'm not sure this is the normal behavior...
Comment 4 Alex Thurgood 2017-05-10 13:55:55 UTC
Confirming on

Version: 5.3.2.2
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
Threads CPU : 8; Version de l'OS :Mac OS X 10.12.4; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

following steps in original report with test file.
Comment 5 Alex Thurgood 2017-05-10 14:00:52 UTC
Reproduced in 

Version: 5.1.6.2
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
Threads CPU : 8; Version de l'OS :Mac OS X 10.12.4; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 6 Alex Thurgood 2017-05-10 14:03:22 UTC
Also reproduced in 

Version 3.6.7.2 (Build ID: e183d5b)

OSX 10.12.4
Comment 7 Alex Thurgood 2017-05-10 14:06:18 UTC
There is no corresponding entry in the OOo321 data pilot, so I am assuming that this was only made available after LibreOffice 330 release.
Comment 8 Alex Thurgood 2017-05-10 14:09:35 UTC
Reproduced also with

Version: 4.1.6.2
Build ID: 40ff705089295be5be0aae9b15123f687c05b0a

The entry is there, but greyed out.
Comment 9 Alex Thurgood 2017-05-10 14:18:36 UTC

*** This bug has been marked as a duplicate of bug 37268 ***