Download it now!
Bug 107345 - Make Notebookbar tabs not look like real tabs
Summary: Make Notebookbar tabs not look like real tabs
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Theming Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2017-04-21 22:52 UTC by Thomas Lendo
Modified: 2018-12-09 00:05 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
notebookbar on macOS (43.75 KB, image/jpeg)
2017-04-22 13:59 UTC, steve -_-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-04-21 22:52:03 UTC
The tabs of the tabbed Notebookbar variant look too much like the '90s styled tabs in dialog windows.

Maybe a different look like in MSO Word 2013 (https://blog.cometdocs.com/wp-content/uploads/themes-in-word-2013.png) would sex up the design. There only the selected tab is displayed as tabs. All other tabs are only terms in a row.

Tabs in macOS only don't look like "tabs" (https://support.apple.com/library/content/dam/edam/applecare/images/en_US/macos/macos-sierra-network-utility-info-tab.png).

Maybe the rendering as intended by the OS (Windows, Gnome, etc.) is not the only possible way for LibO to show this tabs.
Comment 1 V Stuart Foote 2017-04-21 23:40:42 UTC
Pardon the pun--but "just whats on the menu" please.

Think we are limited to what GTK Glade provides in styling the widgets--and each OS/DE theme will tweak that.
Comment 2 Yousuf Philips (jay) (retired) 2017-04-22 02:10:36 UTC
@Alex, @Steve: Can you give a screenshot of what the notebookbar looks like on OSX.
Comment 3 steve -_- 2017-04-22 13:59:06 UTC
Created attachment 132750 [details]
notebookbar on macOS

Version: 5.4.0.0.alpha0+
Build ID: 100e00fd3273536ebff130cfddc5da2b1fe609b1
CPU threads: 4; OS: Mac OS X 10.12.4; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-04-20_05:16:42
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 4 Yousuf Philips (jay) (retired) 2017-04-22 16:45:28 UTC
(In reply to V Stuart Foote from comment #1)
> Think we are limited to what GTK Glade provides in styling the widgets--and
> each OS/DE theme will tweak that.

I believed so as well, but it is possible according to what i believe Kendy mentioned that we could style them (or more accurately the entire UI) different from the OS/DE theme per platform, so if anything, I would only be in favour of doing this on windows.
Comment 5 Thomas Lendo 2017-04-22 19:16:11 UTC
Thanks all for the comments and Steve for the screenshot.

I see that on macOS the tabs are shown as Mac users are used to see tabs.
Gnome and KDE users also are satisfied with the current look (at leas kainz.a is). Unity is dying, so no issue.
I will go with Jay and change "All" to "Windows" in this bug as Windows users are used to see some tabs fashioned in a different way than simple options tabs, for example in MSO.
Comment 6 andreas_k 2018-10-24 06:17:57 UTC
I think the only issue is the menubutton on the right of tabbed bar. But also on Windows it works well.

I don't see the issue in 6.2 alpha 1. Maybe on OS-X where the menubar is moved to the left.

For me it's WFM.
Comment 7 Heiko Tietze 2018-12-03 12:10:25 UTC
*** Bug 121877 has been marked as a duplicate of this bug. ***