Bug 107389 - Scrolling right in spreadsheet displaces AutoFilter dropdown buttons
Summary: Scrolling right in spreadsheet displaces AutoFilter dropdown buttons
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice Online
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
QA Contact:
URL:
Whiteboard: target:5.5.0 target:5.3.4 target:5.4.0.1
Keywords:
: 107390 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-24 13:54 UTC by Aron Budea
Modified: 2017-05-31 15:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample spreadsheet (7.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-04-24 13:54 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-04-24 13:54:57 UTC
Created attachment 132785 [details]
Sample spreadsheet

This is a report for LibreOffice Online. Filtering isn't supported, yet (see bug 104464), but the dropdown buttons should appear correctly.

Open the attached document.
Select cell A1, and start moving right using the arrow keys. Sometimes after getting to the right, the dropdown buttons start appearing displaced (happens at column N for me).

If the spreadsheet is opened with gtktiledviewer, the icons are already shown displaced.

LOOLWSD master.. (git hash: 9c7cbab)
LOKit   LibreOfficeDev 5.4.0.0.alpha0 (git hash: c2511f2)
Comment 1 Aron Budea 2017-04-24 13:57:08 UTC
Reported by Markus Mohrhard and others.
Comment 2 Aron Budea 2017-04-24 15:07:57 UTC
*** Bug 107390 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2017-05-28 09:24:45 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba5a9132375bcfedebd7c3d2500006161800da3b

tdf#107389: Wrong positioning of AutoFilter buttons in tiledrendering mode

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2017-05-29 15:33:24 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d903fcf7582341ad4823aff999cbb9dc4d3d860d&h=libreoffice-5-3

tdf#107389: Wrong positioning of AutoFilter buttons in tiledrendering mode

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-05-31 15:38:07 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ddcd9c3a6e78131d511e91f832ab33c41d41916d&h=libreoffice-5-4

tdf#107389: Wrong positioning of AutoFilter buttons in tiledrendering mode

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.