Bug 107432 - Can't get LETTER size TEXT DOCUMENT to print in Portrait mode with LibreOffice Vanilla from AppStore
Summary: Can't get LETTER size TEXT DOCUMENT to print in Portrait mode with LibreOffic...
Status: VERIFIED DUPLICATE of bug 86838
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-25 22:57 UTC by Brian Keill
Modified: 2017-10-19 17:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Keill 2017-04-25 22:57:35 UTC
Description:
Can't get LETTER size TEXT DOCUMENT to print in Portrait mode
If the PAGE layout setting = PORTRAIT, and the Paper Size = LETTER, the print dialog box shows the document sideways and it prints that way.

WORKAROUND: Change Paper Size to A4, or USER CUSTOM 8.51" X 11.0" and it works fine. There is something wrong with LETTER paper.

Steps to Reproduce:
1. Open TEXT document
2. In Format / Page tab:  Ensure Orientation is set to Portrait and Select Paper Format = LETTER 
3. Click OK
4. PRINT document (prints landscape on portrait paper). 
[By the way, Print Preview shows it as portrait]

Actual Results:  
Prints landscape on portrait paper

Expected Results:
Print portrait on portrait


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36
Comment 1 Alex Thurgood 2017-04-26 12:41:54 UTC
@Brian :

this might be a duplicate of an already reported bug (rings a bell). Please could you provide:

- the name and type of printer setup (network/usb, etc);
- the language setting of your LibreOffice installation.

Setting to NEEDINFO, please set back to UNCONFIRMED when you have provided the requested information.
Comment 2 Alex Thurgood 2017-04-26 12:49:06 UTC
@Brain : you also mention your version of LibreOffice as 5.2.3.3

Please try with a latest production release (Fresh/Stable) and report back your findings here.
Comment 3 Alex Thurgood 2017-04-26 12:51:05 UTC
Possible DUP of bug 86838 (which would potentially need to be re-opened) , but am awaiting confirmation from OP.
Comment 4 Brian Keill 2017-04-26 14:32:10 UTC
"Please could you provide:  - the name and type of printer setup (network/usb, etc);
- the language setting of your LibreOffice installation."

Wireless NETWORK, Brother HL-L2340DW printer.
ENGLISH LANGUAGE


Additional comment:  SOMEONE ASKED for me to update to the newest version and test. This is the LibreOffice VANILLA version, available in the APP Store. This does NOT happen in the NON-Vanilla versions of LibreOffice. ONLY Vanilla.
Comment 5 Alex Thurgood 2017-04-28 08:14:17 UTC

*** This bug has been marked as a duplicate of bug 86838 ***
Comment 6 Randy 2017-09-29 16:48:42 UTC
I'm not sure that this is resolved.
Using 5.4 on macOS Sierra.
Print preview is correct, however portrait always prints out landscape.
Can export to PDF and is correct.
Comment 7 Steve Glines 2017-10-19 17:45:46 UTC
The printer screen doesn't offer the portrait/landscape choice. Always printing in landscape. This is a critical issue.
Comment 8 Steve Glines 2017-10-19 17:47:47 UTC
This bug renders the Libra office useless - Please this is a Critical issue.