Download it now!
Bug 107478 - Cannot dock a SideBar by mouse dragging
Summary: Cannot dock a SideBar by mouse dragging
Status: RESOLVED DUPLICATE of bug 92122
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Desktop-Integration Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2017-04-27 12:02 UTC by baffclan
Modified: 2017-12-04 21:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Video shot (1.49 MB, video/x-ms-wmv)
2017-04-28 12:28 UTC, baffclan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2017-04-27 12:02:56 UTC
Cannot dock a SideBar by mouse dragging

Steps to Reproduce:
1. Start LibO with new profile
2. Create Writer Document
3. Open Sidebar
4. Undock a Sidebar
5. Dock a Sidebar by mouse dragging

Actual Results:
6. Cannot dock a Sidebar

Expected Results:
6. Can dock a Sidebar


Reproduce with 5.3.3.1 and 5.4.0.0.alpha0+ on Windows10(x86)
Version 1703, OS Build 15063.138

Version: 5.3.3.1
Build ID: 46360c72c4823cefeaa85af537fba22bd568da7e
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new;
Locale: ja-JP (ja_JP); Calc: group

Version: 5.4.0.0.alpha0+
Build ID: d8a564010c46a4062cbfd7e055f5dc64597d3268
CPU threads: 4; OS: Windows 6.2; UI render: default;
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-04-26_01:39:19
Locale: ja-JP (ja_JP); Calc: CL


Cannot Reproduce with 5.3.3.1 and 5.4.0.0.alpha0+ on Windows10(x64)
Version 1067, OS Build 14393.1066

Version: 5.4.0.0.alpha0+ (x64)
Build ID: 85e78b83515494a297286ba1dcba30a59fac130d
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2017-04-25_22:56:11
Locale: ja-JP (ja_JP); Calc: group

Version: 5.3.3.1 (x64)
Build ID: 46360c72c4823cefeaa85af537fba22bd568da7e
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: ja-JP (ja_JP); Calc: group
Comment 1 Xisco Faulí 2017-04-27 12:30:00 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 4354f0e9ef4a5538729a2a6f2d1745e247f6c5cd
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-21_06:05:57
Locale: es-ES (es_ES); Calc: group

on Win 7 x86
Comment 2 V Stuart Foote 2017-04-27 12:46:38 UTC
Can not reproduce on Windows 10 Pro 64-bit en-US with

Version: 5.4.0.0.alpha0+
Build ID: 4354f0e9ef4a5538729a2a6f2d1745e247f6c5cd
CPU threads: 8; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-21_06:05:57
Locale: en-US (en_US); Calc: CL

or

Version: 5.4.0.0.alpha0+ (x64)
Build ID: 437105b940d997d742bd5e31cfa0ce4b949b29f2
CPU threads: 8; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2017-04-27_00:58:13
Locale: en-US (en_US); Calc: group

Please retest but pay attention to the target for the docking left or right edge of frame--the target is only about 20px width as the mouse cursor passes over the left or right edge of the frame. The focus is at the cursor.
Comment 3 baffclan 2017-04-28 12:28:29 UTC
Created attachment 132934 [details]
Video shot

(In reply to V Stuart Foote from comment #2)
> Please retest but pay attention to the target for the docking left or right
> edge of frame--the target is only about 20px width as the mouse cursor
> passes over the left or right edge of the frame. The focus is at the cursor.
I understand it  I can dock with LibO (x64).
Is there a possibility that "Creators Update" is the cause?

See attachment.
Comment 4 QA Administrators 2017-10-30 10:54:28 UTC Comment hidden (obsolete)
Comment 5 baffclan 2017-10-31 09:51:28 UTC
Reproduce on LibO-Dev 6.0.0.0.alpha1/Windows 10(x86).

Version: 6.0.0.0.alpha1
Build ID: c1d1f859b268f650143d48f294999cda0fa57350
CPU threads: 4; OS: Windows 10.0; UI render: default;
Locale: ja-JP (ja_JP); Calc: group
Comment 6 V Stuart Foote 2017-10-31 12:55:12 UTC
Remain unable to reproduce on Windows 10 Home 64-bit (v1709) en-US laptop with
Version: 6.0.0.0.alpha1+
Build ID: 3d872ecc51e47e02e70732c848964274b2aad29e
CPU threads: 4; OS: Windows 10.0; UI render: default--or--GL; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-10-29_08:58:20
Locale: en-US (en_US); Calc: group

Version: 5.4.3.1 (x64)
Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
CPU threads: 4; OS: Windows 6.19; UI render: default--or--GL; 
Locale: en-US (en_US); Calc: group

And on other systems, laptops and PCs.

So CTL, or CJK locale or character mode layout?
Comment 7 Buovjaga 2017-11-10 14:15:37 UTC
I suspect it is because of this: bug 92122
See my comment 12 for how to check the setting in Win 10
Comment 8 V Stuart Foote 2017-11-10 14:51:05 UTC
(In reply to Buovjaga from comment #7)
> I suspect it is because of this: bug 92122
> See my comment 12 for how to check the setting in Win 10

Hmm, on a system where docking works correctly, when I disable the visual effects tab "Show window content while dragging", or set the "Adjust for best performance" -- the "frame" around the panel does not respond to mouse over the docking points (left or right edge)--and can not dock.

Toggling the Windows OS settings enables/disables the effect.

Folks should check the Windows DE theme in use as that will control these Visual Effects.

Guess that makes this a DE issue, and NOTOURBUG?  Though, we probably should identify what WDM calls are linked and see if it can be tweaked to behave.

Also, wonder if using Gconf ->  "reduced_resources" setting for DE has the same effect on Linux boxes?
Comment 9 Buovjaga 2017-11-10 15:04:17 UTC
(In reply to V Stuart Foote from comment #8)
> Also, wonder if using Gconf ->  "reduced_resources" setting for DE has the
> same effect on Linux boxes?

For anyone who wants to try: https://askubuntu.com/questions/5161/how-to-disable-windows-contents-being-moved-on-dragging-so-that-only-the-frame
Comment 10 Maxim Monastirsky 2017-12-04 21:56:44 UTC
(In reply to Buovjaga from comment #7)
> I suspect it is because of this: bug 92122
Indeed, the screencast shows that only the outline of the window is visible during dragging.

*** This bug has been marked as a duplicate of bug 92122 ***