Bug 107481 - EDITING: Text behind frame after undoing page break
Summary: EDITING: Text behind frame after undoing page break
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Anchor-and-Text-Wrap Undo-Redo Writer-Page-Break
  Show dependency treegraph
 
Reported: 2017-04-27 13:12 UTC by Telesto
Modified: 2020-04-25 21:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-04-27 13:12:20 UTC
Description:
The text alignment changes after undoing a page break (text behind frame)

Steps to Reproduce:
1. Open attachment 51600 [details] (bug 41192)
2. Add a page break (CTRL+ENTER) at the ending of the first page 
3. Undo the page break (CTRL+Y)

Actual Results:  
Text is positioned behind the frame

Expected Results:
Should look same as first opened


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
Build ID: a917902c48f21d04039da86048c5c36555137d7e
CPU threads: 4; OS: Windows 6.2; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-04-24_23:35:22
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL

and in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Buovjaga 2017-04-30 12:18:42 UTC
Repro.

Arch Linux 64-bit
Version: 5.4.0.0.alpha1+
Build ID: aca48f46895811009ec90665d816ef835f0694be
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on 30th April 2017
Comment 2 QA Administrators 2018-06-15 02:44:34 UTC Comment hidden (obsolete)
Comment 3 Telesto 2020-04-25 21:26:01 UTC
Still around.

Likely a anchor + undo problem (if have reported a bunch of those lately)

Versie: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU-threads: 4; Besturingssysteem: Windows 6.3 Build 9600; UI-render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-taal: nl-NL
Calc: CL