Bug 107552 - Data table is not shown in calc
Summary: Data table is not shown in calc
Status: RESOLVED DUPLICATE of bug 123026
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks:
 
Reported: 2017-05-01 22:55 UTC by joni yang
Modified: 2022-09-17 15:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the zip attachment file, please extract it firstly (293.16 KB, application/zip)
2017-05-01 22:57 UTC, joni yang
Details
Default format cell is number rather than text while it's actual data is string (186.40 KB, image/png)
2017-05-02 05:42 UTC, joni yang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description joni yang 2017-05-01 22:55:28 UTC
The following attachment contain several files
1. data_not_shown1.png is a screenshot to show the problem. You can see there that the Cluster column data is not shown but this case is not a problem for ms excel 2007.
2. shown_in_excel.png is a screenshot to show the problem on ms excel 2007. This does properly showing all cluster datas column.
3. export_data__020517053412197.xlsx is a file that to reproduce the bug. you can compare the result between libreoffice 5 and ms excel 2007.
4. libreversion.png is a screenshot that showing the complete libreoffice version number

I hope this could make any clearance in my bug report. thank you.
Comment 1 joni yang 2017-05-01 22:57:37 UTC
Created attachment 132997 [details]
the zip attachment file, please extract it firstly

the zip attachment file, please extract it firstly
Comment 2 m.a.riosv 2017-05-02 01:00:32 UTC
Seems an issue with the automatic row heigh with some xls files.
You can select the whole sheet, righ-click on a row number and apply Optimal height.

*** This bug has been marked as a duplicate of bug 32950 ***
Comment 3 joni yang 2017-05-02 05:42:59 UTC
Created attachment 133000 [details]
Default format cell is number rather than text while it's actual data is string

 Thanks for the fast response, but I think this is libreoffice calc bug. If I right click and choose format cells, it does defaulting to number type instead of text. But if I change to text format then all data is properly shown. Why didnt libreoffice think this type of string as text rather than detect as number format?
Comment 4 joni yang 2017-05-02 05:45:34 UTC
The second attachment is an image that showing incorrect defaulting data types in libreoffice calc.
Comment 5 Justin L 2022-09-17 15:10:36 UTC
This is an XLSX document - assign as duplicate to XLSX version instead of XLS version of the bug.

*** This bug has been marked as a duplicate of bug 123026 ***