Download it now!
Bug 107557 - Proposal to make sidebar automatically hide
Summary: Proposal to make sidebar automatically hide
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2017-05-02 08:00 UTC by Volga
Modified: 2017-05-02 15:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-05-02 08:00:20 UTC
Description:
Making sidebar hide automatically would keep document viewing area larger when you selesct View -> Zoom -> Page width or Optimal view to view the document, and make the usage of sidebar easier. This need an option to enabled.

Steps to Reproduce:
-

Actual Results:  
-

Expected Results:
When this feature enabled, the sidebar will be hide by default, when cursor moved to the right edge of screen, when cursor moved out of sidebar, the sidebar will be hidden immidiately or keeping on screen several secondes.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Comment 1 Yousuf Philips (jay) (retired) 2017-05-02 12:47:49 UTC
(In reply to Volga from comment #0)
> Description:
> Making sidebar hide automatically would keep document viewing area larger
> when you selesct View -> Zoom -> Page width or Optimal view to view the
> document, and make the usage of sidebar easier. This need an option to
> enabled.

Well i would assume that the user can hit both zoom levels of page width and optimal view using the mouse (ctrl + scrollwheel) and the zoom in button in the statusbar. So are you proposing that it also hide the sidebar when this happens?

Personally i dont think having the sidebar do this is a good idea. Users should select the best UI layout for their workflow and stick with it and we do provide easy means to show and hide the sidebar that users can easily toggle when they need to do so.

@Heiko, @Stuart: Your opinions?
Comment 2 V Stuart Foote 2017-05-02 14:12:46 UTC
Not a fan of the idea. 

The existing controls, or the automated MUFFIN layouts, to collapse the Sidebar to the frame edge--Show/Hide-- toggle is sufficient.

For example see the toggle behavior as in Single Toolbar view mode is preferable rather than any "mouse over" activation.
Comment 3 Heiko Tietze 2017-05-02 14:26:06 UTC
The sidebar was introduced since widescreens have plenty of horizontal space. At least in normal edit mode it should be visible, depending on the other UI. And when you switch to print preview it is hidden right now. I don't see a good use case which makes it necessary to hide the sidebar at all, neither to do that automatically.
Comment 4 Yousuf Philips (jay) (retired) 2017-05-02 15:53:43 UTC
So lets close it then.