Bug Hunting Session
Bug 107571 - Default Language for Impress documents from provided templates is German, despite locale or langpack settings.
Summary: Default Language for Impress documents from provided templates is German, des...
Status: RESOLVED DUPLICATE of bug 107027
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-05-02 19:43 UTC by jfblagden
Modified: 2017-05-03 16:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jfblagden 2017-05-02 19:43:08 UTC
By default, the Default Language for Documents (Western) is German. This results in random English words being marked as having been spelled incorrectly. LibreOffice should be able to detect the language without having to ask for it. 

I realize that this is easy enough for a user to change, but it’s something which shouldn’t have to be changed at all. Besides, it’s rather off-putting for new users. Someone might try LibreOffice and give up on it after seeing it mark correctly-spelled words as being incorrectly spelled.
Comment 1 Alex Thurgood 2017-05-03 08:12:01 UTC
@jfblagden: the default language for spellchecking documents is the language you choose in the Options - Language Settings and also dependent on any langpacks you have installed.

If you don't have the relevant langpack installed, how do you expect to have the correct dictionary by which to compare the spelling ? The Writing Aids entry under the Language Settings allows a user to add further dictionaries, if necessary by downloading from the extensions website, and have those dictionaries included by the spellchecker, so either I am failing to understand what kind of enhancement you are requesting or else this is simply invalid and will be marked as such.

Please explain what exactly you envisage as a functional enhancement request. Perhaps you are suggesting that we provide a LibreOffice app download with a complete set of dictionaries ? A decision was made against this at the beginning of the project's creation due to storage/build constraints.

Is the problem specific to Mac OSX, it doesn't appear to be so to me when I compare it to Linux versions of LibreOffice, the same thinking is present - individual langpacks that the user then configures as he/she desires.
Comment 2 Alex Thurgood 2017-05-03 08:14:33 UTC
Of course, the LibreOffice project does provide multiple dictionary installations as standard on Windows (Custom Installation)...
Comment 3 Alex Thurgood 2017-05-03 08:18:18 UTC
Bug 75734 is somewhat related to this bug. The original poster recognized the difficulty of finding an elegant and appropriate solution to the problem of missing dictionaries, and hence incorrectly flagged or otherwise ignored misspelled words in another language.
Comment 4 Alex Thurgood 2017-05-03 08:28:09 UTC
See also bug 97991 for a discussion on _reducing_ the size of the MSI Windows download to an individual language with the app, enabling separate downloads for other languages as is currently the case for Linux and Windows.

As you can see from the discussion in bug 97991, there is currently no general consensus.
Comment 5 Alex Thurgood 2017-05-03 08:30:12 UTC
In light of this question in comment 1 :

Please explain what exactly you envisage as a functional enhancement request. Perhaps you are suggesting that we provide a LibreOffice app download with a complete set of dictionaries ? 

Setting to NEEDINFO pending response from original poster.
Comment 6 jfblagden 2017-05-03 13:00:37 UTC
I’m not entirely certain of the cause of the issue. If that is indeed the problem, here’s my response: 

Yes, a complete set of dictionaries would be very useful. With the sandboxing requirement on Mac OS X 10.7 (Lion) and later for apps distributed through Apple’s Mac App Store, it’s very possible that Mac OS X doesn’t share dictionaries with apps, especially third-party apps. 



But I really think it’s that LibreOffice doesn’t communicate with Mac OS X to find out the user’s language. Or if it does check, it doesn’t apply that information.

I haven’t actually read the source code yet, so I’m not 100% sure of the cause. I might review some of the code later today.
Comment 7 jfblagden 2017-05-03 13:06:23 UTC
I know that Impress uses some Java code, and I don’t remember having this problem with Calc or Writer. It’s possible that the JVM is preventing interaction with the operating system. I know that Java was designed to have as little direct interaction with the operating system as possible, because it was intended to be used on the web.
Comment 8 Alex Thurgood 2017-05-03 14:29:28 UTC
So, I think I might have understood what you mean.

If I open a new Impress document (File - New) then choose any of the suggested templates, the pre-inserted strings which are localized for my language (French) are underscored as errors. If I check the character properties of these strings, LibreOffice has them set as German by default.

Any text that you enter to replace these strings keeps the same default language property.

So, confirming that this is a bug, but I believe it has already been reported, just need to find it.
Comment 9 Alex Thurgood 2017-05-03 14:42:56 UTC
Possibly a DUPLICATE or related bug to bug 107045
Comment 10 Laurent BP 2017-05-03 16:00:56 UTC

*** This bug has been marked as a duplicate of bug 107027 ***