Bug 107654 - Table Design window for new table, title bar names existing Table1
Summary: Table Design window for new table, title bar names existing Table1
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-06 01:08 UTC by Terrence Enger
Modified: 2021-07-22 15:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2017-05-06 01:08:09 UTC
STR

(1) Download and open embedded_fb.odb, attached to bug 107653
    <https://bugs.documentfoundation.org/attachment.cgi?id=133099>.
    Program presents main database window.

(2) In pane Database, click <Tables>.  Pane Tables shows Table1 and
    Table2.

(3) In pane Tasks, click <Create Table in Design View>.  Program
    presents window "Table Design".

    Observed : The title bar names "Table1".

    Expected : I am not sure.  Perhaps table name "unnamed1", or
               "unknown1", or "New table 1", or something like that.
               However "Table1" is not a possible name for the new
               table.

The default table name supplied when you save the table definition is,
quite naturally and rightly, Table3.

If you do a second <Create Table in Design View> at the same time, the
name in the title bar of the Table Design window is incremented to
Table2, which also happens to be wrong in this case.

This observation is with daily Linux dbgutil bibisect repository
version 2017-05-05 running on debian-stretch.

I think I remember this happening for a long time, and I have never
noticed anybody else mention the problem.  Moreover, anybody doing
real work is unlikely to create a table with such a generic name as
Table1.  So, I am setting importance two levels below the default,
giving Trivial.

At a guess, I am setting O/S = All.
Comment 1 m.a.riosv 2017-05-06 23:17:28 UTC
Reproducible.
Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: es-ES (es_ES); Calc: group
Comment 2 Robert Großkopf 2017-05-07 10:36:25 UTC
Have tested with older versions. It's the same with LO 4.4 and also with LO 3.6.7.2. Could be inherited by OOo.

My system: OpenSUSE 42.1 64bit rpm Linux.
Comment 3 QA Administrators 2018-05-08 02:32:57 UTC Comment hidden (obsolete)
Comment 4 Terrence Enger 2018-05-08 03:39:54 UTC
I still see the same problem in daily Linux dbgutil bibisect
repository version 2018-05-07 running on debian-buster.
Comment 5 QA Administrators 2019-05-09 03:02:26 UTC Comment hidden (obsolete)
Comment 6 Terrence Enger 2019-05-14 19:15:23 UTC
I still see the bug in 64-6.3 bibisect repository from 2019-05-13,
commit 630db80d.
Comment 7 QA Administrators 2021-05-14 04:09:22 UTC Comment hidden (obsolete)
Comment 8 Terrence Enger 2021-06-19 23:05:50 UTC
I still see the problem in a local build of commit d95e400b
(2021-06-18), built and running on debian-buster.

However, after I created Table3, the title bar for the next table
creation again named Table1.