Bug 107666 - EDITING: No caret outside the textbox after inserting a textbox
Summary: EDITING: No caret outside the textbox after inserting a textbox
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0 target:5.4.0.1 target:5.3.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-05-06 20:54 UTC by Telesto
Modified: 2017-07-11 17:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
details of bibisect (1.78 KB, text/plain)
2017-05-12 04:18 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-05-06 20:54:12 UTC
Description:
The caret (text cursor) outside the textbox disappears after inserting a textbox. 

Steps to Reproduce:
1. Open Writer
2. Create a few empty paragraphs (Enter)
3. Insert a textbox (Insert -> Textbox) somewhat below the empty paragraphs
4. Type something into the textbox
5. Click a the beginning of the page 

Actual Results:  
No text cursor (caret)

Expected Results:
Should see a text cursor


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha1+
Build ID: 274ecb49b70b3f01d47546e3b44317946c106042
CPU threads: 4; OS: Windows 6.2; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-05_22:45:07
Locale: nl-BE (nl_NL); Calc: single

but not in
Version: 5.4.0.0.alpha0+ (x64)
Build ID: eefe13c77d01be37c911e75af191717a944fedb3
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-04-10_23:47:07
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 riesslibo 2017-05-07 12:27:43 UTC
Confirmation for

Version: 5.4.0.0.alpha1+
Build-ID: 2b1737f648024328390bf44c4f2c614e748a92fd
CPU-Threads: 2; Betriebssystem:Windows 6.1; UI-Render: Standard; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-07_02:29:33
Gebietsschema: de-DE (de_DE); Calc: group

Its reproducable, curios, after inserting the textbox and writing in it
clicking outside there is no more flshing textcursor visible, even if you
click anywhere, change the modus insert/overwrite and so on.
Saving, Closing, Reopening brings it back, but after clicking in the textbox writing and clicking anywhere outside the textbox its gone again.

Thanks Telesto :-)
Comment 2 Terrence Enger 2017-05-12 04:18:39 UTC
Created attachment 133254 [details]
details of bibisect

Working in the daily Linux dbgutil bibisect repository on
debian-stretch, I have narrowed the introduction of this bug to the
121 commits:

          commit    date        s-h
          --------  ----------  --------
    good  b8d9ccca  2017-04-28  74ccd02e
    bad   6a8c9e95  2017-04-29  eea79562

I am removing keyword bibisectRequest and adding bibisected.
Comment 3 Telesto 2017-06-12 15:48:54 UTC
Adding Xisco

Still repro with:
Version: 5.5.0.0.alpha0+
Build ID: 076ed447f694239d5c67adee528ea6e471d909ff
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-09_23:54:20
Locale: nl-NL (nl_NL); Calc: CL

Should probably be fixed before 5.4 final
Comment 4 Xisco Faulí 2017-06-18 14:12:25 UTC
Regression introduced by:

author	Tamás Zolnai <tamas.zolnai@collabora.com>	2017-04-28 20:16:27 (GMT)
committer	Tamás Zolnai <tamas.zolnai@collabora.com>	2017-04-28 22:39:09 (GMT)
commit	44555103217df34b218787f3dc6a2634b41fe52e (patch)
tree	52c759ac82ffcf3978daf79e9a14a7074012dd0a
parent	38d9919432898c114d38022c2eb0d9fa9fea948c (diff)
tdf#107505: Impress - crash with two people co-editing one slide

Bisected with bibisect-linux-64-5.4

Adding Cc: to Tamás Zolnai
Comment 5 Commit Notification 2017-06-18 18:51:07 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5a89f96012c7776f23a2a81f8542e046d29c2a2b

tdf#107666: EDITING: No caret outside the textbox after inserting a textbox

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-06-18 18:52:39 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a6c80dcb93a73d8d56122dab5030ed7eec17c109&h=libreoffice-5-4

tdf#107666: EDITING: No caret outside the textbox after inserting a textbox

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Tamás Zolnai 2017-06-18 18:54:15 UTC
Thanks for the bug report.

I revert the problematic commit. I will find a better way to fix the issue what that commit was intended to fix.
Comment 8 Commit Notification 2017-07-11 14:09:06 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=06ff6c388da642ed3d7b6bcae98c2e975a30200c&h=libreoffice-5-3

tdf#107666: EDITING: No caret outside the textbox after inserting a textbox

It will be available in 5.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.