Download it now!
Bug 107670 - Navigator doesn't allow to delete elements
Summary: Navigator doesn't allow to delete elements
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 128624 (view as bug list)
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2017-05-07 07:53 UTC by Marco A.G.Pinto
Modified: 2020-04-20 06:34 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco A.G.Pinto 2017-05-07 07:53:06 UTC
Hello!

The other day I was using Word 2016 to work in the second volume of my PhD thesis.

I was adding 1500 pages per scenario.

Then, after talking with Áron Budea, I reached the conclusion that it was unpracticable.

So, I decided to remove the 1500 pages for each scenario and use a simplified way.

I was deleting 1500 pages by hand and it was taking a lot of time.

Then, in M$'s navigator I tried to right-click in the topic and noticed there was a DELETE option.

I Pressed delete and it deleted the 1500 pages (bound to topic).

I have just tried it with LO 5.3 and there is no such facility.

Could it be implemented?

Thanks!
Comment 1 Cor Nouws 2017-05-07 08:00:26 UTC
Hi Marco,

thanks for the report.

What ate 'topics' for you? You mean chapters, or also other elements (frames, tables, images, ..) ?
And what about Calc, Impress?

Set to new - more discussion needed.
Comment 2 Marco A.G.Pinto 2017-05-07 08:16:22 UTC
With topics I meant chapters and subchapters.

I had several subchapters with 1500 pages of data each.

In M$ Word 2016 I just right-clicked in the navigator and selected "delete".
Comment 3 Heiko Tietze 2017-05-07 08:42:51 UTC
(In reply to Cor Nouws from comment #1)
> What are 'topics' for you? You mean chapters, or also other elements
> (frames, tables, images, ..) ?

Default actions should always be available in context menus and just disabled in case it's not possible to execute. Don't know we should forbid to delete tables via the Navigator, for instance.
Comment 4 Heiko Tietze 2020-01-06 13:54:01 UTC
*** Bug 128624 has been marked as a duplicate of this bug. ***
Comment 5 Roman Kuznetsov 2020-02-02 18:02:00 UTC
In writer we have delete item in Navigator's context menu for all objects.

I think we can close it as FIXED by Jim Raykowski =)

https://gerrit.libreoffice.org/c/core/+/87053
Comment 6 Roman Kuznetsov 2020-02-02 18:03:06 UTC
it's possibly in current master

Версия: 7.0.0.0.alpha0+ (x64)
ID сборки: e8ac78d3afdeb0302eaea34a50f1ca912d5fe897
Потоков ЦП: 4; ОС:Windows 10.0 Build 17763; Отрисовка ИП: Skia/Vulkan; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 7 Dieter 2020-03-29 15:03:04 UTC
Tested with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 41177730421f9be9ad955766a5a19667d8003b11
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Result:

I can delete
Headings
Tables
Frames
Images
OLE Objects
Bookmarks
Hyperlinks
Indexes
Comments
Drawing Objects (shapes)


I can‘t delete
Sections
References

Is this the expected behaviour? Regarding to comment 3 I expect that it is possible to delete all elements.

cc: Jim Raykowski
Comment 8 Jim Raykowski 2020-04-20 01:36:14 UTC
see https://bugs.documentfoundation.org/show_bug.cgi?id=42787#c7 for Section delete. 

Can't remember why I didn't add References delete. Most likely it was along the lines of why Section delete wasn't added.
Comment 9 Dieter 2020-04-20 06:34:42 UTC
(In reply to Jim Raykowski from comment #8)
> Can't remember why I didn't add References delete. Most likely it was along
> the lines of why Section delete wasn't added.

Shall I open a new bug report for deleting references?