Download it now!
Bug 107680 - UI: There is a in-transparent grid instead of line in the table borders line arrangement preview with OpenGL enabled
Summary: UI: There is a in-transparent grid instead of line in the table borders line ...
Status: RESOLVED DUPLICATE of bug 102960
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Table-Properties-Dialog
  Show dependency treegraph
 
Reported: 2017-05-07 12:59 UTC by Telesto
Modified: 2019-04-03 13:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (8.96 KB, application/3dr)
2017-05-07 12:59 UTC, Telesto
Details
Screenshot (24.16 KB, image/jpeg)
2017-05-07 13:00 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-05-07 12:59:14 UTC
Description:
The selected border line in the preview of the table properties -> Table tab is hidden by some sort of grid when OpenGL is enabled

Steps to Reproduce:
1. Open the attached file 
2. Select the top row (blue border)
3. Right click -> Table Properties
4. Go to tab borders
5. Click on some borders (compare with non-OpenGL)

Actual Results:  
The appearance of the line after first click doesn't change (because of the grid)

Expected Results:
Same look as without OpenGL


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.alpha1+
Build ID: 274ecb49b70b3f01d47546e3b44317946c106042
CPU threads: 4; OS: Windows 6.2; UI render: GL; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-05_22:45:07
Locale: nl-BE (nl_NL); Calc: single


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-05-07 12:59:30 UTC
Created attachment 133124 [details]
Example file
Comment 2 Telesto 2017-05-07 13:00:35 UTC
Created attachment 133125 [details]
Screenshot
Comment 3 m.a.riosv 2017-05-07 15:51:28 UTC
Reproducible, openGL enable.

OpenGL_device.log
DriverVersion: 21.20.16.4550
DriverDate: 11-11-2016
DeviceID: PCI\VEN_8086&DEV_5916&SUBSYS_380117AA&REV_02
AdapterVendorID: 0x8086
AdapterDeviceID: 0x5916
AdapterSubsysID: 0x380117aa
DeviceKey: System\CurrentControlSet\Control\Video\{C71DB88B-86B9-48BC-A7B2-988713DD34A4}\0000
DeviceString: Intel(R) HD Graphics 620

Please can you attach you OpenGL_device.log, it is on the 'cache' folder of LibreOffice installation.
Comment 4 QA Administrators 2018-05-08 02:32:11 UTC Comment hidden (obsolete)
Comment 5 Miklos Vajna 2019-04-03 13:48:20 UTC
I can't reproduce this one on master, but reverse-bisecting points out 1e533f69f0c3a9a2136ea5d46b884145703ad637 (tdf#102960 vcl opengl: fix missing support for polygon track frames, 2018-06-27) fixed this.

*** This bug has been marked as a duplicate of bug 102960 ***