Bug 107691 - MAILMERGE: Window becomes unresponsible when sending mail to address from empty row
Summary: MAILMERGE: Window becomes unresponsible when sending mail to address from emp...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2017-05-07 22:10 UTC by Gabor Kelemen
Modified: 2018-05-03 15:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test mail merge file (10.34 KB, application/vnd.oasis.opendocument.text)
2017-05-07 22:10 UTC, Gabor Kelemen
Details
Test mail merge data source (9.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-05-07 22:11 UTC, Gabor Kelemen
Details
Screenshot of the window and terminal after sending the mails (209.30 KB, image/png)
2017-05-07 22:12 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-05-07 22:10:33 UTC
Created attachment 133144 [details]
Test mail merge file

Attached an example document and address source.
The address source file has an empty row before valid data, including column headers.

When I try to send e-mails the e-mail window closes and becomes unresponsive, I need to kill LO from the process manager.

Terminal output is the following:

gabor@dome:~/src/core$ warn:vcl.layout:4123:1:vcl/source/window/builder.cxx:520: No default button defined in modules/swriter/ui/mmcreatingdialog.ui
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:4123:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:vcl.layout:4123:1:vcl/source/window/builder.cxx:520: No default button defined in modules/swriter/ui/mmsendmails.ui
warn:sfx.view:4123:1:sfx2/source/view/viewfrm.cxx:2947: SID_SIDEBAR state requested, but no task pane child window exists for this ID!
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
warn:sfx.doc:4123:1:sfx2/source/doc/docfile.cxx:682: Physical name not convertible!
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
warn:sfx.doc:4123:1:sfx2/source/doc/docfile.cxx:682: Physical name not convertible!
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
warn:sfx.doc:4123:1:sfx2/source/doc/docfile.cxx:682: Physical name not convertible!
Comment 1 Gabor Kelemen 2017-05-07 22:11:20 UTC
Created attachment 133145 [details]
Test mail merge data source
Comment 2 Gabor Kelemen 2017-05-07 22:12:00 UTC
Created attachment 133146 [details]
Screenshot of the window and terminal after sending the mails
Comment 3 Gabor Kelemen 2017-05-07 22:13:20 UTC
Also in my mailbox one new sent e-mail appears with the following content:

Bcc: kelemeng@ubuntu.com
Return-Path: <kelemeng@openscope.org>
Received: from [127.0.1.1] (catv-80-99-96-240.catv.broadband.hu. [80.99.96.240])
        by smtp.gmail.com with ESMTPSA id l1sm15197827wrl.15.2017.05.07.14.38.51
        for <kelemeng@ubuntu.com>
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Sun, 07 May 2017 14:38:51 -0700 (PDT)
Message-ID: <590f93eb.41a0df0a.5c51a.5586@mx.google.com>
Date: Sun, 07 May 2017 14:38:51 -0700 (PDT)
Sender: "Kelemen, Gabor" <kelemeng@openscope.org>
From: kelemeng@ubuntu.com

quit
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Subject: Test
From: =?utf-8?q?Kelemen_Gabor?= <kelemeng@ubuntu.com>
To: kelemeng@ubuntu.com
X-Mailer: LibreOfficeDev 5.4 via Caolan's mailmerge component
Date: Sun, 07 May 2017 23:38:51 +0200

=EF=BB=BFThis is a sample mail merge document for: Gabor

Your e-mail address is: kelemeng@ubuntu.com

But you should not get this mail in any case  :).
Comment 4 Aron Budea 2018-03-16 00:03:06 UTC
To clarify what the expected behavior is, the empty row should be simply disregarded, right?
Comment 5 Xisco Faulí 2018-05-02 10:27:08 UTC
(In reply to Aron Budea from comment #4)
> To clarify what the expected behavior is, the empty row should be simply
> disregarded, right?

Hi Gabor,
Could you please help Aron here?
Setting to NEEDINFO until the info has been provided...
Comment 6 Gabor Kelemen 2018-05-02 12:07:07 UTC
(In reply to Aron Budea from comment #4)
> To clarify what the expected behavior is, the empty row should be simply
> disregarded, right?

Sure, it makes no sense to generate a merged document or mail with all empty data.
Some users have a tendency to fill data source tables with a few empty rows at the beginning - they find it more beautiful.
Nevertheless, we should not freeze even in such a situation.
Comment 7 Gabor Kelemen 2018-05-03 15:13:36 UTC
After a bit of retesting, I'm unable to reproduce this.
Mails are sent to the valid addresses and the empty row is ignored correctly on master.