Download it now!
Bug 107759 - CRASH: LibreO crashes while undoing an action on a table
Summary: CRASH: LibreO crashes while undoing an action on a table
Status: RESOLVED DUPLICATE of bug 107568
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2017-05-10 18:55 UTC by Xisco Faulí
Modified: 2017-05-13 00:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (39.87 KB, text/x-log)
2017-05-10 18:59 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-05-10 18:55:17 UTC
Steps:
Steps:
1. Open attachment 126127 [details] from bug 100813
2. Open the navigator ( press F5 )
3. Go to table 8
4. Insert a column on the right
5. Undo

CRASH!

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 597a2f5d5bd37443262b0775b8439bc3502aef1b
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: es-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-05-10 18:59:54 UTC
Created attachment 133223 [details]
backtrace
Comment 2 Per 2017-05-11 10:20:47 UTC
tested on Version: 5.3.2.2 (x64)
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
win7 AMD hardware.
No crash (tried 3 times - all ok)
Comment 3 Xisco Faulí 2017-05-11 13:34:12 UTC
Forgot to mention I can also reproduce it in

Version: 5.3.3.2
Build ID: 1:5.3.3~rc2-0ubuntu0.16.10.1~lo0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: es-ES (ca_ES.UTF-8); Calc: group
Comment 4 raal 2017-05-12 16:08:54 UTC
I can confirm with Version: 5.4.0.0.alpha1+
Build ID: 8da106529e85981ce37fbbd18160023c26cc7129
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-07_23:02:43
Comment 5 Timur 2017-05-12 17:49:31 UTC
Insert column in table 8 reproduced also with 5.1.6 in Linux. 

Also tested with 5.4.0.0.alpha0+ Build ID: 74ccd02eda2d6325a27266fd935aba29b3d75020 TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2017-04-28
First, I had crash immediately on F5. I got crash report but without path. Why? Is crash report broken?  

On reopen, no crash on F5, but I couldn't get crash on Insert column right in table 8 (and repeated insert). But I had crash on second undo. So yes, bug.
Comment 6 Xisco Faulí 2017-05-13 00:22:23 UTC
Fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6785b99a3f7e7531c8ef7ed16402cc4e02c9750 which is the fix for bug 107568 as both bugs share the same root cause.

Tested in

Version: 5.4.0.0.alpha1+
Build ID: 2e399f32e7505bdcf855112d8a48ae0edefe5bbc
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: fo-FO (ca_ES.UTF-8); Calc: group

Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 107568 ***