Bug 107764 - Menu bar (File, Edit, View,...) missing with OpenGL rendering enabled on Intel(R) HD Graphics in Windows (workaround: disable OpenGL; fix: update Intel graphics drivers--a known good version is 21.20.16.4727)
Summary: Menu bar (File, Edit, View,...) missing with OpenGL rendering enabled on Inte...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 101961 108331 108407 108883 109108 111367 111947 111954 112363 112527 112777 113045 113109 113454 113612 113614 113616 114128 114202 115779 115915 119535 (view as bug list)
Depends on:
Blocks: Main-Menu VCL-OpenGL
  Show dependency treegraph
 
Reported: 2017-05-11 08:04 UTC by Josué Mouco
Modified: 2018-09-23 13:29 UTC (History)
39 users (show)

See Also:
Crash report or crash signature:


Attachments
Printscreen (79.88 KB, image/png)
2017-05-11 08:07 UTC, Josué Mouco
Details
LO opengl (23.58 KB, image/png)
2017-07-14 19:29 UTC, Corey Sparks
Details
No menu bars (269.74 KB, image/png)
2017-10-03 17:52 UTC, Michael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josué Mouco 2017-05-11 08:04:49 UTC
Description:
Hi,
We have differents models of Lenovo machines. On one of them (Lenovo ThinkPad T470s), the menu bar with File, Edit, View, etc... is completely missing in LibreOffice Writer, Calc, etc...

Steps to Reproduce:
1.Install LibreOffice on a Lenovo T470s with Windows 10 Creators Update, version 1703
2.Open Writer
3.

Actual Results:  
The menu bar is missing: File, Edit, View, etc

Expected Results:
The menu bar with File, Edit, View, etc


Reproducible: Always

User Profile Reset: Tested on differents T470s.

Additional Info:
Video card: Intel HD Graphics 620
Driver version: 21.20.16.4639
Machine type: Lenovo ThinkPad T470s 20HG


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36
Comment 1 Josué Mouco 2017-05-11 08:07:50 UTC
Created attachment 133230 [details]
Printscreen
Comment 2 Regina Henschel 2017-05-11 10:04:36 UTC Comment hidden (obsolete)
Comment 3 Josué Mouco 2017-05-11 10:41:19 UTC
Virgin user profile generated > bug still present.

The bug is not linked to a bad user profile. We tested that on several different NEW machines, different NEW user profiles.
Comment 4 Regina Henschel 2017-05-11 13:46:58 UTC
I cannot reproduce the error. So we need to find out, what is different in your environment.

Do you have any customized steps in the installation process?

Do you make a simple local installation or are server and network involved?

Had the computers, which work, a different version of LibreOffice installed before you have switched to version 5.3.3?

Do you have enabled "experimental features" and tried to use the notebookbar?

There exists a new command .uno:Menubar to switch the menubar on and off. You can add it to the standard toolbar. The usual behavior is, that on restart of LibreOffice the menubar is always "on". The feature to turn menubar "off" belongs to the "tabbed" kind of the notebookbar.
Comment 5 Josué Mouco 2017-05-12 06:28:54 UTC
This is the command line I use to install LibreOffice on all of our machines:
msiexec.exe /i "LibreOffice_5.3.2_Win_x64.msi" ALLUSERS=1 /qb /norestart ADDLOCAL=ALL AgreeToLicense=Yes CREATEDESKTOPLINK=0 REMOVE=gm_o_Onlineupdate QuickStart=0 RebootYesNo=No

The installation source files are on a server, we install it during a MDT task sequence, we also capture a golden image and deploy it to all of our computers. No previous version of LibreOffice was on the golden image.

The same golden image has been deployed to different Lenovo models. Only T470s have the problem.

We don't use experimental features.

Thanks for your help,
Comment 6 Regina Henschel 2017-05-12 07:01:44 UTC
Does your Lenovo T470s has the special "Microsoft Windows 10 Pro Signature Edition"?
Comment 7 Josué Mouco 2017-05-12 07:10:58 UTC
I don't know Microsoft Windows 10 Pro Signature Edition. We use Windows 10 Enterprise x64.

I've just updated LibreOffice 5.3.2 to 5.3.3 and have the same behaviour.
Comment 8 Regina Henschel 2017-05-12 07:24:34 UTC
I'll bring the problem to the developer mailing list. You might get a quicker response via IRC. Usually it would be irc://irc.freenode.net/#libreoffice. But your problem is special, so perhaps try on irc://irc.freenode.net/#libreoffice-dev
Comment 9 Josué Mouco 2017-05-12 07:29:58 UTC
Thank you!
Comment 10 Thorsten Behrens (CIB) 2017-05-12 09:13:00 UTC
Smells a bit like an opengl rendering issue again - can you try the steps listed here to disable it: https://wiki.documentfoundation.org/OpenGL ?

(registry fragment to unconditionally kill it is here: https://bugs.documentfoundation.org/attachment.cgi?id=118060 )
Comment 11 Josué Mouco 2017-05-12 09:33:15 UTC
Disabling OpenGL fix the problem.
Comment 12 Regina Henschel 2017-05-12 11:31:34 UTC
Nice to hear, that it solves the problem for you.

I add this issue to the bug tracker for improvements in regard to OpenGL.
Comment 13 Buovjaga 2017-05-12 18:05:03 UTC
Josué: please open this file in Notepad and copy and paste the contents here: C:\Users\User\AppData\Roaming\LibreOffice\4\cache\opengl_device.log
Comment 14 Josué Mouco 2017-05-15 05:57:15 UTC
DriverVersion: 21.20.16.4639
DriverDate: 3-22-2017
DeviceID: PCI\VEN_8086&DEV_5916&SUBSYS_224B17AA&REV_02
AdapterVendorID: 0x8086
AdapterDeviceID: 0x5916
AdapterSubsysID: 0x224b17aa
DeviceKey: System\CurrentControlSet\Control\Video\{F5488970-3A89-4E8A-92A0-B0D325AF24ED}\0000
DeviceString: Intel(R) HD Graphics 620
Comment 15 Buovjaga 2017-05-15 06:05:38 UTC
(In reply to Josué Mouco from comment #14)
> DeviceString: Intel(R) HD Graphics 620

Miguel: you have this same graphics device - are you seeing any such problem?
I noticed in https://bugs.documentfoundation.org/show_bug.cgi?id=107680#c3 that you have an older driver version compared to Josué's. Maybe the newer driver has more problems?
Comment 16 m.a.riosv 2017-05-15 14:05:21 UTC
I have not seen such issue.

opengl_device.log
DriverVersion: 21.20.16.4550
DriverDate: 11-11-2016
DeviceID: PCI\VEN_8086&DEV_5916&SUBSYS_380117AA&REV_02
AdapterVendorID: 0x8086
AdapterDeviceID: 0x5916
AdapterSubsysID: 0x380117aa
DeviceKey: System\CurrentControlSet\Control\Video\{69E1F09C-1BFD-42A9-BAAF-40C942FA2092}\0000
DeviceString: Intel(R) HD Graphics 620

I have the driver updated from Lenovo, updated again now with a Lenovo update of 2017-03-24, other things are updated but not the driver, I can remember when I try to use the drivers provided by Intel directly, there was some troubles, so I came back.
Comment 17 Josué Mouco 2017-05-16 06:05:30 UTC
We use video driver from Lenovo as well, and not from Intel directly.
Comment 18 Marcel Berteler 2017-05-22 08:51:45 UTC
Is this the same issue as described in this post: https://ask.libreoffice.org/en/question/90910/writer-displays-no-text/

I experienced the above (menus showing no text, only _) when installing 5.3.3 on a win7 laptop. Changing / deleting profiles made no difference and reverting back to  5.2.7 fixed the problem.
Comment 19 Josué Mouco 2017-05-22 08:52:51 UTC
(In reply to Marcel Berteler from comment #18)
> Is this the same issue as described in this post:
> https://ask.libreoffice.org/en/question/90910/writer-displays-no-text/
> 
> I experienced the above (menus showing no text, only _) when installing
> 5.3.3 on a win7 laptop. Changing / deleting profiles made no difference and
> reverting back to  5.2.7 fixed the problem.

No, not the same.
Comment 20 Marcel Berteler 2017-05-22 08:55:51 UTC
If this is not the same, is there an existing open issue for this behaviour (as I could not find one)
Comment 21 Aron Budea 2017-05-22 12:01:08 UTC
(In reply to Marcel Berteler from comment #20)
> If this is not the same, is there an existing open issue for this behaviour
> (as I could not find one)

Yes, there's bug 107166.
Comment 22 Thorsten Behrens (CIB) 2017-05-28 23:26:30 UTC
Let's call this confirmed - see e.g. german users list https://listarchives.libreoffice.org/de/users/msg17940.html

"Laptop with Win10Pro64, release 1703, display resolution 1920 x 1080"
Comment 23 Franklin Schiftan 2017-05-30 04:59:10 UTC
Additional zu Comment 22:

The PC (Laptop) is a very new one and has an Intel HD Graphics 630 with newest driver *.4664
Comment 24 Timur 2017-05-30 08:25:20 UTC
From the discussion I add "with OpenGL" and "on Intel(R) HD Graphics" to the title. This should be updated and kept most specific.
What I didn't understand is how this appeared with 5.3. Because OpenGL is on by default from before. 
You may get http://tdf.io/siguiexe to easily get and run "parallel" LO in Windows (extract without installation) in order to test different LO versions.
Comment 25 Franklin Schiftan 2017-05-30 10:13:28 UTC
In earlier Versions of LibO I didn't had this new Laptop with this new Graphic Device ... ;-)
But the same fault behavior I see on this new machine with the newest Dev 5.4.0.0 beta, AND also with V 5.1.6.2.
With V 5.0.6.2 I see NOT this behavior - BUT in this version OpenGL was NOT checked for default! If I manually check OpenGL, from the next LibO-Start I see only a black screen with no contents.
Comment 26 darioforacappa 2017-05-31 11:18:31 UTC
I have the same problem. Since 5.3.2. I installe 5.4 beta 1 but there is the same problem
this is the opengl_device.log

DriverVersion: 8.15.10.2900
DriverDate: 11-26-2012
DeviceID: PCI\VEN_8086&DEV_0046&SUBSYS_144A103C&REV_02
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0046
AdapterSubsysID: 0x144a103c
DeviceKey: System\CurrentControlSet\Control\Video\{29648CAB-E0FC-4AEB-9035-52540B87DA5A}\0000
DeviceString: Intel(R) HD Graphics
Comment 27 Regina Henschel 2017-06-05 11:12:22 UTC
*** Bug 108331 has been marked as a duplicate of this bug. ***
Comment 28 Franklin Schiftan 2017-06-06 21:02:37 UTC
The same fault behavior exists with the newest fresh released Intel Graphics Driver *.4678 (and OpenGL in LibO activated).
Comment 29 Regina Henschel 2017-06-08 10:43:55 UTC
*** Bug 108407 has been marked as a duplicate of this bug. ***
Comment 30 darioforacappa 2017-06-09 11:37:26 UTC
I tried the version 5.4.0 beta2, same behavior
Comment 31 PJC123 2017-06-13 17:31:44 UTC
I just received a brand new Lenovo T470 laptop and I am having the same issue.  I have the latest version of Windows installed (Windows Pro 1703, Build 15063.332), I have updated the BIOS and drivers from Lenovo to the most current, and I have the latest version of LibreOffice Still installed (5.2.7).

If you need any log files, just let me know.
Comment 32 m.a.riosv 2017-06-13 18:08:54 UTC
(In reply to PJC123 from comment #31)
> .........
Please take a look to comment#10
Comment 33 PJC123 2017-06-15 16:13:16 UTC
(In reply to m.a.riosv from comment #32)
> (In reply to PJC123 from comment #31)
> > .........
> Please take a look to comment#10

OpenGL Extensions Viewer 5.0.1 Report:

Renderer: Intel(R) HD Graphics 620
Vendor: Intel
Memory: 1024 MB
Version: 4.4.0 - Build 21.20.16.4639
Shading language version: 4.40 - Build 21.20.16.4639


Vulkan report:

Intel HD Graphics 620
API Version = 4194304
Driver Version = 65539
Vendor ID = 8086h
Device ID = 5916h
Device Type = INTEGRATED_GPU
Memory = 1770 MB

Driver Info:
HD Graphics 620
Driver Provider = Intel
Driver Date = 03-22-2017
Driver Version = 21.20.16.4639

Display Info:
Display = 1920 X 1080 32 bpp (60 Hz)

Other:
Video BIOS Version: 1046 PC 14.34 07/21/2016 23:19:17
Device ID = 8086 5916 - 17AA 2245

Operating System Info:
Windows 10 Pro 64 bit, Version 1703, OS Build 15063.413

Laptop Model = Lenovo T470
RAM = 4 GB
CPU = Intel Core i5-7300U
Comment 34 PJC123 2017-06-15 18:05:18 UTC
I was looking through the duplicate bug reports and tried the temporary fix that someone posted and it indeed works.  Here are the exact steps:

1) Open LibreOffice.
2) Press Alt+F12.
3) Go to LibreOffice > View.
4) NOTE: The mouse will not work for this.  TAB to "Use OpenGL for all rendering" and unselect it by using the spacebar.
5) Click OK and then exit LibreOffice.
6) Reboot the computer.
Comment 35 V Stuart Foote 2017-07-01 18:56:11 UTC
*** Bug 108883 has been marked as a duplicate of this bug. ***
Comment 36 V Stuart Foote 2017-07-14 14:29:39 UTC
Need to determine if Tomaž patch for bug 107166 has helpful effect here as well.

Could folks affected please retest with current master.

http://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/

=-ref-=
https://gerrit.libreoffice.org/39901

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0686abc10aa729c8768b06249dbf7e57f4e56ae5
Comment 37 Xisco Faulí 2017-07-14 14:38:47 UTC
*** Bug 109108 has been marked as a duplicate of this bug. ***
Comment 38 Franklin Schiftan 2017-07-14 15:18:12 UTC
No, it doesn't help, with libo-master64~2017-07-14_02.04.48_LibreOfficeDev_6.0.0.0.alpha0_Win_x64 it's still the same.   :-(
Comment 39 Corey Sparks 2017-07-14 17:43:25 UTC
I had this issue as well on a lenovo p51s. The suggestion in comment in comment 34 by pjc123, turning off OpenGL rendering worked for me
Comment 40 V Stuart Foote 2017-07-14 18:10:08 UTC
(In reply to Corey Sparks from comment #39)
> I had this issue as well on a lenovo p51s. The suggestion in comment in
> comment 34 by pjc123, turning off OpenGL rendering worked for me

@Corey, could you post your GPU details. Should be with your LibreOffice user profile in C:\<username>\AppData\roaming\LibreOffice\4\cache need the

opengl_device.log

Alternatively, run msinof32.exe and post the top of the summary and the top of the Components/Display panel.
Comment 41 Corey Sparks 2017-07-14 18:27:58 UTC
Details are:
DriverVersion: 21.20.16.4664
DriverDate: 4-21-2017
DeviceID: PCI\VEN_8086&DEV_5916&SUBSYS_224817AA&REV_02
AdapterVendorID: 0x8086
AdapterDeviceID: 0x5916
AdapterSubsysID: 0x224817aa
DeviceKey: System\CurrentControlSet\Control\Video\{91137F71-5A95-44DD-8EB4-8EBBC382C695}\0000
DeviceString: Intel(R) HD Graphics 620
Comment 42 Corey Sparks 2017-07-14 18:35:12 UTC
System details are:
OS Name	Microsoft Windows 10 Enterprise
Version	10.0.15063 Build 15063
Other OS Description 	Not Available
OS Manufacturer	Microsoft Corporation
System Name	RR173526IP01
System Manufacturer	LENOVO
System Model	20HBCTO1WW
System Type	x64-based PC
System SKU	LENOVO_MT_20HB_BU_Think_FM_ThinkPad P51s
Processor	Intel(R) Core(TM) i7-7600U CPU @ 2.80GHz, 2904 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date	LENOVO N1VET31W (1.21 ), 4/19/2017
SMBIOS Version	3.0
Embedded Controller Version	1.11
BIOS Mode	UEFI
BaseBoard Manufacturer	LENOVO
BaseBoard Model	Not Available
BaseBoard Name	Base Board
Platform Role	Mobile
Secure Boot State	On
PCR7 Configuration	Elevation Required to View
Windows Directory	C:\WINDOWS
System Directory	C:\WINDOWS\system32
Boot Device	\Device\HarddiskVolume2
Locale	United States
Hardware Abstraction Layer	Version = "10.0.15063.0"


Name	NVIDIA Quadro M520
PNP Device ID	PCI\VEN_10DE&DEV_137B&SUBSYS_224817AA&REV_A2\4&36C67725&0&00E0
Adapter Type	Quadro M520, NVIDIA compatible
Adapter Description	NVIDIA Quadro M520
Adapter RAM	(2,147,483,648) bytes
Installed Drivers	C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_de351f3662db491c\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_de351f3662db491c\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_de351f3662db491c\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_de351f3662db491c\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_de351f3662db491c\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_de351f3662db491c\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_de351f3662db491c\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvlt.inf_amd64_de351f3662db491c\nvwgf2um
Driver Version	21.21.13.7719
INF File	oem72.inf (Section212 section)
Color Planes	Not Available
Color Table Entries	Not Available
Resolution	Not Available
Bits/Pixel	Not Available
Memory Address	0xEC000000-0xECFFFFFF
Memory Address	0x90000000-0x9FFFFFFF
Memory Address	0xA0000000-0xA1FFFFFF
IRQ Channel	IRQ 4294967288
Driver	c:\windows\system32\driverstore\filerepository\nvlt.inf_amd64_de351f3662db491c\nvlddmkm.sys (21.21.13.7719, 13.71 MB (14,378,544 bytes), 7/5/2017 11:51 AM)
	
Name	Intel(R) HD Graphics 620
PNP Device ID	PCI\VEN_8086&DEV_5916&SUBSYS_224817AA&REV_02\3&11583659&0&10
Adapter Type	Intel(R) HD Graphics Family, Intel Corporation compatible
Adapter Description	Intel(R) HD Graphics 620
Adapter RAM	1.00 GB (1,073,741,824 bytes)
Installed Drivers	igdumdim64,igd10iumd64,igd10iumd64,igd12umd64,igdumdim32,igd10iumd32,igd10iumd32,igd12umd32
Driver Version	21.20.16.4664
INF File	oem96.inf (iKBLD_w10_DS section)
Color Planes	Not Available
Color Table Entries	4294967296
Resolution	1920 x 1080 x 60 hertz
Bits/Pixel	32
Memory Address	0xEB000000-0xEBFFFFFF
Memory Address	0x80000000-0x8FFFFFFF
I/O Port	0x0000FEC0-0x0000FEFF
IRQ Channel	IRQ 4294967287
Driver	c:\windows\system32\driverstore\filerepository\igdlh64.inf_amd64_d4f155951a7ede94\igdkmd64.sys (21.20.16.4664, 10.56 MB (11,073,488 bytes), 7/5/2017 11:47 AM)
Comment 43 V Stuart Foote 2017-07-14 19:05:38 UTC
(In reply to Corey Sparks from comment #42)

@Corey, thanks. But could you configure OS to force LibreOffice onto the nVidia GPU and test that as well with and without LibreOffice OpenGL support enabled.

=-ref-=

https://pcsupport.lenovo.com/us/en/solutions/ht078706
https://support.lenovo.com/us/en/solutions/ht082304
Comment 44 Corey Sparks 2017-07-14 19:29:53 UTC
Created attachment 134644 [details]
LO opengl
Comment 45 Corey Sparks 2017-07-14 19:31:22 UTC
Libreoffice looks normal when I turn on Nvidia, and have opengl off in Libre. I can't seem to be able to turn opengl back on in libreoffice when nvidia is running, even though I select to use Opengl for all rendering, it stays off, enen after restart
Comment 46 V Stuart Foote 2017-07-14 20:17:51 UTC
(In reply to Corey Sparks from comment #45)
> Libreoffice looks normal when I turn on Nvidia, and have opengl off in
> Libre. I can't seem to be able to turn opengl back on in libreoffice when
> nvidia is running, even though I select to use Opengl for all rendering, it
> stays off, enen after restart

If not on the blacklist, if it stays off/won't enable--IIUC there is a self test that runs but fails for the GPU/driver combo. One of the devs may ask for the logs from the cache folder.

You could try an updated driver for the GPU, looks like Lenovo has nVidia Optimus 382.29 (22.21.13.8229) posted [1]--but the current 377.19 driver for the M520 nVidia GPU should pass the blacklist criteria [2].


=-ref-=
[1] https://download.lenovo.com/pccbbs/mobiles/n1vda19w.txt

[2] http://opengrok.libreoffice.org/xref/core/vcl/opengl/opengl_blacklist_windows.xml
Comment 47 Corey Sparks 2017-07-14 21:07:16 UTC
Yeah, when I allow black list, Libreoffice hangs and won't open at all.
Comment 48 PJC123 2017-08-29 15:29:59 UTC Comment hidden (obsolete)
Comment 49 PJC123 2017-08-31 17:02:29 UTC Comment hidden (obsolete)
Comment 50 Franklin Schiftan 2017-08-31 17:22:37 UTC
No, this issue was never fixed in no version.
Comment 51 Josué Mouco 2017-09-01 06:13:28 UTC
This bug is still active with version 5.4.1
Comment 52 tog0710@gmail.com 2017-09-13 15:19:00 UTC
Same problem for me : Dell XPS 15 9560

opengl_device.log

DriverVersion: 21.20.16.4664
DriverDate: 4-21-2017
DeviceID: PCI\VEN_8086&DEV_591B&SUBSYS_07BE1028&REV_04
AdapterVendorID: 0x8086
AdapterDeviceID: 0x591b
AdapterSubsysID: 0x07be1028
DeviceKey: System\CurrentControlSet\Control\Video\{127A9C32-46FA-4B51-B5A2-A1E0EB13B950}\0000
DeviceString: Intel(R) HD Graphics 630
Comment 53 tog0710@gmail.com 2017-09-13 17:05:11 UTC
(In reply to tog0710@gmail.com from comment #52)
> Same problem for me : Dell XPS 15 9560
> 
> opengl_device.log
> 
> DriverVersion: 21.20.16.4664
> DriverDate: 4-21-2017
> DeviceID: PCI\VEN_8086&DEV_591B&SUBSYS_07BE1028&REV_04
> AdapterVendorID: 0x8086
> AdapterDeviceID: 0x591b
> AdapterSubsysID: 0x07be1028
> DeviceKey:
> System\CurrentControlSet\Control\Video\{127A9C32-46FA-4B51-B5A2-
> A1E0EB13B950}\0000
> DeviceString: Intel(R) HD Graphics 630

When i disable opengl it works, but everything seems less optimized, a bit laggy.

For information :
i've tried an old version (5.2.7.2) same problem with opengl, and without opengl it feels more reactive.
Comment 54 Xisco Faulí 2017-09-17 09:49:04 UTC
*** Bug 112363 has been marked as a duplicate of this bug. ***
Comment 55 sbaragnaus 2017-09-18 17:51:49 UTC
I have this issue too with brand new Lenovo Thinkpad 13 (graphics drivers already updated).

Libreoffice 5.4.1.2

Workaround on comment #34 works but Libreoffice seems laggy.
Comment 56 Xisco Faulí 2017-09-26 08:36:33 UTC
*** Bug 112527 has been marked as a duplicate of this bug. ***
Comment 57 Buovjaga 2017-09-26 08:44:35 UTC
*** Bug 111954 has been marked as a duplicate of this bug. ***
Comment 58 Xisco Faulí 2017-10-01 22:29:26 UTC
*** Bug 112777 has been marked as a duplicate of this bug. ***
Comment 59 Xisco Faulí 2017-10-01 22:30:45 UTC
Increasing importance due to the number of duplicated issues
Comment 60 M. 2017-10-03 10:23:36 UTC Comment hidden (obsolete)
Comment 61 Aron Budea 2017-10-03 10:29:46 UTC
(In reply to M. from comment #60)
> Text in menues first disappeared when updating to 5.3.2.

This is a different issue, see screenshots (the menus are completely missing).
Comment 62 Michael Meeks 2017-10-03 12:44:00 UTC
Sigh - if Windows and/or the GL drivers are sufficiently bad that they
render nothing - I don't see any alternative - but; when we start in
GL mode: if the drivers have changed and/or we havn't qualified the
subsystem yet - to do some test rendering in the background and
sanity-check the result: "is there any text rendered" - for
example. Then again - this bug looks crazy: as if the font metrics are
completely bogus on this machine - the Printscreen shows no vertical
height allocated for the menu-bar at all ...

Is it possible that the problem is with the font ? what font is selected for the default App font in windows ? If you change the display font in GDI mode and
switch back to OpenGL do you see the issue still ?

Thanks !
Comment 63 Michael 2017-10-03 17:50:12 UTC
Having the same problem. 
Dell XPS - 9360 i7. 
Windows 10, display 3200x1800
libreoffice version: 5.4.1
Comment 64 Michael 2017-10-03 17:52:34 UTC
Created attachment 136741 [details]
No menu bars

Dell XPS i7 (9360)
Windows 10
resolution 3200x1800
Comment 65 Andreas 2017-10-04 16:00:19 UTC
After trying all the hints (registry entrys etc.) , without success, today  I found a temporary solution, which works - at least for my setup. 

When I switch the windows desktop theme from an Aero desktop design to a basic design, all the menus appeared instantly - even with an open libreoffice application! Switching back to what ever Aero design, the fonts dissappeared instantly. 

I have checked, if the desktop themes use a different font. But nevertheless if I use an Aero or a basic design, the font is always "Segoe UI". 

And it makes also no difference when I switch the font-size from 125 to 100 percent and vice versa. 

Here is my configuration:

# OS 
## Windows 7 64-bit professional (language: german)

# computer (laptop)
## HP EliteBook 850 G3 (Laptop)

# Graphiccard(s)
## switchable
## Intel(R) HD Graphics 520 (Driver: 20.19.15.4483 (01.07.2016))
## AMD Radeon R7 M365X (Driver: 21.19.169.768 (08.03.2017))

#opengl_device.log

DriverVersion:        20.19.15.4483
DriverDate:            7-1-2016
DeviceID:               PCI\VEN_8086&DEV_1916&SUBSYS_8079103C&REV_07
AdapterVendorID:  0x8086
AdapterDeviceID:  0x1916
AdapterSubsysID:  0x8079103c
DeviceKey:             System\CurrentControlSet\Control\Video\{8F4F89C5-7508-4451-9C33-D88A164A932B}\0000
DeviceString:          Intel(R) HD Graphics 520

#LO version
## 5.4.1.2 (x64) - but problem exists in many other LO versions I've tried in the past few months. 

With kind regards Andreas
Comment 66 Martin Hooper 2017-10-07 17:13:13 UTC
Same here.

HP Pavilion x360 with Intel HD 620 Graphics.

Workaround to disable OpenGL in the View settings of LO.
Comment 67 stievenard.david 2017-10-10 06:42:19 UTC
same problem here with an Dell xps15


# OS

windows 10 pro


# opengl_device.log

DriverVersion: 21.20.16.4664
DriverDate: 4-21-2017
DeviceID: PCI\VEN_8086&DEV_591B&SUBSYS_07BE1028&REV_04
AdapterVendorID: 0x8086
AdapterDeviceID: 0x591b
AdapterSubsysID: 0x07be1028
DeviceKey: System\CurrentControlSet\Control\Video\{66E29521-1D55-4C5C-877E-C2C0C699D5D3}\0000
DeviceString: Intel(R) HD Graphics 630


# opengl_devices.log

Device Index: 0
  Selected: false
  Device Name: GeForce GTX 1050
  Device Vendor: NVIDIA Corporation
  Device Version: OpenCL 1.2 CUDA
  Driver Version: 384.77
  Device Type: gpu 
  Device Extensions: cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_fp64 cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll cl_nv_d3d10_sharing cl_khr_d3d10_sharing cl_nv_d3d11_sharing cl_nv_copy_opts cl_nv_create_buffer
  Device OpenCL C Version: OpenCL C 1.2 
  Device Available: true
  Device Compiler Available: true
  Device Linker Available: true
  Platform Name: NVIDIA CUDA
  Platform Vendor: NVIDIA Corporation
  Platform Version: OpenCL 1.2 CUDA 9.0.106
  Platform Profile: FULL_PROFILE
  Platform Extensions: cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_fp64 cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll cl_nv_d3d10_sharing cl_khr_d3d10_sharing cl_nv_d3d11_sharing cl_nv_copy_opts cl_nv_create_buffer

Device Index: 1
  Selected: false
  Device Name: Intel(R) HD Graphics 630
  Device Vendor: Intel(R) Corporation
  Device Version: OpenCL 2.1 
  Driver Version: 21.20.16.4664
  Device Type: gpu 
  Device Extensions: cl_intel_accelerator cl_intel_advanced_motion_estimation cl_intel_d3d11_nv12_media_sharing cl_intel_driver_diagnostics cl_intel_dx9_media_sharing cl_intel_motion_estimation cl_intel_packed_yuv cl_intel_required_subgroup_size cl_intel_simultaneous_sharing cl_intel_subgroups cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_d3d10_sharing cl_khr_d3d11_sharing cl_khr_depth_images cl_khr_dx9_media_sharing cl_khr_fp16 cl_khr_fp64 cl_khr_gl_depth_images cl_khr_gl_event cl_khr_gl_msaa_sharing cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_gl_sharing cl_khr_icd cl_khr_image2d_from_buffer cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_mipmap_image cl_khr_mipmap_image_writes cl_khr_spir cl_khr_subgroups cl_khr_throttle_hints 
  Device OpenCL C Version: OpenCL C 2.0 
  Device Available: true
  Device Compiler Available: true
  Device Linker Available: true
  Platform Name: Intel(R) OpenCL
  Platform Vendor: Intel(R) Corporation
  Platform Version: OpenCL 2.1 
  Platform Profile: FULL_PROFILE
  Platform Extensions: cl_intel_dx9_media_sharing cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_d3d11_sharing cl_khr_depth_images cl_khr_dx9_media_sharing cl_khr_fp64 cl_khr_gl_sharing cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_icd cl_khr_image2d_from_buffer cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_spir

Device Index: 2
  Selected: true
  Device Name: Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz
  Device Vendor: Intel(R) Corporation
  Device Version: OpenCL 2.1 (Build 2)
  Driver Version: 6.8.0.2
  Device Type: cpu 
  Device Extensions: cl_khr_icd cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_depth_images cl_khr_3d_image_writes cl_intel_exec_by_local_thread cl_khr_spir cl_khr_dx9_media_sharing cl_intel_dx9_media_sharing cl_khr_d3d11_sharing cl_khr_gl_sharing cl_khr_fp64 cl_khr_image2d_from_buffer 
  Device OpenCL C Version: OpenCL C 2.0 
  Device Available: true
  Device Compiler Available: true
  Device Linker Available: true
  Platform Name: Intel(R) OpenCL
  Platform Vendor: Intel(R) Corporation
  Platform Version: OpenCL 2.1 
  Platform Profile: FULL_PROFILE
  Platform Extensions: cl_intel_dx9_media_sharing cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_d3d11_sharing cl_khr_depth_images cl_khr_dx9_media_sharing cl_khr_fp64 cl_khr_gl_sharing cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_icd cl_khr_image2d_from_buffer cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_spir

# libreoffice version
5.4.2.2 x64
Comment 68 V Stuart Foote 2017-10-12 04:23:47 UTC
*** Bug 113045 has been marked as a duplicate of this bug. ***
Comment 69 Telesto 2017-10-14 07:30:18 UTC Comment hidden (obsolete)
Comment 70 Franklin Schiftan 2017-10-14 07:36:54 UTC
As you can see, the earliest affected Version is 5.1.6.2
Comment 71 Telesto 2017-10-14 08:00:15 UTC
(In reply to Franklin Schiftan from comment #70)
> As you can see, the earliest affected Version is 5.1.6.2

Ah I see. Any clue if there is a version working correctly with OpenGL? Even if you have to check OpenGL manually (like you did in comment 25). It's probably a long shot, but trying doesn't hurt.

https://downloadarchive.documentfoundation.org/libreoffice/old/5.1.0.3/portable/
https://downloadarchive.documentfoundation.org/libreoffice/old/5.0.2.2/portable/
Comment 72 Mark Ziesemer 2017-10-18 15:53:12 UTC
I can confirm the same, on a Dell Precision 5520.  Like others here, I can avoid the issue by having LibreOffice run with the Nvidia graphics instead of Intel.

Why is this bug still in "NEEDINFO" status?  Anything else I can provide that hasn't already been provided by others here?  What is needed to get this to "ASSIGNED" status?  (Or "CONFIRMED", but doesn't look like that is an option here...)
Comment 73 Josué Mouco 2017-10-19 10:48:41 UTC
Problem solved for me with video driver :
Intel HD Graphics Driver for Windows 10 (64-bit) for ThinkPad T470s, version 22.20.16.4749, on Lenovo support website.
Comment 74 Buovjaga 2017-10-19 10:52:25 UTC
(In reply to Josué Mouco from comment #73)
> Problem solved for me with video driver :
> Intel HD Graphics Driver for Windows 10 (64-bit) for ThinkPad T470s, version
> 22.20.16.4749, on Lenovo support website.

Nice to hear! What about the other affected people? Does a driver update make the problem go away?
Comment 75 documentfoundation 2017-10-19 11:01:08 UTC
(In reply to Buovjaga from comment #74)
> (In reply to Josué Mouco from comment #73)
> > Problem solved for me with video driver :
> > Intel HD Graphics Driver for Windows 10 (64-bit) for ThinkPad T470s, version
> > 22.20.16.4749, on Lenovo support website.
> 
> Nice to hear! What about the other affected people? Does a driver update
> make the problem go away?

No, because there is no update for my DELL XPS 15 9560
Comment 76 Franklin Schiftan 2017-10-19 11:18:50 UTC
For me also Intel found no other driver than the installed version ....4678.
So here also the problem exists unsolved.
Comment 77 Buovjaga 2017-10-19 11:19:31 UTC
(In reply to documentfoundation from comment #75)
> No, because there is no update for my DELL XPS 15 9560

Ok, I guess we will have to wait for Dell to get off their butts and push an update.
I checked and the last release is 21.20.16.4664 from 29 Jun 2017
Comment 78 sebr 2017-10-19 11:23:35 UTC
Works for me after Intel Graphics driver update (via Device Manager -> Display adapters -> Intel(R) HD Graphics 630 - > Update Driver)

Driver Info after update:
  Intel(R) HD Graphics 630
  Date:    30/06/2017
  Version: 21.20.16.4727
Comment 79 Franklin Schiftan 2017-10-19 11:54:29 UTC
Wow, Intels software doesn't found a newer driver, but with the way sebr@ingbr.de described in comment #78 (via Device Manager -> Display adapters -> Intel(R) HD Graphics 630 - > Update Driver) the new driver 22.20.16.4785 was found and with this driver the problem is also solved for me.  :-)

Driver Info after update:
  Intel(R) HD Graphics 630
  Date:    2017-08-29
  Version: 22.20.16.4785
Comment 80 Buovjaga 2017-10-19 12:51:05 UTC
Ok, three confirmations, so no need to leave this hanging. I'll use status WFM instead of NOTOURBUG even though I was tempted..
Comment 81 Jean-Baptiste Faure 2017-10-28 06:24:13 UTC
(In reply to Buovjaga from comment #80)
> Ok, three confirmations, so no need to leave this hanging. I'll use status
> WFM instead of NOTOURBUG even though I was tempted..

Is there a mean to workaround this issue by automatically deactivating OpenGL if  the Intel driver is known bugged ? Often basic user don't [want] understand and switches to another office suite as it is the easiest solution for she.

Best regards. JBF
Comment 82 Franklin Schiftan 2017-10-28 06:38:32 UTC
I am interested to know if there are any differences one can see in working with LibO between activated or not activated OpenGL?

Because all the last time I was working with deactivated OpenGL I didn't see any difference to now with the new driver and activated OpenGL.
Comment 83 Jean-Baptiste Faure 2017-10-28 06:45:04 UTC
No commit -> nothing fixed on LO side -> the correct status is WorksForMe (or NotOurBug in this case).
Set back to WorksForMe.

Best regards. JBF
Comment 84 Buovjaga 2017-10-28 11:39:44 UTC
(In reply to Jean-Baptiste Faure from comment #81)
> Is there a mean to workaround this issue by automatically deactivating
> OpenGL if  the Intel driver is known bugged ? Often basic user don't [want]
> understand and switches to another office suite as it is the easiest
> solution for she.

LibreOffice uses a blacklist for bad drivers. Developers are of course free to pick up the bad driver version from the comments and add to the blacklist.
Comment 85 Aron Budea 2017-11-30 01:57:48 UTC
*** Bug 114128 has been marked as a duplicate of this bug. ***
Comment 86 Aron Budea 2017-11-30 02:11:52 UTC
*** Bug 113614 has been marked as a duplicate of this bug. ***
Comment 87 Aron Budea 2017-11-30 02:12:26 UTC
*** Bug 113612 has been marked as a duplicate of this bug. ***
Comment 88 Aron Budea 2017-11-30 02:14:16 UTC
*** Bug 113616 has been marked as a duplicate of this bug. ***
Comment 89 Aron Budea 2017-11-30 03:49:35 UTC
*** Bug 111947 has been marked as a duplicate of this bug. ***
Comment 90 Adam Walczak 2018-01-04 12:13:57 UTC
After a install 6.0.1 RC1 this problem still happens.
Why wasn't the driver added to the blacklist?
Comment 91 Buovjaga 2018-01-04 12:55:11 UTC
(In reply to Adam Walczak from comment #90)
> After a install 6.0.1 RC1 this problem still happens.
> Why wasn't the driver added to the blacklist?

I guess because no one cared enough. Anyone can send a patch.
Comment 92 V Stuart Foote 2018-01-04 14:47:24 UTC
(In reply to Adam Walczak from comment #90)
> After a install 6.0.1 RC1 this problem still happens.
> Why wasn't the driver added to the blacklist?

So, what GPU and driver combination are you working with? 

Please post result of msinfo32, the first 14 lines of the Summary and the first 12 lines for each GPU shown in the Components->Display panel.
Comment 93 Aron Budea 2018-02-14 17:11:31 UTC
*** Bug 111367 has been marked as a duplicate of this bug. ***
Comment 94 V Stuart Foote 2018-02-21 20:56:46 UTC
*** Bug 115915 has been marked as a duplicate of this bug. ***
Comment 95 Buovjaga 2018-03-08 10:23:37 UTC
*** Bug 115779 has been marked as a duplicate of this bug. ***
Comment 96 Xisco Faulí 2018-04-11 11:04:25 UTC
*** Bug 113454 has been marked as a duplicate of this bug. ***
Comment 97 Buovjaga 2018-05-12 08:15:04 UTC
*** Bug 114202 has been marked as a duplicate of this bug. ***
Comment 98 Xisco Faulí 2018-05-30 10:14:20 UTC
*** Bug 101961 has been marked as a duplicate of this bug. ***
Comment 99 V Stuart Foote 2018-05-30 17:07:17 UTC
*** Bug 113109 has been marked as a duplicate of this bug. ***
Comment 100 Buovjaga 2018-09-23 13:29:35 UTC
*** Bug 119535 has been marked as a duplicate of this bug. ***