Bug Hunting Session
Bug 107770 - Calc 5.3.2.2 impossibly slow on scrolling and altering column widths
Summary: Calc 5.3.2.2 impossibly slow on scrolling and altering column widths
Status: RESOLVED DUPLICATE of bug 109220
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, perf, regression
Depends on:
Blocks:
 
Reported: 2017-05-11 12:03 UTC by David Lynch
Modified: 2017-09-15 20:41 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Works well under 5.3.1.2, impossibly slow under 5.3.2.2 (216.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-05-11 12:03 UTC, David Lynch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Lynch 2017-05-11 12:03:47 UTC
Created attachment 133235 [details]
Works well under 5.3.1.2, impossibly slow under 5.3.2.2

Calc Version: 5.3.2.2 (x64)
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1

Windows 10 

is so slow as to be unusable, particularly scrolling and altering column widths (you can see the latter proceeding in jumps). It takes about 3 seconds to display a new sheet, and about 2 seconds to [page down].

I have reverted to 

Calc Version: 5.3.1.2 (x64)
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2

where the same spreadsheet behaves normally and responsively.

I have attached the spreadsheet.
Comment 1 m.a.riosv 2017-05-11 14:33:27 UTC
I have no issue with.
Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: es-ES (es_ES); Calc: group

Please what the status of OpenCL options Menu/Tools/Options/LibreOffice/OpenCL
Comment 2 David Lynch 2017-05-11 15:41:41 UTC
Please what the status of OpenCL options Menu/Tools/Options/LibreOffice/OpenCL

on Version: 5.3.1.2 (x64)
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
"Allow use of software Interpreter (even when OpenCL is not available)" is ticked
"Allow use of OpenCL" is not ticked.
and a message follows 
"OpenCL is not used."
Version: 5.3.2.2 (x64)
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
ticked
"Allow use of OpenCL" is not ticked.
and a message follows 
"OpenCL is not used."

... exactly the same.

I confirm 5.3.2.2 is still impossibly slow.
Comment 3 Telesto 2017-05-11 18:04:46 UTC
I repro it with:
Version: 5.4.0.0.alpha1+
Build ID: 9d320ec4d818f86e58a15fd46248026502b1cc94
CPU threads: 4; OS: Windows 6.2; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-09_01:27:12
Locale: en-US (nl_NL); Calc: single
Comment 4 m.a.riosv 2017-05-11 21:38:38 UTC
I can't reproduce neither with:
Version: 5.4.0.0.alpha1
Build ID: 0b9f9bef65bb21ebb6a64aafad448f7f62dc824a
CPU threads: 4; OS: Windows 6.2; UI render: GL; 
Locale: es-ES (es_ES); Calc: group

But slow without OpenGL.
Version: 5.4.0.0.alpha1
Build ID: 0b9f9bef65bb21ebb6a64aafad448f7f62dc824a
CPU threads: 4; OS: Windows 6.2; UI render: default; 
Locale: es-ES (es_ES); Calc: single

Looks to me the issue is mainly with OpenGL disable when there are a lot of cell visualizated on the window.

Please can you both test if Menu/Tools/Options/LibreOffice/View - OpenGL
makes the difference.
Comment 5 V Stuart Foote 2017-05-11 22:11:03 UTC
On Windows 10 Pro 64-bit en-US with
Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 8; OS Version: Windows 6.29; UI Render: GL; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

Confirm smooth scrolling and column width changes with OpenGL enabled.

But with Default rendering,  with or without Use hardware acceleration--the column resize is choppy and scroll bar pan/scroll jumps.
Comment 6 David Lynch 2017-05-12 08:11:53 UTC
Version: 5.3.2.2 (x64)
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-GB (en_GB); Calc: group

Column resize is choppy and scroll bar pan/scroll jumps

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

I then ticked Menu/Tools/Options/LibreOffice/OpenCL/Allow use of OpenCL and restarted Calc

Version: 5.3.2.2 (x64)
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-GB (en_GB); Calc: CL

Column resize is still choppy and scroll bar pan/scroll jumps
Comment 7 Vladimir 2017-05-17 20:06:41 UTC
I can confirm this bug. Also OpenCL/Allow does not budge.
Comment 8 tommy27 2017-05-18 05:19:58 UTC
@Vladimir and David Lynch

LibO 5.3.3.2 is out. please upgrade and retest.
Comment 9 David Lynch 2017-05-18 07:36:06 UTC
Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-GB (en_GB); Calc: group


30 seconds to action a [page-up], resetting column width is still slow and jumpy.

>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: en-GB (en_GB); Calc: group

Normal responsive behaviour ... thank you.
Comment 10 David Lynch 2017-05-20 10:22:44 UTC
Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-GB (en_GB); Calc: group

After two days' good behaviour, Calc crashed (report sent) and the non-responsive and jumpy behaviour has restarted, though not as badly as before. 

Rebooting has not helped.
Comment 11 Timur 2017-07-26 17:02:01 UTC
I can repro this also with OpenGL so I don't confirm smooth scrolling and column width changes with OpenGL enabled. This is "major".
Comment 12 Vladimir 2017-07-29 15:13:10 UTC
Rebooting has not helped. 
Safe mode not helped.

I tried 5.3.4.2 and 5.4.0.3 - still slow.

Returned to 5.2.7.2 - works fine.

I have Windows 10. All installs were x64.
Comment 13 Timur 2017-08-04 14:46:24 UTC
*** Bug 111333 has been marked as a duplicate of this bug. ***
Comment 14 Petr Skala 2017-09-14 12:18:21 UTC
Hello,

i have the same problem.
With version 5.3.1.2 and older, everything is working fine, but every above version makes Calc unusable. We tested it with every new version, but nothing was solved. We are using czech translation.

In 5.3.1.2, if we turn on OpenGL, calc is laggy, as in newer version. Could be possible, that OpenGL is turned on in newer versions and it's switching to off doesn't work?

We tested both x86 and x64 versions.

Thanks a lot.
Comment 15 raal 2017-09-15 20:41:48 UTC
Likely duplicate of bug 109220

*** This bug has been marked as a duplicate of bug 109220 ***