Bug Hunting Session
Bug 107854 - Customize window: Styles > Table Design Styles category in Add Commands empty
Summary: Customize window: Styles > Table Design Styles category in Add Commands empty
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:5.4.0
Keywords:
: 107855 (view as bug list)
Depends on:
Blocks: Table-Styles Customize-Dialog
  Show dependency treegraph
 
Reported: 2017-05-14 22:42 UTC by Thomas Lendo
Modified: 2017-05-17 20:46 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-05-14 22:42:37 UTC
In Impewaa > Tools > Customize > (Menus/Context Menus/Toolbars) > Add Command, the category "Styles > Table Design Styles" is empty.

Expected behavior:
Since no table styles are available in Impress yet I don't know what styles should be available here.
Comment 1 Thomas Lendo 2017-05-14 22:44:21 UTC
Impewaa > Impress
Comment 2 Maxim Monastirsky 2017-05-15 06:53:44 UTC
*** Bug 107855 has been marked as a duplicate of this bug. ***
Comment 3 Maxim Monastirsky 2017-05-16 12:28:42 UTC
(In reply to Thomas Lendo from comment #0)
> Expected behavior:
> Since no table styles are available in Impress yet I don't know what styles
> should be available here.
There are table styles. When you select a table, there is a "Table Design" panel in the sidebar. It shouldn't be hard to make those styles appear in the list (same approach as in Bug 107852 would work here too), but make them actually work in toolbar/menubar will require more work. So I think I'll just hide this category for now.
Comment 4 Commit Notification 2017-05-16 20:12:05 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4e52299a6aff1386151223a99e7ed3a49496d967

tdf#107853 tdf#107854 Hide useless style families

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Thomas Lendo 2017-05-17 20:46:49 UTC
Thanks, Maxim!